Bug 1011423 - AttributeError: 'NoneType' object has no attribute 'id'
AttributeError: 'NoneType' object has no attribute 'id'
Status: CLOSED DUPLICATE of bug 1004572
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:0f967c33186d3365c596860dec7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 05:03 EDT by Vít Ondruch
Modified: 2013-09-24 08:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 08:29:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.55 MB, text/plain)
2013-09-24 05:03 EDT, Vít Ondruch
no flags Details
File: anaconda.log (18.68 KB, text/plain)
2013-09-24 05:03 EDT, Vít Ondruch
no flags Details
File: environ (422 bytes, text/plain)
2013-09-24 05:03 EDT, Vít Ondruch
no flags Details
File: lsblk_output (1.80 KB, text/plain)
2013-09-24 05:03 EDT, Vít Ondruch
no flags Details
File: nmcli_dev_list (13.21 KB, text/plain)
2013-09-24 05:03 EDT, Vít Ondruch
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-24 05:03 EDT, Vít Ondruch
no flags Details
File: program.log (52.15 KB, text/plain)
2013-09-24 05:03 EDT, Vít Ondruch
no flags Details
File: storage.log (245.07 KB, text/plain)
2013-09-24 05:04 EDT, Vít Ondruch
no flags Details
File: syslog (107.34 KB, text/plain)
2013-09-24 05:04 EDT, Vít Ondruch
no flags Details
File: ifcfg.log (474 bytes, text/plain)
2013-09-24 05:04 EDT, Vít Ondruch
no flags Details
File: packaging.log (1.08 MB, text/plain)
2013-09-24 05:04 EDT, Vít Ondruch
no flags Details

  None (edit)
Description Vít Ondruch 2013-09-24 05:03:11 EDT
Version-Release number of selected component:
anaconda-20.18-1

The following was filed automatically by anaconda:
anaconda 20.18-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1948, in copy
    root.swaps = [new.devicetree.getDeviceByID(d.id) for d in root.swaps]
  File "/usr/lib/python2.7/site-packages/blivet/devicefactory.py", line 767, in _save_devicetree
    _blivet_copy = self.storage.copy()
  File "/usr/lib/python2.7/site-packages/blivet/devicefactory.py", line 704, in configure
    self._save_devicetree()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1924, in factoryDevice
    factory.configure()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2024, in on_add_clicked
    **kwargs)
AttributeError: 'NoneType' object has no attribute 'id'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/linux/development/20/x86_64/os/ initrd=F20/latest/x86_64/initrd.img BOOT_IMAGE=F20/latest/x86_64/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.1-300.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20
Comment 1 Vít Ondruch 2013-09-24 05:03:24 EDT
Created attachment 802104 [details]
File: anaconda-tb
Comment 2 Vít Ondruch 2013-09-24 05:03:29 EDT
Created attachment 802105 [details]
File: anaconda.log
Comment 3 Vít Ondruch 2013-09-24 05:03:34 EDT
Created attachment 802106 [details]
File: environ
Comment 4 Vít Ondruch 2013-09-24 05:03:38 EDT
Created attachment 802107 [details]
File: lsblk_output
Comment 5 Vít Ondruch 2013-09-24 05:03:43 EDT
Created attachment 802108 [details]
File: nmcli_dev_list
Comment 6 Vít Ondruch 2013-09-24 05:03:51 EDT
Created attachment 802109 [details]
File: os_info
Comment 7 Vít Ondruch 2013-09-24 05:03:55 EDT
Created attachment 802110 [details]
File: program.log
Comment 8 Vít Ondruch 2013-09-24 05:04:01 EDT
Created attachment 802111 [details]
File: storage.log
Comment 9 Vít Ondruch 2013-09-24 05:04:06 EDT
Created attachment 802112 [details]
File: syslog
Comment 10 Vít Ondruch 2013-09-24 05:04:11 EDT
Created attachment 802113 [details]
File: ifcfg.log
Comment 11 Vít Ondruch 2013-09-24 05:04:20 EDT
Created attachment 802114 [details]
File: packaging.log
Comment 12 David Shea 2013-09-24 08:29:10 EDT

*** This bug has been marked as a duplicate of bug 1004572 ***

Note You need to log in before you can comment on or make changes to this bug.