Bug 1011443 - packstack fails to install python-nova
packstack fails to install python-nova
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-jinja2-26 (Show other bugs)
4.0
Unspecified Unspecified
urgent Severity high
: beta
: 4.0
Assigned To: Lon Hohberger
Rami Vaknin
: AutoVerified, Reopened, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 05:53 EDT by Rami Vaknin
Modified: 2016-04-26 18:00 EDT (History)
12 users (show)

See Also:
Fixed In Version: python-jinja2-26-2.6-2.el6ost
Doc Type: Bug Fix
Doc Text:
Do not document - internal fix that prevented use by customers.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:24:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2013-09-24 05:53:24 EDT
Version:
Havana on RHEL6.4
puddle: 4.0/2013-09-23.2


Description:
Packstack fails to install OpenStack due to dependencies issue while installing "python-nova" rpm:


Applying 10.35.160.29_api_nova.pp
                                                                                            [ ERROR ]

ERROR : Error during puppet run : err: /Stage[main]/Nova/Package[python-nova]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install python-nova' returned 1: Error: Package: python-nova-2013.2-0.21.b3.el6ost.noarch (puddle)
Please check log file /var/tmp/packstack/20130924-115815-I3oJSZ/openstack-setup.log for more information


From packstack's log file
=========================

ESC[0;36mnotice: Finished catalog run in 2.72 secondsESC[0m

2013-09-24 12:02:00::ERROR::run_setup::913::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 908, in main
    _main(confFile)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 577, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 554, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: Error during puppet run : err: /Stage[main]/Nova/Package[python-nova]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install python-nova' returned 1: Error: Package: python-nova-2013.2-0.21.b3.el6ost.noarch (puddle)


Trying to install python-nova manually
======================================

# yum install python-nova
Loaded plugins: priorities, product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package python-nova.noarch 0:2013.2-0.21.b3.el6ost will be installed
--> Processing Dependency: python-pyasn1 for package: python-nova-2013.2-0.21.b3.el6ost.noarch
--> Processing Dependency: python-neutronclient for package: python-nova-2013.2-0.21.b3.el6ost.noarch
--> Processing Dependency: python-jinja2 for package: python-nova-2013.2-0.21.b3.el6ost.noarch
--> Processing Dependency: python-boto for package: python-nova-2013.2-0.21.b3.el6ost.noarch
--> Running transaction check
---> Package python-boto.noarch 0:2.5.2-1.1.el6 will be installed
---> Package python-neutronclient.noarch 0:2.2.6-1.el6ost will be installed
--> Processing Dependency: python-cliff >= 1.0 for package: python-neutronclient-2.2.6-1.el6ost.noarch
--> Processing Dependency: pyparsing for package: python-neutronclient-2.2.6-1.el6ost.noarch
---> Package python-nova.noarch 0:2013.2-0.21.b3.el6ost will be installed
--> Processing Dependency: python-jinja2 for package: python-nova-2013.2-0.21.b3.el6ost.noarch
---> Package python-pyasn1.noarch 0:0.0.12a-1.el6 will be installed
--> Running transaction check
---> Package pyparsing.noarch 0:1.5.6-1.el6 will be installed
---> Package python-cliff.noarch 0:1.4.4-1.el6ost will be installed
--> Processing Dependency: python-cmd2 for package: python-cliff-1.4.4-1.el6ost.noarch
---> Package python-nova.noarch 0:2013.2-0.21.b3.el6ost will be installed
--> Processing Dependency: python-jinja2 for package: python-nova-2013.2-0.21.b3.el6ost.noarch
--> Running transaction check
---> Package python-cmd2.noarch 0:0.6.4-6.el6ost will be installed
---> Package python-nova.noarch 0:2013.2-0.21.b3.el6ost will be installed
--> Processing Dependency: python-jinja2 for package: python-nova-2013.2-0.21.b3.el6ost.noarch
--> Finished Dependency Resolution
Error: Package: python-nova-2013.2-0.21.b3.el6ost.noarch (puddle)
           Requires: python-jinja2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@puma10 packstack]#
Comment 1 Pádraig Brady 2013-09-24 06:02:18 EDT
Please manually enable the optional repo

*** This bug has been marked as a duplicate of bug 978651 ***
Comment 6 Lon Hohberger 2013-10-01 16:27:39 EDT
Also changed nova's spec file to match the import:

openstack-nova-2013.2-0.21.b3.el6ost.1
Comment 8 Lon Hohberger 2013-10-01 18:28:34 EDT
I verified that this no longer happens with a packstack all-in-one installation using neutron networking.
Comment 9 Scott Lewis 2013-11-19 11:54:36 EST
Auto adding >= MODIFIED bugs to beta
Comment 12 Ofer Blaut 2013-11-27 16:01:42 EST
tested 

root@puma04 ~(keystone_admin)]# rpm -qa | grep python-nova
python-nova-2013.2-5.el6ost.noarch
python-novaclient-2.15.0-1.el6ost.noarch
[root@puma04 ~(keystone_admin)]# rpm -qR python-nova
/bin/bash  
MySQL-python  
openssh  
openssl  
python(abi) = 2.6
python-anyjson  
python-babel  
python-boto  
python-cheetah  
python-eventlet  
python-glanceclient >= 1:0
python-greenlet  
python-iso8601  
python-jinja2-26  
python-ldap  
python-lxml  
python-memcached  
python-migrate  
python-netaddr  
python-neutronclient  
python-novaclient  
python-oslo-config >= 1:1.2.0
python-paramiko  
python-paste-deploy1.5  
python-pyasn1  
python-qpid  
python-routes1.12  
python-six  
python-sqlalchemy0.7  
python-stevedore  
python-webob1.2  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
sudo  
rpmlib(PayloadIsXz) <= 5.2-1

root@puma04 ~(keystone_admin)]# yum provides python-jinja2-26 
Loaded plugins: priorities, product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
python-jinja2-26-2.6-2.el6ost.noarch : General purpose template engine
Repo        : RHOS-4.0
Matched from:



python-jinja2-26-2.6-2.el6ost.noarch : General purpose template engine
Repo        : installed
Matched from:
Other       : Provides-match: python-jinja2-26
Comment 15 errata-xmlrpc 2013-12-19 19:24:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.