Bug 978651 - auto enablement of the optional channel
auto enablement of the optional channel
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Magr
Toure Dunnon
:
: 1010013 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 23:01 EDT by Pádraig Brady
Modified: 2016-01-04 09:44 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.11.dev806.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-15 09:31:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 47583 None None None Never

  None (edit)
Description Pádraig Brady 2013-06-26 23:01:57 EDT
It would be cool to auto enable the "optional channel" where needed.

RDO and EPEL need the optional channel enabled when on RHEL.
Note only on RHEL proper. Centos/scientific do _not_ need/have optional.
For completeness RHOS does _not_ need optional either.
Comment 1 Pádraig Brady 2013-09-08 21:08:10 EDT
Note since users are prompted that they need to install EPEL,
and it's done automatically, they're disconnected from the associated
documentation that states that 'optional' is a requirement.
Therefore auto enabling 'optional' for RDO + RHN users is
more a necessity than a nice to have.
Comment 2 Xavier Queralt 2013-09-19 13:25:52 EDT
*** Bug 1010013 has been marked as a duplicate of this bug. ***
Comment 3 Pádraig Brady 2013-09-24 06:02:18 EDT
*** Bug 1011443 has been marked as a duplicate of this bug. ***
Comment 6 Pádraig Brady 2013-11-12 11:25:21 EST
Seems this is not fixed in the current (806) version in RDO havana on RHEL 6.5 at least:
http://openstack.redhat.com/forum/discussion/876/rdo-is-not-installing-due-to-rubygems-packages#
Comment 7 Felipe Alfaro Solana 2014-01-16 13:12:17 EST
I confirm I'm suffering from this bug too on Red Hat Enterprise Linux 6.5.
Comment 8 Martin Magr 2014-01-17 05:50:12 EST
What packstack version are you using? Do you use packstack to subscribe your hosts to subscription management?
Comment 11 Yaniv Kaul 2014-07-08 08:40:00 EDT
packstack 0:2014.1.1-0.21.dev1157.1.el6 on CentOS 6.5 suffers from it:

[root@lgdrm44 yum.repos.d]# yum -y install openstack-packstack --disablerepo=puppetlabs*
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * epel: mirror.steadfast.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package openstack-packstack.noarch 0:2014.1.1-0.21.dev1157.1.el6 will be installed
--> Processing Dependency: openstack-packstack-puppet = 2014.1.1-0.21.dev1157.1.el6 for package: openstack-packstack-2014.1.1-0.21.dev1157.1.el6.noarch
--> Processing Dependency: python-netaddr for package: openstack-packstack-2014.1.1-0.21.dev1157.1.el6.noarch
--> Processing Dependency: openstack-puppet-modules for package: openstack-packstack-2014.1.1-0.21.dev1157.1.el6.noarch
--> Running transaction check
---> Package openstack-packstack-puppet.noarch 0:2014.1.1-0.21.dev1157.1.el6 will be installed
---> Package openstack-puppet-modules.noarch 0:2014.1-15.el6 will be installed
--> Processing Dependency: rubygem-json for package: openstack-puppet-modules-2014.1-15.el6.noarch
---> Package python-netaddr.noarch 0:0.7.5-4.el6 will be installed
--> Running transaction check
---> Package rubygem-json.x86_64 0:1.4.6-1.el6 will be installed
--> Processing Dependency: rubygems for package: rubygem-json-1.4.6-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: rubygem-json-1.4.6-1.el6.x86_64 (epel)
           Requires: rubygems
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 12 Yaniv Kaul 2014-07-08 09:12:52 EDT
(In reply to Yaniv Kaul from comment #11)
> packstack 0:2014.1.1-0.21.dev1157.1.el6 on CentOS 6.5 suffers from it:

Ignore above comment - perhaps something was wrong in my channel. In a repeated test it seems to be OK.
Comment 13 Gaël Chamoulaud 2014-12-15 09:31:42 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.