Bug 1011473 - Unable to create new-product via repo-discovery, new Provider options needed along with it
Unable to create new-product via repo-discovery, new Provider options needed ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Kedar Bidarkar
Kedar Bidarkar
: Reopened, Triaged
: 1013121 1016236 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 07:24 EDT by Kedar Bidarkar
Modified: 2014-04-24 13:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:09:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New Provider link does exists (42.86 KB, image/png)
2013-10-22 08:06 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Kedar Bidarkar 2013-09-24 07:24:37 EDT
Description of problem:

Unable to create new-product via repo-discovery, new Provider options needed along with New Product option.


Version-Release number of selected component (if applicable):

nightly 

signo-katello-0.0.21-1.el6.noarch
katello-selinux-1.4.4-1.git.1.7abb02b.el6.noarch
katello-certs-tools-1.4.4-1.el6.noarch
pulp-katello-plugins-0.2-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-elasticsearch-1.4.6-1.git.246.3deb1a2.el6.noarch
katello-configure-1.4.6-1.git.1.c31ada4.el6.noarch
katello-glue-pulp-1.4.6-1.git.246.3deb1a2.el6.noarch
katello-cli-1.4.3-1.git.58.e7174b6.el6.noarch
katello-glue-candlepin-1.4.6-1.git.246.3deb1a2.el6.noarch
katello-1.4.6-1.git.246.3deb1a2.el6.noarch
katello-all-1.4.6-1.git.246.3deb1a2.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.4.3-1.git.58.e7174b6.el6.noarch
katello-common-1.4.6-1.git.246.3deb1a2.el6.noarch
katello-repos-1.4.2-1.el6.noarch



How reproducible:

Try creating a repo via repo-discovery without creating 
a product/provider.

Steps to Reproduce:
1.
2.
3.

Actual results:
Unable to create new-product via repo-discovery, without creating 
a product/provider.

Expected results:
new Provider options needed along with New Product option.


Additional info:
Not sure if this was intended, but we do reach a dead end, trying to do so.
Comment 1 RHEL Product and Program Management 2013-09-24 07:44:26 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Justin Sherrill 2013-10-04 07:52:11 EDT
Not disagreeing with the bug, but this seems really really low priority (worthy of pushing off 6.0.2 if there is no time).  It has also worked like this since mdp1.
Comment 4 Eric Helms 2013-10-07 13:03:08 EDT
https://github.com/Katello/katello/pull/3104
Comment 5 Eric Helms 2013-10-07 13:05:43 EDT
*** Bug 1013121 has been marked as a duplicate of this bug. ***
Comment 8 Kedar Bidarkar 2013-10-16 07:05:46 EDT
clicking the "New Provider" link while creating repo via repo-discovery leads to a blank page.
Comment 9 Og Maciel 2013-10-19 17:02:32 EDT

*** This bug has been marked as a duplicate of bug 1016236 ***
Comment 10 Eric Helms 2013-10-20 10:41:59 EDT
The loading screen was stuck after some changes around adding a loading screen in more places. A further addition to this bug fix re-enables the page loading. See https://github.com/Katello/katello/pull/3227
Comment 11 Mike McCune 2013-10-20 11:48:35 EDT
re-opening this bug and closing the other bug with less info
Comment 12 Mike McCune 2013-10-20 11:48:48 EDT
*** Bug 1016236 has been marked as a duplicate of this bug. ***
Comment 14 Eric Helms 2013-10-21 12:51:00 EDT
Additional fix - https://github.com/Katello/katello/pull/3227
Comment 17 Kedar Bidarkar 2013-10-22 08:06:46 EDT
Created attachment 814955 [details]
New Provider link does exists

This is verified against Satellite-6.0.2-RHEL-6-20131021.0
Comment 18 Bryan Kearney 2014-04-24 13:09:32 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 19 Bryan Kearney 2014-04-24 13:11:00 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.