Bug 101149 - Restart fails in CDT debug session
Restart fails in CDT debug session
Status: CLOSED CURRENTRELEASE
Product: Red Hat Developer Suite
Classification: Retired
Component: CDT (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
eclipse-bugs
:
: 114132 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-29 12:55 EDT by Jeremy Handcock
Modified: 2007-04-18 12:56 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 13:40:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Handcock 2003-07-29 12:55:24 EDT
Description of problem:
An error occurs upon restarting an active debug session in the CDT debugger.

Version-Release number of selected component (if applicable):
eclipse 2.1 (all variants)

How reproducible:
Always

Steps to Reproduce:
1. Start a debug session
2. Step through a bit
3. Click the "Restart" button on the debug toolbar
    

Actual Results:  Error occurs with message "The execution of program is
suspended because of error.  Details: /dev/pts/4: No such file or directory. 
You can't do that without a process to debug."

Expected Results:  Debug session should restart.

Additional info:

Should be fixed upstream as well... see
https://bugs.eclipse.org/bugs/show_bug.cgi?id=37989
Comment 1 Jeremy Handcock 2004-01-22 17:27:05 EST
*** Bug 114132 has been marked as a duplicate of this bug. ***
Comment 2 Rick Moseley 2004-11-29 13:40:02 EST
This bug has been fixed upstream and is in version 2.1 of the CDT fixed on
11/17/2004.

Note You need to log in before you can comment on or make changes to this bug.