Bug 1011555 - AttributeError: 'YumBase' object has no attribute 'preconf'
AttributeError: 'YumBase' object has no attribute 'preconf'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
All Linux
high Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:a14d6cb9a854aae9f28e82b6bdf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 10:17 EDT by Alexander Todorov
Modified: 2013-11-29 08:56 EST (History)
19 users (show)

See Also:
Fixed In Version: python-blivet-0.23.7-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 882279
Environment:
Last Closed: 2013-11-29 08:56:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console.log (44.15 KB, text/plain)
2013-09-24 10:18 EDT, Alexander Todorov
no flags Details
anaconda.log (10.53 KB, text/plain)
2013-09-24 10:18 EDT, Alexander Todorov
no flags Details
program.log (28.67 KB, text/plain)
2013-09-24 10:19 EDT, Alexander Todorov
no flags Details
storage.log (128.04 KB, text/plain)
2013-09-24 10:19 EDT, Alexander Todorov
no flags Details
sys.log (86.75 KB, text/plain)
2013-09-24 10:19 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2013-09-24 10:17:06 EDT
+++ This bug was initially created as a clone of Bug #882279 +++

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=RHEL\x207.0 quiet rd.live.check BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.0-0.29.el7.x86_64
other involved packages: 
package:        anaconda-18.29.2
product:        Red Hat Enterprise Linux
release:        Red Hat Enterprise Linux ComputeNode release 7.0 Beta (Maipo)
type:           libreport
version:        7.0



---------------------------------------------------------------

Filing here for Fedora 20


03:13:48 The VNC server is now running.      
  
      
      
  
   
03:13:48      
WARNING!!! VNC server running with NO PASSWORD! 
You can use the vncpassword=<password> boot option 
if you would like to secure the server.      
03:13:48 Please manually connect your vnc client to ibm-x3550m3-04-g3.lab.eng.brq.redhat.com:1 (10.34.75.135:1) to begin the install.      
  
      
 
      
  
      
(anaconda:1036): Gtk-WARNING **: Overriding tab label for notebook      
  
       
 
 
      
  
      
** (anaconda:1036): CRITICAL **: nm_ip6_route_set_prefix: assertion 'prefix > 0' failed      
  
      
 
      
  
      
Traceback (most recent call last):      
  
       
 
      
  
      
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run      
  
      
      
  
      
    threading.Thread.run(self, *args, **kwargs) 
  File "/usr/lib64/python2.7/threading.py", line 764, in run 
    self.__target(*self.__args, **self.__kwargs) 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 192, in _initialize 
    threadMgr.wait(constants.THREAD_PAYLOAD) 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 85, in wait 
    self.get(name).join() 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 76, in get 
    self.raise_error(name) 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run 
    threading.Thread.run(self, *args, **kwargs) 
  File "/usr/lib64/python2.7/threading.py", line 764, in run 
    self.__target(*self.__args, **self.__kwargs) 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 883, in payloadInitialize 
    payload.setup(storage) 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 160, in setup 
    self.updateBaseRepo(fallback=not flags.automatedInstall) 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 442, in updateBaseRepo 
    self._configureBaseRepo(self.storage, checkmount=checkmount) 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 561, in _configureBaseRepo 
    self._yum.preconf.releasever = self._getReleaseVersion(url) 
AttributeError: 'YumBase' object has no attribute 'preconf'
Comment 1 Alexander Todorov 2013-09-24 10:18:48 EDT
Created attachment 802263 [details]
console.log
Comment 2 Alexander Todorov 2013-09-24 10:18:59 EDT
Created attachment 802264 [details]
anaconda.log
Comment 3 Alexander Todorov 2013-09-24 10:19:08 EDT
Created attachment 802265 [details]
program.log
Comment 4 Alexander Todorov 2013-09-24 10:19:18 EDT
Created attachment 802266 [details]
storage.log
Comment 5 Alexander Todorov 2013-09-24 10:19:27 EDT
Created attachment 802267 [details]
sys.log
Comment 7 Vratislav Podzimek 2013-09-24 17:10:41 EDT
Does that really happen on Fedora? With some non-custom image? What are the steps to reproduce the bug?
Comment 8 Alexander Todorov 2013-09-25 04:57:57 EDT
(In reply to Vratislav Podzimek from comment #7)
> Does that really happen on Fedora? With some non-custom image? What are the
> steps to reproduce the bug?

Yeah, didn't you see the failed test job? 

The distro is a daily snapshot available in BRQ and it shoudn't be customized at all as far as I know. 

To reproduce just clone the test job from comment #6. Possibly happens only on ibm-x3550m3-04-g3.lab.eng.brq.redhat.com
Comment 9 Vratislav Podzimek 2013-09-25 09:02:43 EDT
The YumBase object is supposed to have the _preconf attribute. Reassigning to yum.
Comment 10 Zdeněk Pavlas 2013-09-25 09:24:30 EDT
Very likely a dupe of BZ 860022 (_getConfig() re-entry due to a) recursive access to .conf from plugin setup code, or b) multi-threaded acess to .conf property without proper locking).  See comment 18, 19 and 24.  Reassigning back to anaconda.
Comment 11 Vratislav Podzimek 2013-09-25 13:18:01 EDT
Brian, can you please have a look at this one?
Comment 12 Brian Lane 2013-09-25 20:32:14 EDT
Radek, does this error look familiar?

** (anaconda:1036): CRITICAL **: nm_ip6_route_set_prefix: assertion 'prefix > 0' failed

I'm speculating that something blew up in a thread and the others carried on and the preconf TB is a side-effect of that.

If this only happens on ibm-x3550m3-04-g3.lab.eng.brq.redhat.com, then what is different about it?
Comment 13 Radek Vykydal 2013-10-01 10:13:46 EDT
Sorry, it does not ring any bell.

Maybe we could try to configure eth0 to --noipv6 in kickstart and see if it reproduces.

The traceback occurs quite close after eth0 is connected:

06:17:32,846 INFO anaconda: setting <pyanaconda.ui.gui.spokes.network.NetworkSpoke object at 0x7f2580b7ec90> status to: Connected: enp0s10f0, eth0
06:17:33,204 INFO anaconda: Thread Done: AnaCustomStorageInit (139799013037824)
06:17:33,225 INFO anaconda: Running kickstart %%traceback script(s)
06:17:33,226 INFO anaconda: All kickstart %%traceback script(s) have been run

The ipv6 (auto)configuration messages are suspicious.
(eg 03:12:50,623 ERR NetworkManager: <error> [1379992370.623429] [rdisc/nm-lndp-rdisc.c:184] send_rs(): (eth0): cannot send router solicitation: -99.)
but I can't say if they are at the root of the traceback.
Comment 14 Andre Robatino 2013-11-01 15:51:07 EDT
went into "Installation source" spoke, selected "CD/DVD drive", crashed

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta-TC6\x20x86_64 quiet inst.text BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
package:        anaconda-20.25.4-1
product:        Fedora
reason:         AttributeError: 'YumBase' object has no attribute 'preconf'
release:        Cannot get release name.
version:        20-Beta-TC6
Comment 15 Andre Robatino 2013-11-01 16:32:51 EDT
went into "Installation source" spoke, selected "CD/DVD drive", crashed

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta-TC6\x20i386 quiet inst.text BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.i686
package:        anaconda-20.25.4-1
product:        Fedora
reason:         AttributeError: 'YumBase' object has no attribute 'preconf'
release:        Cannot get release name.
version:        20-Beta-TC6
Comment 16 Andre Robatino 2013-11-01 16:35:22 EDT
Both of the above were generated by attempting a text install from the 20 Beta TC6 DVD, and going into the "Installation source" spoke and selecting "CD/DVD drive". This is the default for a DVD install, so one normally wouldn't go into that spoke anyway, but still, this shouldn't happen.
Comment 17 Mike Ruckman 2013-11-01 18:43:46 EDT
F20 TC6 text based installation on bare metal from a USB stick created by DD. Filled out spokes until "Installation Source," without a problem. Upon selecting CD/DVD for the installation source, yum threw an error. "Exception yum.Errors.RepoError: RepoError() in <bound method YumBase.__del__ of <yum.YumBase object at 0x7fb8f8e62f90>> ignored " Installation couldn't continue due to installation spoke not being complete - eventually crashed (after 30 minutes or so).

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta-TC6\x20x86_64 quiet inst.text BOOT_IMAGE=vmlinuz BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
package:        anaconda-20.25.4-1
product:        Fedora
reason:         AttributeError: 'YumBase' object has no attribute 'preconf'
release:        Cannot get release name.
version:        20-Beta-TC6
Comment 18 Brian Lane 2013-11-07 20:09:30 EST
(In reply to Andre Robatino from comment #16)
> Both of the above were generated by attempting a text install from the 20
> Beta TC6 DVD, and going into the "Installation source" spoke and selecting
> "CD/DVD drive". This is the default for a DVD install, so one normally
> wouldn't go into that spoke anyway, but still, this shouldn't happen.

If you can, please give this updates.img a try against RC2

http://bcl.fedorapeople.org/updates/1011555.img
Comment 19 Andre Robatino 2013-11-07 20:25:37 EST
I was able to generate what seems to be the same error using the 20 Beta RC2 i386 DVD and your updates.img. Unfortunately, I couldn't see the numbers of the choices I was offered, since a call trace happened after printing the numbers, and when I tried to scroll up to see them, they weren't there. I just guessed and entered "1", and it created a new bug https://bugzilla.redhat.com/show_bug.cgi?id=1028245 . I don't know if that means it's a different problem.
Comment 20 Brian Lane 2013-11-07 21:34:20 EST
Thanks, it's the same general problem, but caused in a different way.
Comment 21 Brian Lane 2013-11-08 18:28:59 EST
I have updated the 1011555.img, if you have a chance, please try it again.
Comment 22 Andre Robatino 2013-11-08 18:39:32 EST
With the new 1011555.img, I can't reproduce the crash in bug 1028245 (see https://bugzilla.redhat.com/show_bug.cgi?id=1028245#c14 ). This bug I only hit without the updates.img, so can't test it without an updated install image.
Comment 23 Fedora Update System 2013-11-22 23:50:42 EST
anaconda-20.25.10-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.25.10-1.fc20
Comment 24 Fedora Update System 2013-11-23 22:30:47 EST
Package anaconda-20.25.10-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.10-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21928/anaconda-20.25.10-1.fc20
then log in and leave karma (feedback).
Comment 25 Fedora Update System 2013-11-26 12:57:57 EST
Package python-blivet-0.23.6-1.fc20, anaconda-20.25.11-1.fc20, pykickstart-1.99.48-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.23.6-1.fc20 anaconda-20.25.11-1.fc20 pykickstart-1.99.48-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21928/pykickstart-1.99.48-1.fc20,python-blivet-0.23.6-1.fc20,anaconda-20.25.11-1.fc20
then log in and leave karma (feedback).
Comment 26 Fedora Update System 2013-11-29 08:56:59 EST
python-blivet-0.23.7-1.fc20, anaconda-20.25.12-1.fc20, pykickstart-1.99.48-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.