Bug 1028245 - AttributeError: 'YumBase' object has no attribute 'preconf'
AttributeError: 'YumBase' object has no attribute 'preconf'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:b0fd3d4ea157251065a6e3b4b5e...
:
: 1027471 1031424 1035047 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 20:21 EST by Andre Robatino
Modified: 2014-02-21 14:37 EST (History)
7 users (show)

See Also:
Fixed In Version: python-blivet-0.23.7-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-29 08:57:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (386.16 KB, text/plain)
2013-11-07 20:21 EST, Andre Robatino
no flags Details
File: anaconda.log (6.46 KB, text/plain)
2013-11-07 20:21 EST, Andre Robatino
no flags Details
File: environ (394 bytes, text/plain)
2013-11-07 20:21 EST, Andre Robatino
no flags Details
File: lsblk_output (1.21 KB, text/plain)
2013-11-07 20:21 EST, Andre Robatino
no flags Details
File: nmcli_dev_list (4.24 KB, text/plain)
2013-11-07 20:21 EST, Andre Robatino
no flags Details
File: os_info (291 bytes, text/plain)
2013-11-07 20:21 EST, Andre Robatino
no flags Details
File: program.log (19.78 KB, text/plain)
2013-11-07 20:21 EST, Andre Robatino
no flags Details
File: storage.log (31.24 KB, text/plain)
2013-11-07 20:22 EST, Andre Robatino
no flags Details
File: syslog (55.80 KB, text/plain)
2013-11-07 20:22 EST, Andre Robatino
no flags Details
File: ifcfg.log (563 bytes, text/plain)
2013-11-07 20:22 EST, Andre Robatino
no flags Details
File: packaging.log (258.21 KB, text/plain)
2013-11-07 20:22 EST, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2013-11-07 20:21:28 EST
Description of problem:
same crash using the 20 Beta RC2 i386 DVD and 1011555.img

Version-Release number of selected component:
anaconda-20.25.5-1

The following was filed automatically by anaconda:
anaconda 20.25.5-1 exception report
Traceback (most recent call first):
  File "/tmp/updates/pyanaconda/packaging/yumpayload.py", line 634, in _configureBaseRepo
    self._yum.preconf.releasever = self._getReleaseVersion(url)
  File "/tmp/updates/pyanaconda/packaging/yumpayload.py", line 136, in inner_method
    ret = method(yum_payload, *args, **kwargs)
  File "/tmp/updates/pyanaconda/packaging/yumpayload.py", line 512, in updateBaseRepo
    self._configureBaseRepo(self.storage, checkmount=checkmount)
  File "/tmp/updates/pyanaconda/packaging/yumpayload.py", line 136, in inner_method
    ret = method(yum_payload, *args, **kwargs)
  File "/tmp/updates/pyanaconda/ui/tui/spokes/source.py", line 312, in getRepoMetadata
    self.payload.updateBaseRepo(fallback=False, checkmount=False)
  File "/usr/lib/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/tmp/updates/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'YumBase' object has no attribute 'preconf'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20i386 quiet inst.text inst.updates=http://bcl.fedorapeople.org/updates/1011555.img BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.6-300.fc20.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta
Comment 1 Andre Robatino 2013-11-07 20:21:38 EST
Created attachment 821368 [details]
File: anaconda-tb
Comment 2 Andre Robatino 2013-11-07 20:21:41 EST
Created attachment 821369 [details]
File: anaconda.log
Comment 3 Andre Robatino 2013-11-07 20:21:44 EST
Created attachment 821370 [details]
File: environ
Comment 4 Andre Robatino 2013-11-07 20:21:47 EST
Created attachment 821371 [details]
File: lsblk_output
Comment 5 Andre Robatino 2013-11-07 20:21:50 EST
Created attachment 821372 [details]
File: nmcli_dev_list
Comment 6 Andre Robatino 2013-11-07 20:21:53 EST
Created attachment 821373 [details]
File: os_info
Comment 7 Andre Robatino 2013-11-07 20:21:56 EST
Created attachment 821374 [details]
File: program.log
Comment 8 Andre Robatino 2013-11-07 20:22:00 EST
Created attachment 821375 [details]
File: storage.log
Comment 9 Andre Robatino 2013-11-07 20:22:03 EST
Created attachment 821376 [details]
File: syslog
Comment 10 Andre Robatino 2013-11-07 20:22:07 EST
Created attachment 821377 [details]
File: ifcfg.log
Comment 11 Andre Robatino 2013-11-07 20:22:14 EST
Created attachment 821378 [details]
File: packaging.log
Comment 12 Andre Robatino 2013-11-08 12:40:02 EST
crash using 20 Beta RC2 x86_64 DVD, text mode + 1011555.img, going into "installation source" and "CD/DVD", repeated several times

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet inst.text inst.updates=http://bcl.fedorapeople.org/updates/1011555.img BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.6-300.fc20.x86_64
package:        anaconda-20.25.5-1
product:        Fedora
reason:         AttributeError: 'YumBase' object has no attribute 'preconf'
release:        Cannot get release name.
version:        20-Beta
Comment 13 Brian Lane 2013-11-08 18:29:43 EST
I have updates 
http://bcl.fedorapeople.org/updates/1011555.img

please try it again, it should fix bug 1011555 and this one.
Comment 14 Andre Robatino 2013-11-08 18:37:15 EST
With 20 Beta RC2 x86_64 DVD text install and the updated 1011555.img, I can't reproduce this crash in VirtualBox (though I still see the 2 lines "Exception yum.Errors.RepoError: RepoError() in <bound method .......> ignored" after each attempt).
Comment 15 Chris Lumens 2013-11-19 10:38:56 EST
*** Bug 1027471 has been marked as a duplicate of this bug. ***
Comment 16 Chris Lumens 2013-11-19 10:39:06 EST
*** Bug 1031424 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2013-11-22 23:50:56 EST
anaconda-20.25.10-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.25.10-1.fc20
Comment 18 Fedora Update System 2013-11-23 22:30:59 EST
Package anaconda-20.25.10-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.10-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21928/anaconda-20.25.10-1.fc20
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2013-11-26 12:58:12 EST
Package python-blivet-0.23.6-1.fc20, anaconda-20.25.11-1.fc20, pykickstart-1.99.48-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.23.6-1.fc20 anaconda-20.25.11-1.fc20 pykickstart-1.99.48-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21928/pykickstart-1.99.48-1.fc20,python-blivet-0.23.6-1.fc20,anaconda-20.25.11-1.fc20
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2013-11-29 08:57:10 EST
python-blivet-0.23.7-1.fc20, anaconda-20.25.12-1.fc20, pykickstart-1.99.48-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 David Shea 2014-02-21 14:37:22 EST
*** Bug 1035047 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.