Bug 1011598 - AttributeError: 'NoneType' object has no attribute 'id'
AttributeError: 'NoneType' object has no attribute 'id'
Status: CLOSED DUPLICATE of bug 1004572
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:291b8151ed6f73a505acf98f1fa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 11:28 EDT by Lubos Kocman
Modified: 2013-09-24 12:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 12:27:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (786.63 KB, text/plain)
2013-09-24 11:28 EDT, Lubos Kocman
no flags Details
File: anaconda.log (24.02 KB, text/plain)
2013-09-24 11:28 EDT, Lubos Kocman
no flags Details
File: environ (422 bytes, text/plain)
2013-09-24 11:28 EDT, Lubos Kocman
no flags Details
File: lsblk_output (1.27 KB, text/plain)
2013-09-24 11:28 EDT, Lubos Kocman
no flags Details
File: nmcli_dev_list (9.28 KB, text/plain)
2013-09-24 11:28 EDT, Lubos Kocman
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-24 11:29 EDT, Lubos Kocman
no flags Details
File: program.log (34.65 KB, text/plain)
2013-09-24 11:29 EDT, Lubos Kocman
no flags Details
File: storage.log (126.81 KB, text/plain)
2013-09-24 11:29 EDT, Lubos Kocman
no flags Details
File: syslog (97.43 KB, text/plain)
2013-09-24 11:29 EDT, Lubos Kocman
no flags Details
File: ifcfg.log (474 bytes, text/plain)
2013-09-24 11:29 EDT, Lubos Kocman
no flags Details
File: packaging.log (438.15 KB, text/plain)
2013-09-24 11:29 EDT, Lubos Kocman
no flags Details

  None (edit)
Description Lubos Kocman 2013-09-24 11:28:21 EDT
Description of problem:
1. Reclaim disk and remove all previous partitions
2. select btrfs and review layout
3. remove root partition by clicking on the [ - ] button

Wild exception appears

Version-Release number of selected component:
anaconda-20.18-1

The following was filed automatically by anaconda:
anaconda 20.18-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1948, in copy
    root.swaps = [new.devicetree.getDeviceByID(d.id) for d in root.swaps]
  File "/usr/lib/python2.7/site-packages/blivet/devicefactory.py", line 767, in _save_devicetree
    _blivet_copy = self.storage.copy()
  File "/usr/lib/python2.7/site-packages/blivet/devicefactory.py", line 704, in configure
    self._save_devicetree()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2112, in _destroy_device
    factory.configure()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2171, in on_remove_clicked
    self._destroy_device(device)
AttributeError: 'NoneType' object has no attribute 'id'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/distrotrees/64272/initrd method=http://download-01.eng.brq.redhat.com/pub/fedora/linux/development-snapshot-20130924/20/x86_64/os/ repo=http://download-01.eng.brq.redhat.com/pub/fedora/linux/development-snapshot-20130924/20/x86_64/os/  BOOT_IMAGE=/distrotrees/64272/kernel 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.1-300.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20
Comment 1 Lubos Kocman 2013-09-24 11:28:29 EDT
Created attachment 802302 [details]
File: anaconda-tb
Comment 2 Lubos Kocman 2013-09-24 11:28:34 EDT
Created attachment 802303 [details]
File: anaconda.log
Comment 3 Lubos Kocman 2013-09-24 11:28:41 EDT
Created attachment 802304 [details]
File: environ
Comment 4 Lubos Kocman 2013-09-24 11:28:48 EDT
Created attachment 802305 [details]
File: lsblk_output
Comment 5 Lubos Kocman 2013-09-24 11:28:55 EDT
Created attachment 802306 [details]
File: nmcli_dev_list
Comment 6 Lubos Kocman 2013-09-24 11:29:05 EDT
Created attachment 802307 [details]
File: os_info
Comment 7 Lubos Kocman 2013-09-24 11:29:10 EDT
Created attachment 802308 [details]
File: program.log
Comment 8 Lubos Kocman 2013-09-24 11:29:16 EDT
Created attachment 802309 [details]
File: storage.log
Comment 9 Lubos Kocman 2013-09-24 11:29:21 EDT
Created attachment 802310 [details]
File: syslog
Comment 10 Lubos Kocman 2013-09-24 11:29:25 EDT
Created attachment 802311 [details]
File: ifcfg.log
Comment 11 Lubos Kocman 2013-09-24 11:29:31 EDT
Created attachment 802312 [details]
File: packaging.log
Comment 12 David Shea 2013-09-24 12:27:51 EDT

*** This bug has been marked as a duplicate of bug 1004572 ***

Note You need to log in before you can comment on or make changes to this bug.