Bug 1011608 - Unable to migrate VM between 3.3 (is14) hosts and older hosts
Unable to migrate VM between 3.3 (is14) hosts and older hosts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Eduardo Warszawski
Elad
storage
:
: 1015175 (view as bug list)
Depends On:
Blocks: 985770
  Show dependency treegraph
 
Reported: 2013-09-24 11:51 EDT by Federico Simoncelli
Modified: 2016-02-10 15:54 EST (History)
14 users (show)

See Also:
Fixed In Version: v4.13.0
Doc Type: Bug Fix
Doc Text:
Live migration was not backwards compatible, so virtual machines could not be migrated between hosts with older VDSM versions and 3.3 beta hosts. This has been fixed, so live migration works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:16:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
abaron: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19509 None None None Never
oVirt gerrit 19825 None None None Never

  None (edit)
Description Federico Simoncelli 2013-09-24 11:51:03 EDT
Description of problem:
Unable to migrate VM between 3.3 hosts.

Version-Release number of selected component (if applicable):
vdsm-4.12.0-127.gitedb88bf.el6ev.x86_64.rpm (is14)

How reproducible:
100%

Steps to Reproduce:
1. Start a vm using a previous vdsm version (e.g. vdsm-4.12.0-105.git0da1561.el6ev.x86_64.rpm is13)
2. Live migrate the VM to an host with the new version (is14)

Actual results:

Thread-1306::ERROR::2013-09-23 16:02:42,422::BindingXMLRPC::993::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 979, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 211, in vmDestroy
    return vm.destroy()
  File "/usr/share/vdsm/API.py", line 323, in destroy
    res = v.destroy()
  File "/usr/share/vdsm/vm.py", line 4326, in destroy
    response = self.releaseVm()
  File "/usr/share/vdsm/vm.py", line 4292, in releaseVm
    self._cleanup()
  File "/usr/share/vdsm/vm.py", line 2750, in _cleanup
    self._cleanupDrives()
  File "/usr/share/vdsm/vm.py", line 2482, in _cleanupDrives
    drive, exc_info=True)
  File "/usr/lib64/python2.6/logging/__init__.py", line 1329, in error
    self.logger.error(msg, *args, **kwargs)
  File "/usr/lib64/python2.6/logging/__init__.py", line 1082, in error
    self._log(ERROR, msg, args, **kwargs)
File "/usr/lib64/python2.6/logging/__init__.py", line 1082, in error
    self._log(ERROR, msg, args, **kwargs)
  File "/usr/lib64/python2.6/logging/__init__.py", line 1173, in _log
    self.handle(record)
  File "/usr/lib64/python2.6/logging/__init__.py", line 1183, in handle
    self.callHandlers(record)
  File "/usr/lib64/python2.6/logging/__init__.py", line 1220, in callHandlers
    hdlr.handle(record)
  File "/usr/lib64/python2.6/logging/__init__.py", line 679, in handle
    self.emit(record)
  File "/usr/lib64/python2.6/logging/handlers.py", line 780, in emit
    msg = self.format(record)
  File "/usr/lib64/python2.6/logging/__init__.py", line 654, in format
    return fmt.format(record)
  File "/usr/lib64/python2.6/logging/__init__.py", line 436, in format
    record.message = record.getMessage()
  File "/usr/lib64/python2.6/logging/__init__.py", line 306, in getMessage
    msg = msg % self.args
  File "/usr/share/vdsm/vm.py", line 107, in __str__
    if not a.startswith('__')]
  File "/usr/share/vdsm/vm.py", line 1344, in hasVolumeLeases
    if self.shared != DRIVE_SHARED_TYPE.EXCLUSIVE:
AttributeError: 'Drive' object has no attribute 'shared'


Expected results:
Live migration should be successful.
Comment 2 Dan Kenigsberg 2013-09-24 18:37:02 EDT
As reported by Dead Horse Consulting on http://lists.ovirt.org/pipermail/users/2013-September/016590.html (thanks!)
Comment 3 Aharon Canan 2013-09-29 05:17:04 EDT
Guys, 

you do not really need QA here.
please test and check the fix if you think you need.

we will verify when it will be "ON_QA"
Comment 4 Ayal Baron 2013-10-08 06:46:39 EDT
*** Bug 1015175 has been marked as a duplicate of this bug. ***
Comment 5 Cheryn Tan 2013-10-10 22:11:15 EDT
Removing from release notes, changed the Doc Type.
Comment 6 Elad 2013-10-27 06:23:25 EDT
VM migration between host with vdsm version is13 (vdsm-4.12.0-105.git0da1561.el6ev.x86_64) to host with vdsm version is20 (vdsm-4.13.0-0.5.beta1.el6ev.x86_64) succeeded. 
The VM was first started on is13 vdsm and then migrated to is20 vdsm.
Comment 7 errata-xmlrpc 2014-01-21 11:16:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.