Bug 1015175 - VM migration from 3.3 host to 3.2 host fails - target directory /var/run/vdsm/storage does not exist
VM migration from 3.3 host to 3.2 host fails - target directory /var/run/vdsm...
Status: CLOSED DUPLICATE of bug 1011608
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: nobody nobody
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 10:54 EDT by Pavel Novotny
Modified: 2016-02-10 13:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 06:46:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libvirtd.log from the source 3.3 host (37.62 KB, text/plain)
2013-10-03 10:58 EDT, Pavel Novotny
no flags Details
VDSM log from the source 3.3 host (239.63 KB, text/plain)
2013-10-03 10:58 EDT, Pavel Novotny
no flags Details
libvirtd.log from the target 3.2 host (25.79 KB, text/plain)
2013-10-03 10:59 EDT, Pavel Novotny
no flags Details
VDSM log from the target 3.2 host (1.12 MB, text/plain)
2013-10-03 11:00 EDT, Pavel Novotny
no flags Details

  None (edit)
Description Pavel Novotny 2013-10-03 10:54:58 EDT
Description of problem:
Migration of a VM from 3.3 host to 3.2 host fails. Libvirt throws an exception that it cannot find the VM disk image file on the target host under /var/run/vdsm/storage/ directory, which is missing there completely.
Note: SELinux was set to permissive mode on both hosts.

Version-Release number of selected component (if applicable):
3.3 host:
vdsm-4.12.0-156.git6e499d6.el6ev.x86_64
libvirt-0.10.2-27.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.355.el6_4.7.x86_64

3.2 host:
vdsm-4.10.2-25.1.el6ev.x86_64
libvirt-0.10.2-18.el6_4.14.x86_64
qemu-kvm-rhev-0.12.1.2-2.355.el6_4.2.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Add 3.3 and 3.2 host in a 3.2 cluster.
2. Create new VM with a bootable disk and run it on the 3.3 host.
3. Migrate the VM to the 3.2 host.

Actual results:
Migration fails - webadmin message: "Migration failed due to Error: Fatal error during migration (VM: win7x64, Source: srh-09, Destination: srh-10).".
Target host's libvirtd.log: virFileOpenAs:1073 : failed to open file  '/var/run/vdsm/storage/84f6d841-6c6a-49be-a0f5-b7d80f876573/1985711b-46fd-4cb7-909b-1168f60b5547/548c7b86-b75e-441e-97b9-c163ffdacaca': No such file or directory.

Expected results:
Migration completes successfully.

Additional info:

The file exists on the source host:
# ls -lh /var/run/vdsm/storage/84f6d841-6c6a-49be-a0f5-b7d80f876573/1985711b-46fd-4cb7-909b-1168f60b5547/548c7b86-b75e-441e-97b9-c163ffdacaca
-rw-rw----. 1 vdsm kvm 1,0G  2. říj 13.41 /var/run/vdsm/storage/84f6d841-6c6a-49be-a0f5-b7d80f876573/1985711b-46fd-4cb7-909b-1168f60b5547/548c7b86-b75e-441e-97b9-c163ffdacaca

But on the target host...:
# ls /var/run/vdsm/storage
ls: cannot access /var/run/vdsm/storage: No such file or directory
Comment 1 Pavel Novotny 2013-10-03 10:58:11 EDT
Created attachment 807128 [details]
libvirtd.log from the source 3.3 host
Comment 2 Pavel Novotny 2013-10-03 10:58:50 EDT
Created attachment 807129 [details]
VDSM log from the source 3.3 host
Comment 3 Pavel Novotny 2013-10-03 10:59:21 EDT
Created attachment 807130 [details]
libvirtd.log from the target 3.2 host
Comment 4 Pavel Novotny 2013-10-03 11:00:15 EDT
Created attachment 807131 [details]
VDSM log from the target 3.2 host
Comment 6 Ayal Baron 2013-10-08 06:46:39 EDT

*** This bug has been marked as a duplicate of bug 1011608 ***

Note You need to log in before you can comment on or make changes to this bug.