Bug 101176 - /lib/libssl.so.4: undefined symbol: krb5_cc_get_principal
Summary: /lib/libssl.so.4: undefined symbol: krb5_cc_get_principal
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: openssl   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
: 101111 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-29 20:06 UTC by Nicolas Mailhot
Modified: 2007-04-18 16:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 18:14:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolas Mailhot 2003-07-29 20:06:37 UTC
After a rawhide apt sync :

[root@rousalka src]# lftp kernel
/lib/libssl.so.4: undefined symbol: krb5_cc_get_principal
open: ftp - protocole non supporté

lftp-2.6.5-2
openssl-devel-0.9.7a-17
openssl-0.9.7a-17
krb5-devel-1.2.8-4
krb5-libs-1.2.8-4

Comment 1 Nicolas Mailhot 2003-07-29 20:07:49 UTC
(just got this cron message btw) 

/etc/cron.hourly/diskcheck:

Traceback (most recent call last):
  File "/etc/cron.hourly/diskcheck", line 234, in ?
    from socket import gethostname
  File "/usr/lib/python2.2/socket.py", line 41, in ?
    from _socket import *
ImportError: /lib/libssl.so.4: undefined symbol: krb5_cc_get_principal

Comment 2 Bill Nottingham 2003-07-29 20:41:13 UTC
Please upgrade to krb5-1.3-* and retest...

Comment 3 Bill Nottingham 2003-07-29 20:45:56 UTC
*** Bug 101111 has been marked as a duplicate of this bug. ***

Comment 4 Nicolas Mailhot 2003-07-29 20:51:29 UTC
Well that works now - seems the krb packages didn't make it to the apt mirrors
in time.
                                                                                
However the openssl package should really be more carefull about its kerberos
dependencies - rpm should never have allowed installing the new openssl with the
old krb packages present.


Comment 5 Bill Nottingham 2003-07-29 20:56:09 UTC
krb5 changed ABI without changing soname. :(

Comment 6 Gary Peck 2003-12-01 06:08:18 UTC
I think this bug is back in the most recent rawhide. When I run "lftp
ftp.redhat.com" I get:

/lib/libssl.so.4: undefined symbol: krb5_get_credentials
lftp: ftp - not supported protocol

Running "ldd -r /lib/libssl.so.4" gives:

        libcrypto.so.4 => /lib/libcrypto.so.4 (0x4b7d0000)
        libdl.so.2 => /lib/libdl.so.2 (0x4b8c3000)
        libz.so.1 => /usr/lib/libz.so.1 (0x4b8c6000)
        libc.so.6 => /lib/i686/libc.so.6 (0x4b8d7000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x0ab46000)
undefined symbol: krb5_get_credentials  (/lib/libssl.so.4)
undefined symbol: krb5_cc_get_principal (/lib/libssl.so.4)
undefined symbol: krb5_sname_to_principal       (/lib/libssl.so.4)
undefined symbol: krb5_mk_req_extended  (/lib/libssl.so.4)
undefined symbol: krb5_free_ticket      (/lib/libssl.so.4)
undefined symbol: krb5_cc_default       (/lib/libssl.so.4)
undefined symbol: krb5_timeofday        (/lib/libssl.so.4)
undefined symbol: krb5_auth_con_init    (/lib/libssl.so.4)
undefined symbol: krb5_decrypt_tkt_part (/lib/libssl.so.4)
undefined symbol: krb5_auth_con_setrcache       (/lib/libssl.so.4)
undefined symbol: krb5_kt_close (/lib/libssl.so.4)
undefined symbol: krb5_kt_free_entry    (/lib/libssl.so.4)
undefined symbol: krb5_auth_con_getrcache       (/lib/libssl.so.4)
undefined symbol: krb5_checksum_size    (/lib/libssl.so.4)
undefined symbol: krb5_free_principal   (/lib/libssl.so.4)
undefined symbol: krb5_rc_get_lifespan  (/lib/libssl.so.4)
undefined symbol: krb5_kt_resolve       (/lib/libssl.so.4)
undefined symbol: krb5_auth_con_free    (/lib/libssl.so.4)
undefined symbol: krb5_principal_compare        (/lib/libssl.so.4)
undefined symbol: valid_cksumtype       (/lib/libssl.so.4)
undefined symbol: krb5_free_context     (/lib/libssl.so.4)
undefined symbol: krb5_rc_default       (/lib/libssl.so.4)
undefined symbol: krb5_rc_destroy       (/lib/libssl.so.4)
undefined symbol: krb5_kt_default       (/lib/libssl.so.4)
undefined symbol: krb5_kt_get_entry     (/lib/libssl.so.4)
undefined symbol: krb5_get_server_rcache        (/lib/libssl.so.4)
undefined symbol: krb5_rc_initialize    (/lib/libssl.so.4)
undefined symbol: krb5_free_data_contents       (/lib/libssl.so.4)
undefined symbol: krb5_init_context     (/lib/libssl.so.4)

I have installed:
lftp-2.6.8-0.rhfc1.dag (this is from Dag Wieer's repo)
openssl-0.9.7a-25
krb5-libs-1.3.1-7

It looks like libssl.so.4 is not even linked to any kerberos libraries
even though it references kerberos symbols.

Comment 7 Nicolas Mailhot 2003-12-01 08:50:26 UTC
Same here.
I'd tend to say using lftp should be mandatory after an openssl
update;) Seems a wonderful regression test.

Comment 8 Nicolas Mailhot 2004-02-19 18:14:37 UTC
Fixed here

Comment 9 DocWilco 2004-06-28 13:11:58 UTC
Removing /usr/kerberos/lib from /etc/ld.conf and running 'ldconfig'
does wonders. (The newer krb5-* rpms seem to install the libs in
/usr/lib).


Note You need to log in before you can comment on or make changes to this bug.