Bug 101176 - /lib/libssl.so.4: undefined symbol: krb5_cc_get_principal
/lib/libssl.so.4: undefined symbol: krb5_cc_get_principal
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: openssl (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 101111 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-29 16:06 EDT by Nicolas Mailhot
Modified: 2007-04-18 12:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 13:14:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2003-07-29 16:06:37 EDT
After a rawhide apt sync :

[root@rousalka src]# lftp kernel
/lib/libssl.so.4: undefined symbol: krb5_cc_get_principal
open: ftp - protocole non supporté

lftp-2.6.5-2
openssl-devel-0.9.7a-17
openssl-0.9.7a-17
krb5-devel-1.2.8-4
krb5-libs-1.2.8-4
Comment 1 Nicolas Mailhot 2003-07-29 16:07:49 EDT
(just got this cron message btw) 

/etc/cron.hourly/diskcheck:

Traceback (most recent call last):
  File "/etc/cron.hourly/diskcheck", line 234, in ?
    from socket import gethostname
  File "/usr/lib/python2.2/socket.py", line 41, in ?
    from _socket import *
ImportError: /lib/libssl.so.4: undefined symbol: krb5_cc_get_principal
Comment 2 Bill Nottingham 2003-07-29 16:41:13 EDT
Please upgrade to krb5-1.3-* and retest...
Comment 3 Bill Nottingham 2003-07-29 16:45:56 EDT
*** Bug 101111 has been marked as a duplicate of this bug. ***
Comment 4 Nicolas Mailhot 2003-07-29 16:51:29 EDT
Well that works now - seems the krb packages didn't make it to the apt mirrors
in time.
                                                                                
However the openssl package should really be more carefull about its kerberos
dependencies - rpm should never have allowed installing the new openssl with the
old krb packages present.
Comment 5 Bill Nottingham 2003-07-29 16:56:09 EDT
krb5 changed ABI without changing soname. :(
Comment 6 Gary Peck 2003-12-01 01:08:18 EST
I think this bug is back in the most recent rawhide. When I run "lftp
ftp.redhat.com" I get:

/lib/libssl.so.4: undefined symbol: krb5_get_credentials
lftp: ftp - not supported protocol

Running "ldd -r /lib/libssl.so.4" gives:

        libcrypto.so.4 => /lib/libcrypto.so.4 (0x4b7d0000)
        libdl.so.2 => /lib/libdl.so.2 (0x4b8c3000)
        libz.so.1 => /usr/lib/libz.so.1 (0x4b8c6000)
        libc.so.6 => /lib/i686/libc.so.6 (0x4b8d7000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x0ab46000)
undefined symbol: krb5_get_credentials  (/lib/libssl.so.4)
undefined symbol: krb5_cc_get_principal (/lib/libssl.so.4)
undefined symbol: krb5_sname_to_principal       (/lib/libssl.so.4)
undefined symbol: krb5_mk_req_extended  (/lib/libssl.so.4)
undefined symbol: krb5_free_ticket      (/lib/libssl.so.4)
undefined symbol: krb5_cc_default       (/lib/libssl.so.4)
undefined symbol: krb5_timeofday        (/lib/libssl.so.4)
undefined symbol: krb5_auth_con_init    (/lib/libssl.so.4)
undefined symbol: krb5_decrypt_tkt_part (/lib/libssl.so.4)
undefined symbol: krb5_auth_con_setrcache       (/lib/libssl.so.4)
undefined symbol: krb5_kt_close (/lib/libssl.so.4)
undefined symbol: krb5_kt_free_entry    (/lib/libssl.so.4)
undefined symbol: krb5_auth_con_getrcache       (/lib/libssl.so.4)
undefined symbol: krb5_checksum_size    (/lib/libssl.so.4)
undefined symbol: krb5_free_principal   (/lib/libssl.so.4)
undefined symbol: krb5_rc_get_lifespan  (/lib/libssl.so.4)
undefined symbol: krb5_kt_resolve       (/lib/libssl.so.4)
undefined symbol: krb5_auth_con_free    (/lib/libssl.so.4)
undefined symbol: krb5_principal_compare        (/lib/libssl.so.4)
undefined symbol: valid_cksumtype       (/lib/libssl.so.4)
undefined symbol: krb5_free_context     (/lib/libssl.so.4)
undefined symbol: krb5_rc_default       (/lib/libssl.so.4)
undefined symbol: krb5_rc_destroy       (/lib/libssl.so.4)
undefined symbol: krb5_kt_default       (/lib/libssl.so.4)
undefined symbol: krb5_kt_get_entry     (/lib/libssl.so.4)
undefined symbol: krb5_get_server_rcache        (/lib/libssl.so.4)
undefined symbol: krb5_rc_initialize    (/lib/libssl.so.4)
undefined symbol: krb5_free_data_contents       (/lib/libssl.so.4)
undefined symbol: krb5_init_context     (/lib/libssl.so.4)

I have installed:
lftp-2.6.8-0.rhfc1.dag (this is from Dag Wieer's repo)
openssl-0.9.7a-25
krb5-libs-1.3.1-7

It looks like libssl.so.4 is not even linked to any kerberos libraries
even though it references kerberos symbols.
Comment 7 Nicolas Mailhot 2003-12-01 03:50:26 EST
Same here.
I'd tend to say using lftp should be mandatory after an openssl
update;) Seems a wonderful regression test.
Comment 8 Nicolas Mailhot 2004-02-19 13:14:37 EST
Fixed here
Comment 9 DocWilco 2004-06-28 09:11:58 EDT
Removing /usr/kerberos/lib from /etc/ld.conf and running 'ldconfig'
does wonders. (The newer krb5-* rpms seem to install the libs in
/usr/lib).

Note You need to log in before you can comment on or make changes to this bug.