Bug 101111 - redhat-config-network-1.3.1-1 crashes on opening
redhat-config-network-1.3.1-1 crashes on opening
Status: CLOSED DUPLICATE of bug 101176
Product: Red Hat Raw Hide
Classification: Retired
Component: openssl (Show other bugs)
1.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-29 05:12 EDT by Alan Sanderson
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Sanderson 2003-07-29 05:12:21 EDT
Description of problem: Open redhat-config-network from program menus
and it crashes strait away giveing the following message:
An uhandled exception has occured. This is most likely a bug. Please save the
crash dump and file a detailed bug report against redhat-config-network at
https://bugzilla.redhat.com/bugzilla
Component: redhat-config-network
Version: 1.3.1
Summary: TB NewInterfaceDialog.py:27:?:ImportError: /lib/libssl.so.4: undefined
symbol: krb5_cc_get_principal
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 138, in main
    import netconfpkg.gui.GUI_functions
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/__init__.py",
line 31, in ?
  File "<string>", line 1, in ?
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 31, in ?
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 27, in ?
ImportError: /lib/libssl.so.4: undefined symbol: krb5_cc_get_principal

Local variables in innermost frame:
FALSE: 0
signal: <module 'signal' (built-in)>
__builtins__: {'help': Type help() for interactive help, or help(object) for
help about object., 'vars': <built-in function vars>, 'pow': <built-in function
pow>, 'RuntimeError': <class exceptions.RuntimeError at 0x811755c>, 'float':
<type 'float'>, 'StopIteration': <class exceptions.StopIteration at 0x81162ec>,
'globals': <built-in function globals>, 'divmod': <built-in function divmod>,
'unicode': <type 'unicode'>, 'apply': <built-in function apply>, 'isinstance':
<built-in function isinstance>, 'open': <type 'file'>, 'ArithmeticError': <class
exceptions.ArithmeticError at 0x81192a4>, 'quit': 'Use Ctrl-D (i.e. EOF) to
exit.', 'UnicodeError': <class exceptions.UnicodeError at 0x8119acc>, 'zip':
<built-in function zip>, 'LookupError': <class exceptions.LookupError at
0x8117014>, 'super': <type 'super'>, 'AttributeError': <class
exceptions.AttributeError at 0x8111694>, 'hex': <built-in function hex>, 'long':
<type 'long'>, 'ReferenceError': <class exceptions.ReferenceError at 0x8119ca4>,
'NameError': <class exceptions.NameError at 0x811779c>, 'ImportError': <class
exceptions.ImportError at 0x8116ae4>, 'chr': <built-in function chr>, 'complex':
<type 'complex'>, 'dict': <type 'dict'>, '__import__': <built-in function
__import__>, 'input': <built-in function input>, 'type': <type 'type'>, 'oct':
<built-in function oct>, 'SystemExit': <class exceptions.SystemExit at
0x811687c>, 'Exception': <class exceptions.Exception at 0x811606c>,
'StandardError': <class exceptions.StandardError at 0x81164a4>, 'tuple': <type
'tuple'>, 'repr': <built-in function repr>, 'SystemError': <class
exceptions.SystemError at 0x8119d04>, 'IOError': <class exceptions.IOError at
0x8116ebc>, 'IndexError': <class exceptions.IndexError at 0x8118f4c>, 'hasattr':
<built-in function hasattr>, 'delattr': <built-in function delattr>, 'False': 0,
'RuntimeWarning': <class exceptions.RuntimeWarning at 0x811aa7c>, 'setattr':
<built-in function setattr>, 'raw_input': <built-in function raw_input>, 'list':
<type 'list'>, 'SyntaxWarning': <class exceptions.SyntaxWarning at 0x811a704>,
'iter': <built-in function iter>, '__doc__': "Built-in functions, exceptions,
and other objects.\n\nNoteworthy: None is the `nil' object; Ellipsis represents
`...' in slices.", 'compile': <built-in function compile>, 'reload': <built-in
function reload>, 'Warning': <class exceptions.Warning at 0x811a1ac>, 'str':
<type 'str'>, 'property': <type 'property'>, 'round': <built-in function round>,
'dir': <built-in function dir>, 'cmp': <built-in function cmp>, 'MemoryError':
<class exceptions.MemoryError at 0x811a034>, 'hash': <built-in function hash>,
'int': <type 'int'>, 'xrange': <built-in function xrange>, 'reduce': <built-in
function reduce>, 'KeyError': <class exceptions.KeyError at 0x81190dc>,
'coerce': <built-in function coerce>, 'intern': <built-in function intern>,
'exit': 'Use Ctrl-D (i.e. EOF) to exit.', 'issubclass': <built-in function
issubclass>, 'file': <type 'file'>, 'EnvironmentError': <class
exceptions.EnvironmentError at 0x8116ddc>, 'unichr': <built-in function unichr>,
'id': <built-in function id>, 'locals': <built-in function locals>, 'slice':
<built-in function slice>, 'DeprecationWarning': <class
exceptions.DeprecationWarning at 0x811a554>, 'min': <built-in function min>,
'FloatingPointError': <class exceptions.FloatingPointError at 0x81197bc>,
'execfile': <built-in function execfile>, 'OverflowWarning': <class
exceptions.OverflowWarning at 0x811a8bc>, 'getattr': <built-in function
getattr>, 'abs': <built-in function abs>, 'bool': <built-in function bool>,
'True': 1, 'ValueError': <class exceptions.ValueError at 0x811981c>,
'NotImplemented': NotImplemented, 'map': <built-in function map>, 'None': None,
'EOFError': <class exceptions.EOFError at 0x81173cc>, 'buffer': <built-in
function buffer>, 'max': <built-in function max>, 'object': <type 'object'>,
'len': <built-in function len>, 'TabError': <class exceptions.TabError at
0x81187e4>, 'callable': <built-in function callable>, 'credits': Thanks to CWI,
CNRI, BeOpen.com, Digital Creations and a cast of thousands
for supporting Python development.  See www.python.org for more information.,
'SyntaxError': <class exceptions.SyntaxError at 0x81117fc>, 'OSError': <class
exceptions.OSError at 0x811721c>, 'eval': <built-in function eval>, '__name__':
'__builtin__', 'ord': <built-in function ord>, '__debug__': 1,
'IndentationError': <class exceptions.IndentationError at 0x8118784>, '_':
<bound method i18n.gettext of <rhpl.translate.i18n instance at 0x818a62c>>,
'AssertionError': <class exceptions.AssertionError at 0x8118aac>, 'TypeError':
<class exceptions.TypeError at 0x8116504>, 'copyright': Copyright (c) 2001, 2002
Python Software Foundation.
All Rights Reserved.

Copyright (c) 2000 BeOpen.com.
All Rights Reserved.

Copyright (c) 1995-2001 Corporation for National Research Initiatives.
All Rights Reserved.

Copyright (c) 1991-1995 Stichting Mathematisch Centrum, Amsterdam.
All Rights Reserved., 'license': See http://www.python.org/2.2/license.html,
'classmethod': <type 'classmethod'>, 'KeyboardInterrupt': <class
exceptions.KeyboardInterrupt at 0x8116a84>, 'UserWarning': <class
exceptions.UserWarning at 0x811a374>, 'ZeroDivisionError': <class
exceptions.ZeroDivisionError at 0x8119614>, 'UnboundLocalError': <class
exceptions.UnboundLocalError at 0x8111504>, 'filter': <built-in function
filter>, 'range': <built-in function range>, 'staticmethod': <type
'staticmethod'>, 'NotImplementedError': <class exceptions.NotImplementedError at
0x811773c>, 'Ellipsis': Ellipsis, 'OverflowError': <class
exceptions.OverflowError at 0x811944c>}
__name__: netconfpkg.gui.NewInterfaceDialog
__file__:
/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.pyc
gtk: <module 'gtk' from '/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'>
os: <module 'os' from '/usr/lib/python2.2/os.pyc'>
__doc__: None
TRUE: 1


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Alan Sanderson 2003-07-29 05:15:15 EDT
Oh I forgot the version numbers.

rpm -qa | grep redhat-config-network
redhat-config-network-tui-1.3.1-1
redhat-config-network-1.3.1-1

Linux k6-2-500-rhl9 2.4.20-19.9 #1 Tue Jul 15 17:03:15 EDT 2003 i586 i586 i386
GNU/Linux
Comment 2 Harald Hoyer 2003-07-29 05:34:07 EDT
this seems to be a problem with /lib/libssl.so.4
$ ll /lib/libssl.so.4
lrwxrwxrwx    1 root     root           16  6. Mär 17:05 /lib/libssl.so.4 ->
libssl.so.0.9.7a
$ rpm -qf /lib/libssl.so.0.9.7a
openssl-0.9.7a-15
Comment 3 Harald Hoyer 2003-07-29 05:34:24 EDT
ImportError: /lib/libssl.so.4: undefined symbol: krb5_cc_get_principal
Comment 4 Alan Sanderson 2003-07-29 10:11:38 EDT
rpm -qa | grep openssl
openssl-0.9.7a-17
openssl096b-0.9.6b-8
openssl-devel-0.9.7a-17

rpm -qa | grep krb5
krb5-devel-1.2.8-4
pam_krb5-1.61-1
krb5-libs-1.2.8-4
Comment 5 Bill Nottingham 2003-07-29 16:45:53 EDT
Please upgrade to the latest krb5 packages.

*** This bug has been marked as a duplicate of 101176 ***
Comment 6 sqrly 2004-05-03 17:43:05 EDT
I am getting this same error. Running Fedora Core-1 which was upgraded
from RH 9 using yum.

# rpm -qa | grep krb5
pam_krb5-1.60-1
krb5-server-1.3.1-6
krb5-devel-1.3.1-6
krb5-libs-1.2.7-10
krb5-libs-1.3.1-6
krb5-workstation-1.3.1-6
krb5-workstation-1.2.7-10
pam_krb5-2.0.5-1
# rpm -qa | grep openssl
openssl096-0.9.6-26
openssl-perl-0.9.7a-33.10
openssl-devel-0.9.7a-33.10
openssl096b-0.9.6b-18
openssl-0.9.7a-33.10
# rpm -qa | grep redhat-config-network
redhat-config-network-tui-1.2.0-2
redhat-config-network-1.2.0-2
redhat-config-network-tui-1.3.10-1
redhat-config-network-1.3.10-1
# uname -a 
Linux mid-dhcp33-252-163.bbn.com 2.4.22-1.2188.nptl #1 Wed Apr 21
20:36:05 EDT 2004 i686 i686 i386 GNU/Linux

Should I remove the old versions of the duplicates? 
Comment 7 Red Hat Bugzilla 2006-02-21 13:57:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.