Bug 101181 - Severn "upgrade" install fails just after monitor selection.
Summary: Severn "upgrade" install fails just after monitor selection.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-29 20:28 UTC by Elton Woo
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 21:41:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
memory dump of crash (72.00 KB, text/plain)
2003-07-29 20:29 UTC, Elton Woo
no flags Details

Description Elton Woo 2003-07-29 20:28:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
I am unable to install packages with rpm and the software manager
(Ref. bug #101080). As a workaround, I decided to do an upgrade
install of the beta, to get the packages which were not installed.
(e.g. licq, plugger, etc...).

NOTE: Initial install was done using my CDwriter drive (/dev/hdc alias
/mnt/cdrom1). This time, I installed the Disk 1 in my Secondary Slave
drive (DVD reader) which is /dev/hdd alias /mnt/cdrom.

The installation went as far as selecting "upgrade" system, at which point the
error dialog popped up. 

Please refer to attachment (anacdump.txt)

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install CD1 and shutdown / restart / reboot machine _ on a system
which already has RH 9.0.93 (Severn) installed_.
2. Go through the usual process of choosing mouse, and monitor, etc.
3. Select "upgrade"
    

Actual Results:  Installer abends with error message.

Expected Results:  Installer should proceed, and allow user to select packages, etc.

Additional info:

Comment 1 Elton Woo 2003-07-29 20:29:43 UTC
Created attachment 93234 [details]
memory dump of crash

Comment 2 Michael Fulbright 2003-07-29 20:40:50 UTC
If you boot off the CD #1 with 'linux rescue' and when it asks you if you want
to mount an existing linux installation, does that succeed?

Comment 3 Elton Woo 2003-07-30 02:59:05 UTC
with "linux rescue" I get into text mode, but I don't know what else to do.
(Regrettably I haven't learnt all the procedures in rescue mode). I've done
"linux text", and was able to do an upgrade, but this did not (or I missed seeing
that) give me the option of selecting particular pacakges, so all that got
"upgraded" was one library and xterm.

Comment 4 Bob Cochran 2003-08-04 18:06:09 UTC
Put in CD 1 and at the prompt type Linux rescue.

When it asks if you want networking support -- answer depending on your
preferences, be ready to supply IP addresses if you say yes.

When it asks to mount an existing installation, continue with that, to see if it
can find a system to mount.

If mounting it succeeds (you will be told through a message) you can chroot into
your system:

chroot /mnt/sysimage

and then you can start trouble shooting in your system, inspecting file
contents, searching, etc just as if you were at a normal root shell. For example
you can issue this:

vi /etc/fstab

and edit fstab right in the rescue environment. The facility is a great life saver.

Bob Cochran

Comment 5 Jeremy Katz 2003-08-13 23:34:22 UTC
Yep, those are pretty good directions :-)

Also, the anacdump.txt that you attached seems to be cut off and missing the
bottom of the kernel messages (which are potentially interesting with IO
errors).  Was there more and bugzilla ate part of the attachment?

Comment 6 curtis quisenberry 2003-09-03 17:49:25 UTC
Hi,

     I'm a little unclear about your error; however, I also had a problem
installing packages during an install of Severn.  It locked up the gui, &
wouldn't let me proceed, i.e. select the components for installing.  I was able
to get around this by opening another user session, by way of ^AltF12.  This
brought up the same display, however, I was then able to select the components
for installation, such as games.

Curtis


Note You need to log in before you can comment on or make changes to this bug.