Bug 1011924 - when single pci device is chosen in New VM dialog for non-linux system, dialog should highlight it instead of aborting
when single pci device is chosen in New VM dialog for non-linux system, dialo...
Status: CLOSED DUPLICATE of bug 1009391
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.0
Assigned To: Shahar Havivi
Pavel Novotny
virt
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 08:01 EDT by David Jaša
Modified: 2013-10-20 14:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 09:41:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-09-25 08:01:39 EDT
Description of problem:
when single pci device is choosed in New VM dialog for non-linux system, dialog should highlight it instead of aborting the whole dialog

Version-Release number of selected component (if applicable):
is16 / 3.3.0-0.22.master.el6ev

How reproducible:
always

Steps to Reproduce:
1. enter "New VM" dialog, set VM name, set OS type to Windows (any of them)
2. in Advanced Options / Console, check "Single PCI device"
3. hit OK

Actual results:
the dialog fails with error message, leaving user in the base screen

Expected results:
the dialog highlights OS type and "Single PCI" fields with note of their incompatibility

Additional info:
Comment 1 Michal Skrivanek 2013-09-26 08:18:09 EDT
we should gray out the checkbox on Windows OS in the dialog itself. The backend check might be still useful for REST though
Comment 2 Shahar Havivi 2013-10-08 09:41:49 EDT
bz #1009391 is fixing this problem as well

*** This bug has been marked as a duplicate of bug 1009391 ***

Note You need to log in before you can comment on or make changes to this bug.