Bug 1011936 - [abrt] crash in spice_bitmap_to_pixman (from virt-manager)
[abrt] crash in spice_bitmap_to_pixman (from virt-manager)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spice (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
abrt_hash:71f75878c9c488fb975bd610f77...
:
: 1012717 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 08:23 EDT by Ilya Gradina
Modified: 2013-11-10 01:33 EST (History)
12 users (show)

See Also:
Fixed In Version: spice-gtk-0.21-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:33:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ilya Gradina 2013-09-25 08:23:03 EDT
Version-Release number of selected component:
virt-manager-0.10.0-2.git948b5359.fc20

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/share/virt-manager/virt-manager
crash_function: spice_logv
executable:     /usr/bin/python2.7
kernel:         3.11.1-300.fc20.x86_64
runlevel:       unknown
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 spice_logv at log.c:109
 #3 spice_log at log.c:123
 #4 bitmap_1be_32_to_32 at pixman_utils.c:1343
 #5 spice_bitmap_to_pixman at pixman_utils.c:1524
 #6 spice_bitmap_convert_to_pixman at pixman_utils.c:1579
 #7 canvas_bitmap_to_surface at ../spice-common/common/canvas_base.c:657
 #8 canvas_get_bits at ../spice-common/common/canvas_base.c:943
 #9 canvas_get_image_internal at ../spice-common/common/canvas_base.c:1141
 #10 canvas_get_image at ../spice-common/common/canvas_base.c:1285
 #11 canvas_draw_blend at ../spice-common/common/canvas_base.c:2627
Comment 11 Cole Robinson 2013-09-27 08:07:04 EDT
Bug marked private? ill just privatize all the abrt content
Comment 12 Cole Robinson 2013-09-27 08:07:34 EDT
*** Bug 1012717 has been marked as a duplicate of this bug. ***
Comment 13 Cole Robinson 2013-09-27 08:08:46 EDT
FYI two hits in as many days since F20 alpha went out, this will probably be a hot issue.
Comment 14 Bobby Powers 2013-09-27 09:05:42 EDT
I'm happy to debug or test patches. Let me know if there is any way I can help, although I don't really have time to dig into the spice code myself.
Comment 15 Cole Robinson 2013-09-27 09:14:58 EDT
(In reply to Bobby Powers from comment #14)
> I'm happy to debug or test patches. Let me know if there is any way I can
> help, although I don't really have time to dig into the spice code myself.

Were you doing anything particular when it crashed? Has it crashed more than once and if so how frequently?
Comment 16 Bobby Powers 2013-09-27 09:42:42 EDT
I had about 5 or 6 yesterday, at least.  It was all when I was interacting with the guest - either typing or mouse.  I assume this is because it was sending damage updates through the spice driver.  I also have dual monitors, although I don't think that is related.  Finally, I've seen it both in fullscreen as well as windowed mode. I may have an old version of the Red Hat QXL GPU driver '6.1.0.10016' from 10/15/2012.  I can try installing the latest Windows guest tools from the spice-space site if that is a good idea.
Comment 17 Bobby Powers 2013-09-27 10:09:29 EDT
And it continues today.  It seems to happen most often with full-screen refresh/ events, such as opening visual studio, or visual studio opening the application I'm attempting to debug.  During heavy use, virt-manager crashes every 15 seconds - 1 min, or so.  I've updated to the latest 0.65 release of windows spice guest tools which have the latest QXL driver, but it doesn't seem to have any difference.
Comment 18 Marc-Andre Lureau 2013-09-27 10:37:25 EDT
Bobby, is the guest configured with dual monitor too (2 qxl devices)? thanks
Comment 19 Bobby Powers 2013-09-27 11:28:51 EDT
Marc - nope! The guest is a single qxl device, I've seen crashes at multiple resolutions, currently at 1920x1080.
Comment 20 Marc-Andre Lureau 2013-10-03 07:56:48 EDT
Bobby, I haven't been able to reproduce your exact crash in 32bpp. However, a similar crash can be easily triggered in 16bpp. And the reason is very likely the same, as we have a recent regression in palette cache handling. I sent a fix to ML:

http://lists.freedesktop.org/archives/spice-devel/2013-October/014717.html

If you are able to recompile spice-gtk, it would be nice if you could verify removing palette_remove() from palette_release() solves it for you too.

In any case, I'll build a f20 update asap.
Comment 21 Fedora Update System 2013-10-03 10:41:39 EDT
spice-gtk-0.21-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/spice-gtk-0.21-3.fc20
Comment 22 Fedora Update System 2013-10-03 21:55:54 EDT
Package spice-gtk-0.21-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spice-gtk-0.21-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18235/spice-gtk-0.21-3.fc20
then log in and leave karma (feedback).
Comment 23 Fedora Update System 2013-11-10 01:33:24 EST
spice-gtk-0.21-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.