Bug 1011975 - EAP62_0600 - PicketLink STS - Productize (missing)
EAP62_0600 - PicketLink STS - Productize (missing)
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: PicketLink (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER7
: EAP 6.2.0
Assigned To: Peter Skopek
Josef Cacek
Russell Dickenson
:
Depends On:
Blocks: 1015393 1030937
  Show dependency treegraph
 
Reported: 2013-09-25 09:30 EDT by Ondrej Lukas
Modified: 2017-05-31 09:11 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:55:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Lukas 2013-09-25 09:30:37 EDT
PicketLink STS - Productize is not presented in EAP 6.2.0.ER3
Comment 4 Paul Gier 2013-09-27 08:59:52 EDT
Josef: Yes, as I understand it, the requirement is to get the new picketlink quickstarts included with EAP 6.2.

However, I agree with Ondrej that it doesn't make sense to include quickstarts which are dependent on picketlink 2.5, unless we also upgrade in EAP.
Comment 8 John Doyle 2013-10-02 06:27:56 EDT
My intention is to support STS in the same manner as we support the other quickstarts.  Customers are free to contact GSS with questions about the QS, but we will not provide patches as it is provided as an example that customer may modify.  We should not provide it as a Module/service delivered with EAP.

I agree to exempt this from the Beta if necessary.
Comment 9 Peter Skopek 2013-10-11 11:13:15 EDT
Pull request files:
https://github.com/jboss-developer/jboss-eap-quickstarts/pull/675
Comment 10 sgilda 2013-10-16 12:46:49 EDT
The quickstart was merged and I made all the changes I could make to the instructions, but the README still needs information.

Under 'Access the Application", we need to tell them what to expect.

When I access http://localhost:8080/jboss-picketlink-sts, I get this dialog prompt:

        The server http:localhost:8080 requires a username and password. The server says PicketLinkSTSRealm.

I see users in the users.properties file but none of them seem to work.

Do you need to add users using the add-user.sh script for this application? 
Or is something hard-coded? 
What do I enter for the user/password to gain access?

We need to provide instructions for after the app is deployed.
Comment 11 sgilda 2013-10-30 10:00:50 EDT
Following the chain of pulls, it looks like this was the final one: 
https://github.com/jboss-developer/jboss-eap-quickstarts/pull/683

This was the commit:
https://github.com/sgilda/jboss-as-quickstart/commit/2654bb51647e78b39b0cd7dfb58d6aa54c8e5c13

This was merged a few weeks ago, so I think this one can be marked as modifed.
Comment 12 sgilda 2013-10-30 10:20:10 EDT
The commmit to the 6.2.1 branch was done on Oct. 16:

https://github.com/jboss-developer/jboss-eap-quickstarts/commit/633c582ce5acaa07ef1d3d34879e3e8735e194ee
Comment 13 Josef Cacek 2013-11-21 06:15:14 EST
Verified in CR1.

Note You need to log in before you can comment on or make changes to this bug.