Bug 1015393 - Impossible to build any picketlink quickstarts example due to BOM version change
Impossible to build any picketlink quickstarts example due to BOM version change
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ER5
: EAP 6.2.0
Assigned To: sgilda
Vladimir Rastseluev
:
Depends On: 1011975
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 02:01 EDT by Vladimir Rastseluev
Modified: 2017-10-09 20:17 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:23:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jcacek: needinfo? (psilva)
sgilda: needinfo-


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1011851 None None None Never
Red Hat Bugzilla 1016602 None None None Never

  None (edit)
Description Vladimir Rastseluev 2013-10-04 02:01:24 EDT
Description of problem:
In EAP 6.2.0 ER4 picketlink quickstarts examples was changed version of artifact
<version.jboss.bom.eap>6.2.0.Beta1</version.jboss.bom.eap>
It causes impossibility to build any of this examples even using workaround, described in https://bugzilla.redhat.com/show_bug.cgi?id=1011917 (using generated maven repo)

Version-Release number of selected component (if applicable):
EAP 6.2.0 ER4

How reproducible:
easy

Steps to Reproduce:
1. go to any of picketlink-quickstarts/ subdirectory
2. mvn clean install

Actual results:

[vrastsel@war picketlink-deltaspike-authorization]$ mvn install
[INFO] Scanning for projects...
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building JBoss WFK Quickstart: picketlink-deltaspike-authorization 6.2.0.Beta1
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for org.picketlink:picketlink-api:jar:2.1.6.3.Final-redhat-2 is missing, no dependency information available
[WARNING] The POM for org.picketlink:picketlink-impl:jar:2.1.6.3.Final-redhat-2 is missing, no dependency information available
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.046s
[INFO] Finished at: Fri Oct 04 07:50:45 CEST 2013
[INFO] Final Memory: 3M/51M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project jboss-as-picketlink-deltaspike-authorization: Could not resolve dependencies for project org.jboss.quickstarts.eap:jboss-as-picketlink-deltaspike-authorization:war:6.2.0.Beta1: The following artifacts could not be resolved: org.picketlink:picketlink-api:jar:2.1.6.3.Final-redhat-2, org.picketlink:picketlink-impl:jar:2.1.6.3.Final-redhat-2: Failure to find org.picketlink:picketlink-api:jar:2.1.6.3.Final-redhat-2 in https://repository.jboss.org/nexus/content/groups/public-jboss was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException

Expected results:
build success

Additional info: p
revioud version of these quickstarts used version
 <version.jboss.bom.eap>6.2.0-redhat-1</version.jboss.bom.eap>
Comment 1 Pete Muir 2013-10-04 05:57:40 EDT
Yes, I think this is a major problem. It looks like Paul Gier did not finish this before he went on PTO, and no one on the JBoss Developer team (Sande, me, Rafael) is clear what is plan was here.

Vaclav, do you know what the plan is, who would know, besides Paul?
Comment 2 sgilda 2013-10-04 07:32:37 EDT
Adding Rafael and Pedro Igor to this bug.
Comment 3 Rafael Benevides 2013-10-04 08:50:30 EDT
My tip is that PL should use the same EAP BOM Version from the other EAP Quickstarts. At the moment is not clear to me what version/tag is this because because pgier used the SNAPSHOT version to get the latest EAP BOMs to test.
Comment 5 sgilda 2013-10-04 13:30:58 EDT
Per @pmuir: We are moving the PicketLink quickstart from EAP to the sandbox for now.

This was already done by Rafael in upstream/master so it will appear after the merge.
Comment 12 Vladimir Rastseluev 2013-10-10 03:03:42 EDT
There aren't picketlink examples in EAP 6.2.0 ER 5. Verified

Note You need to log in before you can comment on or make changes to this bug.