Bug 1012058 - [RHSC] Option 'Select as SPM' seen under Hosts tab of RHSC
[RHSC] Option 'Select as SPM' seen under Hosts tab of RHSC
Status: CLOSED DUPLICATE of bug 1019570
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Ramesh N
Shruti Sampat
:
Depends On: 1008980 1019570
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 11:47 EDT by Shruti Sampat
Modified: 2015-05-13 12:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1008980
Environment:
Last Closed: 2013-10-30 05:56:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (124.95 KB, image/png)
2013-09-25 11:47 EDT, Shruti Sampat
no flags Details

  None (edit)
Description Shruti Sampat 2013-09-25 11:47:44 EDT
Created attachment 802928 [details]
screenshot

+++ This bug was initially created as a clone of Bug #1008980 +++

Description of problem:
------------------------
In RHSC, the button 'Select as SPM' is seen under the hosts tab. This is not relevant in the context of a gluster host and should be removed.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.1-0.0.1.master.el6ev 

How reproducible:
Always

Steps to Reproduce:
1. Install RHSC
2. Navigate to the hosts tab.

Actual results:
The button 'Select as SPM' is seen.

Expected results:
This button is not relevant for a host in a gluster cluster, so it should be removed.

Additional info:
Screenshot attached.
Comment 2 Prasanth 2013-10-11 05:09:46 EDT
FVollowing is seen in vdsm.log as well:

-------------
Thread-4124::ERROR::2013-10-11 14:22:20,881::task::850::TaskManager.Task::(_setError) Task=`6ddf5866-9a49-4bdd-9747-a0f599f45f08`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 857, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/logUtils.py", line 45, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/storage/hsm.py", line 2146, in getAllTasksInfo
    raise se.SpmStatusError()
SpmStatusError: Not SPM: ()
Thread-4124::DEBUG::2013-10-11 14:22:20,889::task::869::TaskManager.Task::(_run) Task=`6ddf5866-9a49-4bdd-9747-a0f599f45f08`::Task._run: 6ddf5866-9a49-4bdd-9747-a0f599f45f08 () {} failed - stopping task
-------------
Comment 3 Ramesh N 2013-10-30 05:56:07 EDT

*** This bug has been marked as a duplicate of bug 1008980 ***
Comment 4 Ramesh N 2013-10-30 05:57:20 EDT

*** This bug has been marked as a duplicate of bug 1019570 ***

Note You need to log in before you can comment on or make changes to this bug.