Bug 1012068 - katello-configure fails silently when certain services fail to start
katello-configure fails silently when certain services fail to start
Status: CLOSED DUPLICATE of bug 1003961
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 12:08 EDT by Og Maciel
Modified: 2014-01-27 09:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:20:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2013-09-25 12:08:51 EDT
Description of problem:

This has been around for a while and it is such a basic functionality for installing Katello that I just have to bug developers to fix it asap.

Basically, if a service such as tomcat6 fails to start (for whatever reason) during katello-configure, the configuration will proceed to finish as if nothing had happened. The end user is left with the impression that all is good, when katello is not actually properly configured

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. You'd have to cause tomcat6 to fail during the installation OR find a way for another service such as pulp to fail from starting
2.
3.

Actual results:

katello-configure finishes without alerting that something went wrong

Expected results:

katello-configure should fail and alert the user

Additional info:
Comment 1 Og Maciel 2013-09-25 12:12:38 EDT
Another way to make it fail is to install java-1.7.0-openjdk *before* configuring katello.

Versions used:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-5.el6sat.noarch
* foreman-compute-1.3.0-5.el6sat.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.3.0-5.el6sat.noarch
* foreman-postgresql-1.3.0-5.el6sat.noarch
* foreman-proxy-1.3.0-1.el6sat.noarch
* katello-1.4.6-9.el6sat.noarch
* katello-all-1.4.6-9.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-13.el6sat.noarch
* katello-cli-common-1.4.3-13.el6sat.noarch
* katello-common-1.4.6-9.el6sat.noarch
* katello-configure-1.4.5-8.el6sat.noarch
* katello-configure-foreman-1.4.5-8.el6sat.noarch
* katello-configure-foreman-proxy-1.4.5-8.el6sat.noarch
* katello-foreman-all-1.4.6-9.el6sat.noarch
* katello-glue-candlepin-1.4.6-9.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-9.el6sat.noarch
* katello-glue-pulp-1.4.6-9.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.14.alpha.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.14.alpha.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.14.alpha.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.14.alpha.el6sat.noarch
* pulp-selinux-2.3.0-0.14.alpha.el6sat.noarch
* pulp-server-2.3.0-0.14.alpha.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.20-3.el6sat.noarch
* signo-katello-0.0.20-3.el6sat.noarch
Comment 3 Ivan Necas 2013-10-17 09:20:04 EDT

*** This bug has been marked as a duplicate of bug 1003961 ***

Note You need to log in before you can comment on or make changes to this bug.