Bug 1012144 - remove the %pre/%post hooks in Storage specfile
remove the %pre/%post hooks in Storage specfile
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: redhat-access-plugin-rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Spenser Shumaker
Prasanth
: ZStream
Depends On: 1012145
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 16:04 EDT by Jeffrey McGowan
Modified: 2015-05-15 14:17 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:40:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey McGowan 2013-09-25 16:04:49 EDT

    
Comment 4 Prasanth 2013-12-18 09:05:19 EST
Please provide the steps to verify this bug.
Comment 5 Prasanth 2013-12-20 13:21:30 EST
Bala/Spencer,

Please provide the steps to verify this bug.
Comment 6 Bala.FA 2013-12-20 21:03:19 EST
I have no clue about this bug.

Jeffrey/Spencer, please provide your inputs for comment#5
Comment 7 Spenser Shumaker 2013-12-23 14:50:29 EST
Hi Prasanth and Bala,

The bug can be verified by checking that the "redhat-support-plugin-rhsc.spec" file no longer has statements that modify rhsc's application.xml.  More clearly, the statement below should no longer exist in the "redhat-support-plugin-rhsc.spec" file.

%posttrans
# Formerly %post, ensures that the redeploy isn't done until the very end of install/upgrade processes
if ! grep -q '<web-uri>redhat-support-plugin-rhev.war</web-uri>'  /usr/share/ovirt-engine/engine.ear/META-INF/application.xml; then
	sed -i '/<\/application>/i \
	<!-- START Red Hat Support Plug-in DO NOT REMOVE THIS COMMENT --> \
	<module> \
	<web> \
	<web-uri>redhat-support-plugin-rhev.war<\/web-uri> \
	<context-root>\/redhat-support-plugin-rhev<\/context-root> \
	<\/web> \
	<\/module> \
	<!-- END Red Hat Support Plug-in DO NOT REMOVE THIS COMMENT -->' /usr/share/ovirt-engine/engine.ear/META-INF/application.xml
fi
Comment 8 Prasanth 2014-01-02 06:42:37 EST
Verified.
Comment 10 errata-xmlrpc 2014-02-25 02:40:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.