Bug 101217 - (ACPI) 8139too transmit timeouts without pci=noacpi specified
(ACPI) 8139too transmit timeouts without pci=noacpi specified
Status: CLOSED UPSTREAM
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-30 02:52 EDT by Steve Ward
Modified: 2013-07-02 22:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 03:44:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of acpidmp under 2.6.0-test1 (71.84 KB, text/plain)
2003-07-30 02:54 EDT, Steve Ward
no flags Details
output of dmidecode (5.15 KB, text/plain)
2003-07-30 02:54 EDT, Steve Ward
no flags Details
dmesg output, failure case (2.4 kernel) (12.03 KB, text/plain)
2003-07-31 03:58 EDT, Steve Ward
no flags Details
dmesg output, success case (2.4 kernel) (9.60 KB, text/plain)
2003-07-31 03:58 EDT, Steve Ward
no flags Details
/proc/interrupts, failure case (2.4 kernel) (515 bytes, text/plain)
2003-07-31 03:59 EDT, Steve Ward
no flags Details
/proc/interrupts, success case (2.4 kernel) (515 bytes, text/plain)
2003-07-31 03:59 EDT, Steve Ward
no flags Details
content of /proc/bus/usb/devices (1.69 KB, text/plain)
2003-08-06 03:57 EDT, Steve Ward
no flags Details
dmesg output, 2.4 smp kernel (14.94 KB, text/plain)
2003-08-17 22:02 EDT, Steve Ward
no flags Details
/proc/interrupts from 2.4 smp kernel (619 bytes, text/plain)
2003-08-17 22:02 EDT, Steve Ward
no flags Details
fixed compile time bug reported by iasl (124.54 KB, text/plain)
2003-08-21 07:14 EDT, Luming Yu
no flags Details
Try to disable IRQ 0 for PCI Interrupt Link at PIC mode. (327 bytes, patch)
2003-08-21 07:23 EDT, Luming Yu
no flags Details | Diff
Patch to resolve interrupt problems with ACPI (12.21 KB, patch)
2003-08-21 15:47 EDT, Jun Nakajima
no flags Details | Diff
output of lcpci -vv (smp kernel) (7.78 KB, text/plain)
2003-08-21 16:42 EDT, Steve Ward
no flags Details
my config file (37.81 KB, text/plain)
2003-08-22 06:32 EDT, Luming Yu
no flags Details
dmesg output, success w/patch (10.79 KB, text/plain)
2003-08-23 00:00 EDT, Steve Ward
no flags Details

  None (edit)
Description Steve Ward 2003-07-30 02:52:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
on-board RTL-8139C fails to work (transmit timeouts) unless pci=noacpi specified
on boot command line.  Tried with both 2.4.21 and 2.6.0-test1 same result. 
Output of dmidecode and acpidmp attached.  

Version-Release number of selected component (if applicable):
2.4.21-20.1.2024.2.1.nptl, 2.6.0-0.test1.1.26

How reproducible:
Always

Steps to Reproduce:
1. Boot system without pci=noacpi.

    

Actual Results:  8139too module loads, appears to work but error on dmesg and
syslog indicates transmit timeout errors.  No routes to network. Can ping
interface itself but cannot ping any other systems on network.

Expected Results:  interface should have come up and run properly.

Additional info:

System board is Soyo P4X400 Dragon Ultra Platinum.
Comment 1 Steve Ward 2003-07-30 02:54:01 EDT
Created attachment 93251 [details]
output of acpidmp under 2.6.0-test1
Comment 2 Steve Ward 2003-07-30 02:54:26 EDT
Created attachment 93252 [details]
output of dmidecode
Comment 3 Len Brown 2003-07-31 01:17:35 EDT
Please add the dmesg and /proc/interrupts output for the success and failing 
cases.

Comment 4 Steve Ward 2003-07-31 03:58:11 EDT
Created attachment 93289 [details]
dmesg output, failure case (2.4 kernel)
Comment 5 Steve Ward 2003-07-31 03:58:46 EDT
Created attachment 93290 [details]
dmesg output, success case (2.4 kernel)
Comment 6 Steve Ward 2003-07-31 03:59:22 EDT
Created attachment 93291 [details]
/proc/interrupts, failure case (2.4 kernel)
Comment 7 Steve Ward 2003-07-31 03:59:54 EDT
Created attachment 93292 [details]
/proc/interrupts, success case (2.4 kernel)
Comment 8 Len Brown 2003-08-05 18:00:42 EDT
According to /proc/interrupts, both acpi and pci=noacpi came up with the same 
XT-PIC interrupt config -- but the acpi case gets no interrupts on eth0. 
 
In both cases, eth0 shares IRQ10 with USB, and according to dmesg the same USB 
controller in both cases.  There are lots of interrupts on the other unshared USB 
controller.  What USB devices are actually present -- can you attach the info from 
/proc/bus/usb? 
 
It would be interesting to see if the ethernet works when there are no USB devices in 
the system -- seems like an interrupt sharing issue. 
 
Comment 9 Steve Ward 2003-08-06 03:52:46 EDT
OK, tried several things.  Disconnected all USB devices (one ActionStar USB
switch, and one RailDriver Modern Desktop, neither supported under Linux) and
tried booting without PCI=noacpi, failed as before.  Disabled all USB
controllers (system has a total of 6 USB ports, 1.1 and 2.0), without
PCI=noacpi, failed as before.  Switched BIOS from PnP=no to PnP=yes, failed as
before (USB disabled and enabled).
Comment 10 Steve Ward 2003-08-06 03:57:30 EDT
Created attachment 93425 [details]
content of /proc/bus/usb/devices
Comment 11 Jun Nakajima 2003-08-17 19:44:03 EDT
Looks like the kernel is UP/PIC mode, can you try an SMP kernel. I think we 
should see better results becaue _PRT for APIC is much simpler.
I think this system is DP or HT system.

Comment 12 Steve Ward 2003-08-17 22:01:27 EDT
2.4 smp kernel works.  However, this is a UP system (with an HT-aware BIOS).
attaching dmesg and /proc/interrupts outputs.
Comment 13 Steve Ward 2003-08-17 22:02:21 EDT
Created attachment 93697 [details]
dmesg output, 2.4 smp kernel
Comment 14 Steve Ward 2003-08-17 22:02:53 EDT
Created attachment 93698 [details]
/proc/interrupts from 2.4 smp kernel
Comment 15 Jun Nakajima 2003-08-20 15:31:51 EDT
We've got this machine, and updated the BIOS 
(http://www.soyousa.com/downloads/selectresults.php?
language=&col1=Proc_Intel+Pentium+4&col2=159&col3=BIOS+Upgrade)
to the latest . We were able to reproduce the problem with the RH kernel, but 
2.6 with full ACPI worked fine with UP/PIC mode.
So I think the problem is specific to that kernel. We are trying the stock 
2.4.22 kernel.
Comment 16 Steve Ward 2003-08-21 01:17:24 EDT
Am also running the latest BIOS release (2AA7).

The unofficial RedHat 2.6-test kernels have also failed for me in UP mode.  SMP
works.

http://people.redhat.com/arjanv/2.5/RPMS.kernel/
Comment 17 Luming Yu 2003-08-21 07:14:42 EDT
Created attachment 93815 [details]
fixed compile time bug reported by iasl

Would you please try overriding DSDT using dsdtfixed.dsl. There are some
compile-time bug caught by iasl.
Comment 18 Luming Yu 2003-08-21 07:23:22 EDT
Created attachment 93816 [details]
Try to disable IRQ 0 for PCI Interrupt Link at PIC mode.


Would you please try this patch. I also need output of lspci -vv for smp
kernel.

Ps. This patch is just for testing , I need to narrow down the problem.
Comment 19 Jun Nakajima 2003-08-21 11:26:13 EDT
Can you test 2.6.0-test3 with UP/ACPI? Ours worked fine on this machine, and we 
found different behavior with PCI Link device settings. We are root-causing it. 
Comment 20 Jun Nakajima 2003-08-21 11:49:01 EDT
Sorry, please stop tesing 2.6.0-test3. Our tree has changes in BK tree. 
Comment 21 Jun Nakajima 2003-08-21 15:47:10 EDT
Created attachment 93824 [details]
Patch to resolve interrupt problems with ACPI

With this patch, Serven kernel correctly sets up PCI interrrupt routing, and
the network works fine. Encourage to try this on other machines.
Comment 22 Steve Ward 2003-08-21 16:42:44 EDT
Created attachment 93828 [details]
output of lcpci -vv (smp kernel)
Comment 23 Steve Ward 2003-08-21 16:49:03 EDT
can someone point me to how to override the dsdt?
Comment 24 Len Brown 2003-08-21 18:19:34 EDT
Please try the kernel patch that Jun attached earlier today, and you may not have 
to tinker with your DSDT. 
 
 
Comment 25 Steve Ward 2003-08-21 20:42:02 EDT
Applied patch, unable to get kernel to build...

ld -m elf_i386 -T /usr/src/linux-2.4.21-20.1.2024.2.1.nptl/arch/i386/vmlinux.lds
-e stext arch/i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o
init/version.o init/do_mounts.o --start-group arch/i386/kernel/kernel.o
arch/i386/mm/mm.o kernel/kernel.o mm/mm.o fs/fs.o ipc/ipc.o  drivers/acpi/acpi.o
drivers/char/char.o drivers/block/block.o drivers/misc/misc.o drivers/net/net.o
drivers/char/drm/drm.o drivers/net/fc/fc.o drivers/net/appletalk/appletalk.o
drivers/net/tokenring/tr.o drivers/net/wan/wan.o drivers/atm/atm.o
drivers/ide/idedriver.o drivers/cdrom/driver.o drivers/pci/driver.o
drivers/net/pcmcia/pcmcia_net.o drivers/net/wireless/wireless_net.o
drivers/pnp/pnp.o drivers/video/video.o drivers/media/media.o drivers/md/mddev.o
drivers/isdn/vmlinux-obj.o drivers/sensors/sensor.o net/network.o
/usr/src/linux-2.4.21-20.1.2024.2.1.nptl/arch/i386/lib/lib.a
/usr/src/linux-2.4.21-20.1.2024.2.1.nptl/lib/lib.a
/usr/src/linux-2.4.21-20.1.2024.2.1.nptl/arch/i386/lib/lib.a --end-group -o
.tmp_vmlinux1
fs/fs.o(.text+0x372e2): In function `zisofs_readpage':
: undefined reference to `zlib_inflateInit_'
fs/fs.o(.text+0x373e4): In function `zisofs_readpage':
: undefined reference to `zlib_inflate'
fs/fs.o(.text+0x37496): In function `zisofs_readpage':
: undefined reference to `zlib_inflateEnd'
fs/fs.o(.text.init+0xacc): In function `mnt_init':
: undefined reference to `init_rootfs'
fs/fs.o(.text.init+0xff1): In function `zisofs_init':
: undefined reference to `zlib_inflate_workspacesize'
make[1]: *** [kallsyms] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.21-20.1.2024.2.1.nptl'
make: *** [vmlinux] Error 2

using the kernel-source rpm and the configs/kernel-2.4.21-i686.config

I did double check and gcc32 is being used to build.
Comment 26 Luming Yu 2003-08-22 06:32:03 EDT
Created attachment 93853 [details]
my config file 

Have my.config a try. It works for me. 
I also need the dmesg, if you resolve your problem using jun's patch

Thanks,
Luming
Comment 27 Steve Ward 2003-08-22 23:59:44 EDT
The patch does appear to work correctly.  Don't suppose it will apply against
2.6.0-test3???  I usually run 2.6 to get AGP3 support...

dmesg output attached below...
Comment 28 Steve Ward 2003-08-23 00:00:36 EDT
Created attachment 93877 [details]
dmesg output, success w/patch
Comment 29 Len Brown 2003-08-23 00:54:50 EDT
thanks for trying it out and supplying the dmesg. 
this patch is already in the latest 2.6.0 bk tree. 
 
Comment 30 Steve Ward 2003-08-23 05:09:21 EDT
btw, confirmed working correctly under linus 2.6.0-test4

Note You need to log in before you can comment on or make changes to this bug.