Bug 1012545 - deadlock in Garbage Collection Start Event callback
deadlock in Garbage Collection Start Event callback
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt-java-connector (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1012827
  Show dependency treegraph
 
Reported: 2013-09-26 11:38 EDT by Jakub Filak
Modified: 2016-11-30 19:45 EST (History)
3 users (show)

See Also:
Fixed In Version: abrt-java-connector-1.0.6-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1012827 (view as bug list)
Environment:
Last Closed: 2013-10-09 21:07:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Deadlock backtrace (78.87 KB, text/plain)
2013-09-26 11:48 EDT, Jakub Filak
no flags Details

  None (edit)
Description Jakub Filak 2013-09-26 11:38:23 EDT
Description of problem:
All abrt-java-connector event callbacks enter a single private critical section. Some callbacks may trigger a GC run while being in the critical section. The GC start callback also wants to enter the critical section but the critical section is locked because the triggering callback waits until the GC run finishes. So both callbacks are waiting for each other.

Version-Release number of selected component (if applicable):
abrt-java-connector-1.0.5-1.fc19

How reproducible:
Accidentally

Steps to Reproduce:
1. run a sufficiently big application for a sufficiently long time
Comment 1 Jakub Filak 2013-09-26 11:48:32 EDT
Created attachment 803476 [details]
Deadlock backtrace

A full backtrace of a deadlock between callback_on_gc_start and callback_on_object_alloc
Comment 2 Jakub Filak 2013-09-27 04:39:05 EDT
Upstream commit d84b4c8883bc145b0afa6b89f025dea1fa98cc3c fixes this bug.
Comment 3 Fedora Update System 2013-10-01 10:50:12 EDT
abrt-java-connector-1.0.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/abrt-java-connector-1.0.6-1.fc19
Comment 4 Fedora Update System 2013-10-02 02:38:51 EDT
Package abrt-java-connector-1.0.6-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-java-connector-1.0.6-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18097/abrt-java-connector-1.0.6-1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-10-09 21:07:59 EDT
abrt-java-connector-1.0.6-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.