This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1012827 - deadlock in Garbage Collection Start Event callback
deadlock in Garbage Collection Start Event callback
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: abrt-java-connector (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: ---
Assigned To: Jakub Filak
Lukas Zachar
: Rebase
: 1020711 1023157 (view as bug list)
Depends On: 1012545
Blocks: 1018804 1020711
  Show dependency treegraph
 
Reported: 2013-09-27 04:36 EDT by Jakub Filak
Modified: 2016-11-30 19:45 EST (History)
7 users (show)

See Also:
Fixed In Version: abrt-java-connector-1.0.6-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Important: if this rebase instead contains *only bug fixes,* or *only enhancements*, select the correct option from the Doc Type drop-down list. Rebase package(s) to version: 1.0.6 Highlights, important fixes, or notable enhancements: Makes the implementation more thread safe and disables experimental features.
Story Points: ---
Clone Of: 1012545
Environment:
Last Closed: 2014-06-13 08:06:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Filak 2013-09-27 04:36:01 EDT
+++ This bug was initially created as a clone of Bug #1012545 +++

Description of problem:
All abrt-java-connector event callbacks enter a single private critical section. Some callbacks may trigger a GC run while being in the critical section. The GC start callback also wants to enter the critical section but the critical section is locked because the triggering callback waits until the GC run finishes. So both callbacks are waiting for each other.

Version-Release number of selected component (if applicable):
abrt-java-connector-1.0.5-1.fc19

How reproducible:
Accidentally

Steps to Reproduce:
1. run a sufficiently big application for a sufficiently long time

--- Additional comment from Jakub Filak on 2013-09-26 17:48:32 CEST ---

A full backtrace of a deadlock between callback_on_gc_start and callback_on_object_alloc
Comment 3 jiri vanek 2013-10-31 05:02:45 EDT
*** Bug 1023157 has been marked as a duplicate of this bug. ***
Comment 5 Nathan Kinder 2013-11-01 17:24:16 EDT
*** Bug 1020711 has been marked as a duplicate of this bug. ***
Comment 7 Ludek Smid 2014-06-13 08:06:15 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.