Bug 1012559 - The JON product consoles should display the functionality, not the name of the Community Project
The JON product consoles should display the functionality, not the name of th...
Status: CLOSED DUPLICATE of bug 988720
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other, Productization (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ---
: JON 3.4.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: JON3-28/PM-400/PRODMGT-361
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 12:05 EDT by Divya Mehra
Modified: 2015-07-09 10:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-09 10:52:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Divya Mehra 2013-09-26 12:05:34 EDT
Description of problem:

https://bugzilla.redhat.com/show_bug.cgi?id=999110

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
- When leveraging a JBoss project in a product, such as Infinispan in EAP, the product console should display the Functionality provided by that component, and not the name of the corresponding Community project.

- the EAP console has been adjusted accordingly:
 https://bugzilla.redhat.com/show_bug.cgi?id=999110

- Please apply the same to the JON console (for EAP, and possibly similar situations with other products)

Additional info:
Comment 2 Jay Shaughnessy 2014-09-03 17:37:23 EDT
I think this would require the individual plugins to be able to distinguish between product/project installs and adjust resource names as appropriate.  I'm not 100% sure this is the intent of the BZ, that's my best guess.  Id so we'd need to compile the list of relevant plugins and see what can be done.
Comment 3 Larry O'Leary 2015-01-05 12:39:28 EST
Once again, this did not make the release.

This is also a long standing product requirement that was originally captured in bug 988720 but is consistently deferred due to the impact of such a change. The problem is that the component names in question are driven from the resource type. A change to the resource type would break all existing deployments.

I will not mark this BZ a duplicate as it highlights a slightly different concept/requirement then BZ 988720. In this case we are asking to use a category/classification rather then a project or product name. For example:

> JGroups > Group Communication
> mod_cluster > Load Balancing
> Infinispan > Caching
> Jacorb > Corba

Moving for consideration in a future minor/major release.
Comment 4 Filip Brychta 2015-07-09 10:52:00 EDT

*** This bug has been marked as a duplicate of bug 988720 ***

Note You need to log in before you can comment on or make changes to this bug.