Bug 1012597 - JON unable to discover EAP servers when EAP domain mode is started from external folders
JON unable to discover EAP servers when EAP domain mode is started from exter...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.2
Unspecified All
unspecified Severity urgent
: ER03
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 13:28 EDT by Sudheer
Modified: 2014-01-02 15:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modified config files (9.47 KB, application/zip)
2013-09-26 13:28 EDT, Sudheer
no flags Details

  None (edit)
Description Sudheer 2013-09-26 13:28:51 EDT
Created attachment 803494 [details]
modified config files

Description of problem:
JON unable to discover EAP servers when EAP domain mode is started from external folders

Version-Release number of selected component (if applicable):
EAP 6.1.1
JON 3.1.2 and associated agent and plugins

How reproducible:


Steps to Reproduce:
1. Make copies of <EAP-home>/domain folder as machine1, machine2 and machine3
2. make appropraite changes to domain, host-master.xml and host-slave.xml files in machine1, 2, 3 folders (see attachement) to simulate

machine 1- domain controller
machine 2 - server-one and server-two (EAP servers)
machine 3 - server-three

3. start servers
./domain.sh --host-config=host-master.xml -Djboss.domain.base.dir=/machine1/

./domain.sh -Djboss.domain.base.dir=/machine2/ --host-config=host-slave.xml -Djboss.domain.master.address=127.0.0.1

./domain.sh -Djboss.domain.base.dir=/machine3/ --host-config=host-slave.xml -Djboss.domain.master.address=127.0.0.1

Actual results:
JON did discovered domain controller but not teh EAP servers. "managed servers" folder was missing

Expected results:

However when I start EAP in domain mode with out of the box setting. JON worked fine and dsicovered all the EAP servers
Additional info:
Comment 1 Larry O'Leary 2013-09-27 09:43:03 EDT
This appears to be the same/duplicate of bug 969621. An agent debug log would be required to confirm.
Comment 3 Libor Zoubek 2013-10-08 10:08:11 EDT
Sudheer, 

I've tried out your config files.  It didn't work for me. Your config files for slave host controllers did not define http management interfaces, thatswhy agent was not able to talk to machine2 and 3 controllers at all. In my case, agent discovered host controllers and detected port 0 (Which is Bug 1016678)

Please add (for machine2)

<http-interface security-realm="ManagementRealm">
 <socket interface="management" port="${jboss.management.http.port:29990}"/>
</http-interface>

under "management-interfaces" element.

after changing host-slave.xml files like mentioned above managed servers are correctly discovered. 

verified on JON 3.2.0.ER3

Note You need to log in before you can comment on or make changes to this bug.