Bug 101275 - fatal error: lu_homedir_populate() called with non-NULL
Summary: fatal error: lu_homedir_populate() called with non-NULL
Status: CLOSED DUPLICATE of bug 135625
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: libuser (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: s390 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 101028
TreeView+ depends on / blocked
 
Reported: 2003-07-30 15:53 UTC by Neale Ferguson
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Neale Ferguson 2003-07-30 15:53:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Description of problem:
After entering the user information and clicking "Ok" the application
automatically closes and I receive:
libuser fatal error: lu_homedir_populate() called with non-NULL
*error/usr/share/redhat-config-users/redhat-config-users: line 4:  9499 Aborted
                /usr/bin/python2.2
/usr/share/redhat-config-users/redhat-config-users.py


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start redhat-config-users
2. Add details for a new user
3. Click OK
    

Actual Results:  User details are added to /etc/passwd, /etc/shadow,
/etc/group,/etc/gshadow but no home directory is created, the application
terminates and the following message is displayed:
libuser fatal error: lu_homedir_populate() called with non-NULL
*error/usr/share/redhat-config-users/redhat-config-users: line 4:  9499 Aborted
                /usr/bin/python2.2
/usr/share/redhat-config-users/redhat-config-users.py

Expected Results:  User should have been added and home directory populated.

Additional info:

Comment 1 Neale Ferguson 2003-07-30 20:09:57 UTC
redhat-config-users works fine with the s390x beta1.

Comment 2 Brent Fox 2003-07-31 16:38:01 UTC
That error message looks like it is coming from libuser.  Changing components.

Comment 3 Harald Hoyer 2003-08-14 14:08:20 UTC
workx for me:
# rpm -q libuser redhat-config-users
libuser-0.51.7-1
redhat-config-users-1.1.12-2


Comment 4 Neale Ferguson 2003-08-14 14:26:53 UTC
My level of redhat-config-users is: redhat-config-users-1.1.10-2. I can't use
up2date as I'm beta testing both the 32 & 64-bit versions of taroon and I
registered under the latter one first and cannot get enabled when I register for
the 32-bit stuff.

Comment 5 Florian La Roche 2003-09-05 10:27:34 UTC
I assume this is fixed and I think the RHN account issue is also
fixed. Re-open if something is left todo...

greetings,

Florian La Roche


Comment 6 Pete Graner 2004-10-14 16:13:19 UTC
This showed up in RHEL3 U3 calling luseradd see:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=135625

Comment 7 Miloslav Trmač 2004-10-29 17:03:46 UTC

*** This bug has been marked as a duplicate of 135625 ***

Comment 8 Red Hat Bugzilla 2006-02-21 18:57:52 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.