Bug 135625 - Violation of error reporting interface
Violation of error reporting interface
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: libuser (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Miloslav Trmač
:
: 101275 126850 (view as bug list)
Depends On: 135715
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 16:57 EDT by Miloslav Trmač
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 21:10:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2004-10-13 16:57:39 EDT
RHEL 3 AS on S390
                                                                     
          
luseradd -u 200 -g 200 -c "COE Boot Account" COE
libuser fatal error: lu_homedir_populate() called with non-NULL
*errorAborted
                                                                     
          
When I check the /etc/passwd and /etc/group the COE user is added.
luserdel works without error.
                                                                     
          
This command works perfectly fine on x86 & ppc.
Comment 2 Miloslav Trmač 2004-10-18 10:07:16 EDT
AFAICT it is an gcc bug (#135715).
Should I attempt to do a libuser workaround?
Comment 4 Miloslav Trmač 2004-10-29 13:03:53 EDT
*** Bug 101275 has been marked as a duplicate of this bug. ***
Comment 6 Miloslav Trmač 2004-11-11 19:03:20 EST
On track for RHEL3 U4.
Comment 8 Tim Powers 2004-11-15 09:54:58 EST
Please make sure you create an errata for this package. I don't see one for libuser yet (or at least can't 
find it).
Comment 9 Miloslav Trmač 2004-11-15 18:59:18 EST
Split from 2004:565 to 2004:643.
Comment 10 Miloslav Trmač 2004-11-19 08:52:21 EST
*** Bug 126850 has been marked as a duplicate of this bug. ***
Comment 11 John Flanagan 2004-12-21 21:10:10 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-643.html

Note You need to log in before you can comment on or make changes to this bug.