Bug 1012786 - Packstack fails to enable mariadb
Packstack fails to enable mariadb
Status: CLOSED DUPLICATE of bug 981116
Product: Fedora
Classification: Fedora
Component: openstack-packstack (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Magr
Fedora Extras Quality Assurance
:
: 1018999 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 02:46 EDT by Matthias Runge
Modified: 2014-01-15 17:01 EST (History)
8 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.12.dev806.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1013003 (view as bug list)
Environment:
Last Closed: 2014-01-15 17:01:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2013-09-27 02:46:20 EDT
Since MySQL was replaced in Fedora 19 by MariaDB, this move went even further in F20, and the backwards compat service mysqld.service was dropped in favor of mariadb.service

ERROR : Error during puppet run : Error: Could not enable mysqld: Execution of '/sbin/chkconfig mysqld on' returned 1: Note: Forwarding request to 'systemctl enable mysqld.service'.
Please check log file /var/tmp/packstack/20130927-082930-1OuaIY/openstack-setup.log for more information

Additional information:
 * A new answerfile was created in: /root/packstack-answers-20130927-082930.txt
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * Did not create a cinder volume group, one already existed
 * To use the command line tools you need to source the file /root/keystonerc_admin created on 192.168.36.18
 * To use the console, browse to http://192.168.36.18/dashboard
[root@gauss ~]# systemctl enable mysqld.servie
Failed to issue method call: No such file or directory
[root@gauss ~]# systemctl enable mariadb.service
ln -s '/usr/lib/systemd/system/mariadb.service' '/etc/systemd/system/multi-user.target.wants/mariadb.service'
[root@gauss ~]# rpm -q openstack-packstack
openstack-packstack-2013.2.1-0.10.dev763.fc20.noarch
Comment 1 Fedora Admin XMLRPC Client 2013-10-14 05:50:44 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2013-10-14 05:51:13 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Matthias Runge 2013-10-16 02:44:37 EDT
*** Bug 1018999 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Runge 2013-10-16 02:45:42 EDT
Taken from a duplicate: 

Additional info:
Changed /usr/lib/python2.7/site-packages/packstack/puppet/modules/mysql/manifests/params.pp to include "$service_name = 'mariadb'" in the Fedora >= 19 section, which seemed to fix this.
Comment 5 Pádraig Brady 2014-01-15 17:01:40 EST
While this bug was dealing with the mariadb _service_ compat issue, 
and bug 981116 was dealing with the _package_ compat issue,
that bug has been reopened and now contains more info on
the _service_ compat issue that this does.
So closing this as dupe...

*** This bug has been marked as a duplicate of bug 981116 ***

Note You need to log in before you can comment on or make changes to this bug.