Bug 1018999 - Installation failed with mariadb
Installation failed with mariadb
Status: CLOSED DUPLICATE of bug 1012786
Product: Fedora
Classification: Fedora
Component: openstack-packstack (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Magr
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 18:18 EDT by Eric Harney
Modified: 2013-10-16 02:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 02:44:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Harney 2013-10-14 18:18:22 EDT
Description of problem:
Packstack all-in-one installation failed due to mariadb/mysql compatibility issue

Version-Release number of selected component (if applicable):
openstack-packstack-2013.2.1-0.10.dev763.fc20.noarch

How reproducible:
Attempted once

Steps to Reproduce:
1.  Install Fedora 20 from Fedora-20-Nightly-x86_64-Live-xfce-20131013.17-1.iso
2.  yum install openstack-packstack
3.  packstack --allinone

Actual results:
SequenceError: Error during puppet run : Error: Could not enable mysqld: Execution of '/sbin/chkconfig mysqld on' returned 1: Note: Forwarding request to 'systemctl enable mysqld.service'.


Expected results:
Compatibility w/ mariadb

Additional info:
Changed /usr/lib/python2.7/site-packages/packstack/puppet/modules/mysql/manifests/params.pp to include "$service_name = 'mariadb'" in the Fedora >= 19 section, which seemed to fix this.
Comment 1 Matthias Runge 2013-10-16 02:44:36 EDT

*** This bug has been marked as a duplicate of bug 1012786 ***

Note You need to log in before you can comment on or make changes to this bug.