Bug 10128 - chkfontpath-1.5-1 can corrupt the xfs config file
Summary: chkfontpath-1.5-1 can corrupt the xfs config file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: chkfontpath   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
: 13963 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-11 23:18 UTC by Robert Clark
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-30 18:24:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Clark 2000-03-11 23:18:00 UTC
If the xfs config file (/etc/X11/fs/config) contains an entry like:

catalogue =
      /path/to/font/dir1,
      /path/to/font/dir2,
      /path/to/font/dir3,
      /path/to/font/dir4

then when chkfontpath tries to add /path/to/new/font/dir to this, the
resulting entry is (note the missing comma on the first line):

catalogue = /path/to/new/font/dir
      /path/to/font/dir1,
      /path/to/font/dir2,
      /path/to/font/dir3,
      /path/to/font/dir4

  This one bit me when I upgraded to netscape-common-4.72-6 which runs:

    /usr/sbin/chkfontpath -q -a /usr/X11R6/lib/X11/fonts/75dpi

on install.

  Incidently, are the -q & -a flags to chkfontpath documented anywhere?

Comment 1 Preston Brown 2000-08-30 18:24:11 UTC
*** Bug 13963 has been marked as a duplicate of this bug. ***

Comment 2 Preston Brown 2001-01-12 20:47:30 UTC
fixed in version 1.8 in rawhide.


Note You need to log in before you can comment on or make changes to this bug.