This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 13963 - netscape 4.73's usage of chkfontpath munges /etc/X11/fs/config
netscape 4.73's usage of chkfontpath munges /etc/X11/fs/config
Status: CLOSED DUPLICATE of bug 10128
Product: Red Hat Linux
Classification: Retired
Component: chkfontpath (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-14 14:32 EDT by Burt Holzman
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-29 15:32:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Burt Holzman 2000-07-14 14:32:26 EDT
Apparently, upgrading to netscape 4.73 botches
/etc/X11/fs/config, by pre-pending 
/usr/X11R6/X11/fonts/75dpi to the fonts catalogue.

That would normally be well and good, but it is
missing a comma, so my config reads:

catalogue = /usr/X11R6/lib/X11/fonts/75dpi
/usr/share/fonts/windows,
/usr/X11R6/lib/X11/fonts/misc:unscaled,

and fails to load the windows TTFs.  Please tell
netscape rpm to get out of my xfs.

- B
Comment 1 Bill Nottingham 2000-07-14 14:44:34 EDT
Netscape simply runs chkfontpath, it doesn't edit it directly.

Reassigned to chkfontpath.
Comment 2 Preston Brown 2000-08-29 14:43:42 EDT
your /etc/X11/fs/config file must have been in an 'unusual' state before
chkfontpath ran, as we have had no other bugreports of this nature.  Can you
please attach your /etc/X11/fs/config to this report?
Comment 3 Burt Holzman 2000-08-29 15:32:09 EDT
Here is my /etc/X11/fs/config:

#
# Default font server configuration file for Red Hat Linux 6.0
#

# allow a max of 4 clients to connect to this font server
client-limit = 4

# when a font server reaches its limit, start up a new one
clone-self = off

# alternate font servers for clients to use
#alternate-servers = foo:7101,bar:7102

# where to look for fonts
# Some of these are commented out, i.e. the TrueType and Type1
# directories in /usr/share, because they aren't forced to be
# installed alongside X.
#
catalogue = 
/usr/share/fonts/windows,
/usr/X11R6/lib/X11/fonts/misc:unscaled,
/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
/usr/X11R6/lib/X11/fonts/100dpi:unscaled,
/usr/X11R6/lib/X11/fonts/Type1,
/usr/X11R6/lib/X11/fonts/Speedo,
/usr/X11R6/lib/X11/fonts/misc,
/usr/share/fonts/default/Type1,
/usr/X11R6/lib/X11/fonts/75dpi,
/usr/X11R6/lib/X11/fonts/100dpi,
/usr/X11R6/lib/X11/fonts/cyrillic,
/usr/share/fonts/ISO8859-2/misc,
/usr/share/fonts/ISO8859-2/75dpi,
/usr/share/fonts/ISO8859-2/100dpi,
/usr/share/fonts/ISO8859-2/Type1,
/usr/share/fonts/ISO8859-9/misc,
/usr/share/fonts/ISO8859-9/75dpi,
/usr/share/fonts/ISO8859-9/100dpi
Comment 4 Preston Brown 2000-08-30 14:24:13 EDT

*** This bug has been marked as a duplicate of 10128 ***

Note You need to log in before you can comment on or make changes to this bug.