Bug 1012822 - RHEL5.10 guest cannot resume after S3
RHEL5.10 guest cannot resume after S3
Status: CLOSED DUPLICATE of bug 842942
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Amit Shah
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 04:27 EDT by huiqingding
Modified: 2013-09-30 00:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 00:22:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description huiqingding 2013-09-27 04:27:38 EDT
Description of problem:
RHEL5.10(32 bit) guest cannot resume after S3.

Version-Release number of selected component (if applicable):
The host kernel is kernel-3.10.0-28.el7.x86_64
The version of qemu-kvm is qemu-kvm-rhev-1.5.3-6.el7.x86_64
The guest kernel is kernel-2.6.18-371.el5PAE

How reproducible:
100%

Steps to Reproduce:
1. Boot RHEL5.10 (32 bit) guest
/usr/libexec/qemu-kvm -M pc -cpu SandyBridge -enable-kvm -m 2048 -smp 4,sockets=2,cores=2,threads=1 -name rhel5.10-32 -uuid 6afa5f93-2d4f-420f-81c6-e5fdddbd1c83 -drive file=/home/RHEL-Server-5-10.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=40c061dd-5d60-4fc5-865f-55db700407f0,cache=none,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0 -device pci-assign,host=00:19.0 -vnc :1  -monitor stdio

2. On guest, do S3
# pm-suspend

Actual results:
The guest cannot resume.

Expected results:
The guest can resume normally.

Additional info:
Comment 1 Amit Shah 2013-09-27 04:35:35 EDT
We disabled RHEL5 as a guest S3/S4 in https://bugzilla.redhat.com/show_bug.cgi?id=834511

The guest should not even enter S3 state because of that commit.  Does pm-suspend actually succeed for you?
Comment 3 huiqingding 2013-09-28 21:30:52 EDT
(In reply to Amit Shah from comment #1)
> We disabled RHEL5 as a guest S3/S4 in
> https://bugzilla.redhat.com/show_bug.cgi?id=834511
> 
> The guest should not even enter S3 state because of that commit.  Does
> pm-suspend actually succeed for you?

When first run "pm-suspend", guest changes black and then comes back to desktop immediately but guest and the network are always working.

When second run "pm-suspend", guest displays black screen for long time and does not resume. Kernel gets calltrace same as Bug 842942.
Comment 4 Amit Shah 2013-09-30 00:22:05 EDT
OK, so it's the same thing reported earlier, and it's most likely failing due to the console devices.  We won't support s3/s4 on rhel5 guests, and hence won't dig into this further.

*** This bug has been marked as a duplicate of bug 842942 ***

Note You need to log in before you can comment on or make changes to this bug.