Bug 1012823 - Running command hosted-engine --vm-status raise exception
Running command hosted-engine --vm-status raise exception
Status: CLOSED DUPLICATE of bug 1008501
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 04:28 EDT by Artyom
Modified: 2013-09-27 05:03 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 05:03:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artyom 2013-09-27 04:28:11 EDT
Description of problem:
Running command hosted-engine --vm-status raise exception:
Traceback (most recent call last):
  File "/usr/lib64/python2.6/runpy.py", line 122, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.6/runpy.py", line 34, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_setup/vm_status.py", line 86, in <module>
    if not status_checker.print_status():
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_setup/vm_status.py", line 56, in print_status
    all_host_stats = ha_cli.get_all_host_stats()
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/client/client.py", line 51, in get_all_host_stats
    constants.SERVICE_TYPE)
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/lib/brokerlink.py", line 113, in get_stats_from_storage
    result = self._checked_communicate(request)
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/lib/brokerlink.py", line 140, in _checked_communicate
    raise RequestError("Request failed: {0}".format(msg))
ovirt_hosted_engine_ha.lib.exceptions.RequestError: Request failed: failed to read metadata: [Errno 2] No such file or directory: '/rhev/data-center/mnt/lion.qa.lab.tlv.redhat.com:_export_alukiano_host__deploy/dceb6768-b622-4fda-b7b0-315b7681840a/ha_agent/hosted-engine.metadata'

Vm is on and available

Version-Release number of selected component (if applicable):
is16
vdsm-4.12.0-156.git6e499d6.el6ev.x86_64

How reproducible:
Always

Steps to Reproduce:
1. install ovirt-host-deploy-setup 
2. Run and finish hosted-engine --deploy
3. run hosted-engine --vm-status

Actual results:
Command return traceback

Expected results:
Return vm status

Additional info:
Comment 1 Sandro Bonazzola 2013-09-27 05:03:38 EDT

*** This bug has been marked as a duplicate of bug 1008501 ***

Note You need to log in before you can comment on or make changes to this bug.