Bug 1008501 - engine monitoring fails because metadata file is missing.
engine monitoring fails because metadata file is missing.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
:
: 1012823 1014620 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 09:38 EDT by Leonid Natapov
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.5.beta1.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:53:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19292 None None None Never

  None (edit)
Description Leonid Natapov 2013-09-16 09:38:53 EDT
Description of problem:
engine monitoring fails because metadata file is missing. The file is missing because it wasn't created by setup. ovirt-hosted-engine setup should create metadata file.

----
inThread::DEBUG::2013-09-16 16:33:39,640::brokerlink::161::BrokerLink::(_communicate) Full response: failure failed to write metadata: [Errno 2] No such file or directory: '/rhev/data-center/mnt/orion.qa.lab.tlv.redhat.com:_export_hosted__engine/97e3e4e6-7ae8-4d1e-8b95-dffaeb5db8d5/ha_agent/hosted-engine.metadata'
MainThread::DEBUG::2013-09-16 16:33:39,640::brokerlink::135::BrokerLink::(_checked_communicate) Failed response from socket
MainThread::WARNING::2013-09-16 16:33:39,640::hosted_engine::236::HostedEngine::(start_monitoring) Error while monitoring engine: Request failed: failed to write metadata: [Errno 2] No such file or directory: '/rhev/data-center/mnt/orion.qa.lab.tlv.redhat.com:_export_hosted__engine/97e3e4e6-7ae8-4d1e-8b95-dffaeb5db8d5/ha_agent/hosted-engine.metadata'
MainThread::INFO::2013-09-16 16:33:39,640::hosted_engine::242::HostedEngine::(start_monitoring) Sleeping 60 seconds
Comment 1 Sandro Bonazzola 2013-09-17 04:25:36 EDT
Merged upstream master.

Creates the metadata file is shared by all hosts participating in the engine
high availability cluster.  Each host is assigned a 4KiB chunk according
to its host id, with a corresponding offset of host_id*4KiB.  The
initial 4KiB of the file are reserved for shared state such as a global
engine ha maintenance bit.
Comment 3 Sandro Bonazzola 2013-09-27 05:03:38 EDT
*** Bug 1012823 has been marked as a duplicate of this bug. ***
Comment 7 Leonid Natapov 2013-10-03 01:32:39 EDT
*** Bug 1014620 has been marked as a duplicate of this bug. ***
Comment 8 Leonid Natapov 2013-10-17 06:45:06 EDT
fixed. ovirt-hosted-engine-setup-1.0.0-0.5.2.beta1.local.el6.noarch
Comment 9 Charlie 2013-11-27 20:18:56 EST
This bug is currently attached to errata RHBA-2013:15257. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 Sandro Bonazzola 2013-12-05 05:44:09 EST
hosted engine is a new package, does not need errata for specific bugs during its development.
Comment 11 errata-xmlrpc 2014-01-21 11:53:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0083.html

Note You need to log in before you can comment on or make changes to this bug.