Bug 101284 - netatalk-1.5.5-8 depends on /usr/bin/rc?
Summary: netatalk-1.5.5-8 depends on /usr/bin/rc?
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: netatalk (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Charlie Bennett
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-30 16:41 UTC by Jonathan Kamens
Modified: 2007-04-18 16:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 20:37:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2003-07-30 16:41:08 UTC
When I try to upgrade to netatalk-1.5.5-8, I get:

        /usr/bin/rc is needed by netatalk-1.5.5-8

If this file is supposed to be in the netatalk package, please add it.  If it's 
in some other RPM, please add a dependency on that RPM to the netatalk spec so 
that I don't have to try to guess which RPM contains this file.

Comment 1 Chris Ricker 2003-07-30 19:24:23 UTC
That's often an application that provides IR remote control support for doing
PVRs and such. When that's the app, it's provided by software RH doesn't ship, lirc

That seems kinda broken to me -- I can't think of why netatalk should need an
infrared remote control, so presumably this is a different one ;-)

That does mean netatalk will now conflict with lirc, and some people building
their own PVRs might actually want to use netatalk to share media with their
macintrashes....

Comment 2 Charlie Bennett 2003-07-30 20:53:58 UTC
"rc" is the shell from the AT&T Plan9 operating system

If you have the source RPM from the Red Hat released version of netatalk
there is a patch you can merge into the RPM you're building which sidesteps
the need for rc.

Do you want netatalk 1.6.3 for RH9?  I have it.  I'm currently grinding out
1.6.3 for all supported releases.


Comment 3 Dave Habben 2003-09-08 05:37:18 UTC
Seems to be fixed in:
netatalk-1.5.5-9

This should probably be marked as CLOSED/RAWHIDE

#rpm -q netatalk --requires
/bin/sh
/bin/sh
/bin/sh
/bin/sh
/etc/pam.d/system-auth
/sbin/chkconfig
/sbin/service
/usr/bin/perl
config(netatalk) = 2:1.5.5-9
cracklib
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.3)
libcrack.so.2
libcrypt.so.1
libcrypt.so.1(GLIBC_2.0)
libcrypto.so.4
libdl.so.2
libdl.so.2(GLIBC_2.0)
libdl.so.2(GLIBC_2.1)
libnsl.so.1
libpam.so.0
libwrap.so.0
openssl
pam >= 0.56
perl >= 1:5
perl(Getopt::Std)
perl(Socket)
perl(strict)
perl(vars)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
tcp_wrappers


Comment 4 Warren Togami 2003-09-21 11:55:22 UTC
Recommend CLOSED RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.