Bug 1012844 - [abrt] gnome-shell-3.10.0.1-1.fc20: clutter_box_layout_allocate: Process /usr/bin/gnome-shell was killed by signal 5 (SIGTRAP)
[abrt] gnome-shell-3.10.0.1-1.fc20: clutter_box_layout_allocate: Process /usr...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: clutter (Show other bugs)
20
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
abrt_hash:174f0dc204710d24b8d40271dc4...
: CommonBugs, Patch
: 1017333 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 05:10 EDT by Igor Gnatenko
Modified: 2014-03-07 20:46 EST (History)
25 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-07 20:46:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (73.17 KB, text/plain)
2013-09-27 05:10 EDT, Igor Gnatenko
no flags Details
File: cgroup (159 bytes, text/plain)
2013-09-27 05:10 EDT, Igor Gnatenko
no flags Details
File: core_backtrace (39.47 KB, text/plain)
2013-09-27 05:10 EDT, Igor Gnatenko
no flags Details
File: dso_list (22.89 KB, text/plain)
2013-09-27 05:10 EDT, Igor Gnatenko
no flags Details
File: environ (1.25 KB, text/plain)
2013-09-27 05:10 EDT, Igor Gnatenko
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-27 05:10 EDT, Igor Gnatenko
no flags Details
File: maps (100.81 KB, text/plain)
2013-09-27 05:10 EDT, Igor Gnatenko
no flags Details
File: open_fds (2.67 KB, text/plain)
2013-09-27 05:10 EDT, Igor Gnatenko
no flags Details
File: proc_pid_status (936 bytes, text/plain)
2013-09-27 05:10 EDT, Igor Gnatenko
no flags Details
File: var_log_messages (23.58 KB, text/plain)
2013-09-27 05:10 EDT, Igor Gnatenko
no flags Details
0001-Add-downstream-patches-for-fix-crashing-GS-BGO-70943.patch (5.91 KB, patch)
2013-11-12 07:20 EST, Igor Gnatenko
ignatenko: review+
Details | Diff
0001-Add-downstream-patches-for-fix-crashing-GS-BGO-70943.patch (6.15 KB, patch)
2013-11-14 05:04 EST, Igor Gnatenko
ignatenko: review+
Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 709434 None None None Never

  None (edit)
Description Igor Gnatenko 2013-09-27 05:10:03 EDT
Version-Release number of selected component:
gnome-shell-3.10.0.1-1.fc20

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: clutter_box_layout_allocate
executable:     /usr/bin/gnome-shell
kernel:         3.11.1-300.fc20.x86_64
runlevel:       unknown
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 clutter_box_layout_allocate at ./clutter-box-layout.c:1024
 #3 st_widget_allocate at st/st-widget.c:448
 #4 st_box_layout_allocate at st/st-box-layout.c:290
 #5 clutter_actor_allocate_internal at ./clutter-actor.c:9739
 #6 clutter_actor_set_animatable_property at ./clutter-actor.c:14720
 #7 _clutter_actor_create_transition at ./clutter-actor.c:18880
 #8 clutter_actor_allocate at ./clutter-actor.c:9866
 #9 clutter_actor_allocate_align_fill at ./clutter-actor.c:15413
 #10 allocate_box_child at ./clutter-box-layout.c:760
 #11 clutter_box_layout_allocate at ./clutter-box-layout.c:1226
Comment 1 Igor Gnatenko 2013-09-27 05:10:08 EDT
Created attachment 803831 [details]
File: backtrace
Comment 2 Igor Gnatenko 2013-09-27 05:10:11 EDT
Created attachment 803832 [details]
File: cgroup
Comment 3 Igor Gnatenko 2013-09-27 05:10:15 EDT
Created attachment 803833 [details]
File: core_backtrace
Comment 4 Igor Gnatenko 2013-09-27 05:10:20 EDT
Created attachment 803834 [details]
File: dso_list
Comment 5 Igor Gnatenko 2013-09-27 05:10:23 EDT
Created attachment 803835 [details]
File: environ
Comment 6 Igor Gnatenko 2013-09-27 05:10:27 EDT
Created attachment 803836 [details]
File: limits
Comment 7 Igor Gnatenko 2013-09-27 05:10:31 EDT
Created attachment 803837 [details]
File: maps
Comment 8 Igor Gnatenko 2013-09-27 05:10:35 EDT
Created attachment 803838 [details]
File: open_fds
Comment 9 Igor Gnatenko 2013-09-27 05:10:39 EDT
Created attachment 803839 [details]
File: proc_pid_status
Comment 10 Igor Gnatenko 2013-09-27 05:10:43 EDT
Created attachment 803840 [details]
File: var_log_messages
Comment 11 Fabio Valentini 2013-09-28 04:45:19 EDT
Steps to reproduce:

1. Open Seahorse, select a keyring
2. Click to change keyring password
3. gnome-shell dialog pops up
4. enter current password
5. enter nothing (empty password fields) and confirm
6. crash gnome-shell

So it is no longer possible to set up a keyring without password.

reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: clutter_box_layout_allocate
executable:     /usr/bin/gnome-shell
kernel:         3.12.0-rc2-fafadora
package:        gnome-shell-3.10.0.1-1.fc20
reason:         Process /usr/bin/gnome-shell was killed by signal 5 (SIGTRAP)
reported_to:    uReport: BTHASH=26d0d67c5f4d555d0e48b8ad858212370d4df9b4
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 12 Jan Sedlák 2013-10-04 09:37:19 EDT
Tried to save password from ownCloud online accout.

reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: clutter_box_layout_allocate
executable:     /usr/bin/gnome-shell
kernel:         3.11.2-301.fc20.x86_64
package:        gnome-shell-3.10.0.1-1.fc20
reason:         Process /usr/bin/gnome-shell was killed by signal 5 (SIGTRAP)
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 13 Igor Gnatenko 2013-10-04 16:18:07 EDT
https://bugzilla.gnome.org/show_bug.cgi?id=709434
Comment 14 Igor Gnatenko 2013-11-12 07:17:25 EST
*** Bug 1017333 has been marked as a duplicate of this bug. ***
Comment 15 Igor Gnatenko 2013-11-12 07:20:09 EST
Created attachment 822900 [details]
0001-Add-downstream-patches-for-fix-crashing-GS-BGO-70943.patch

Please use git am for master branch.
Comment 16 Mike Ruckman 2013-11-12 15:05:17 EST
This is verified for clutter-1.16.0-2.fc20.x86_64.
Comment 17 Igor Gnatenko 2013-11-14 05:04:40 EST
Created attachment 823859 [details]
0001-Add-downstream-patches-for-fix-crashing-GS-BGO-70943.patch
Comment 18 Florian Müllner 2013-11-14 08:42:20 EST
(In reply to Igor Gnatenko from comment #17)
> Created attachment 823859 [details]
> 0001-Add-downstream-patches-for-fix-crashing-GS-BGO-70943.patch

Probably not worth doing a downstream patch here - there will be a new stable upstream release which includes the fix later today or tomorrow.
Comment 19 Igor Gnatenko 2013-11-14 09:07:50 EST
(In reply to Florian Müllner from comment #18)
> (In reply to Igor Gnatenko from comment #17)
> > Created attachment 823859 [details]
> > 0001-Add-downstream-patches-for-fix-crashing-GS-BGO-70943.patch
> 
> Probably not worth doing a downstream patch here - there will be a new
> stable upstream release which includes the fix later today or tomorrow.

if new release will be *before* release - sure, but I don't have knowledge when release will be.
Comment 20 Florian Müllner 2013-11-14 09:31:09 EST
The clutter maintainer assured me that there'll be a release tomorrow at the latest.
Comment 21 Adam Williamson 2013-12-12 20:45:26 EST
clutter 1.16.2 was indeed released soon after (11-19, not quite 'tomorrow' but nevermind :>), and an update submitted:

https://admin.fedoraproject.org/updates/FEDORA-2013-22280/mutter-3.10.2-3.fc20,clutter-1.16.2-3.fc20

but kparal reported that it caused corruption on his graphics card:

https://bugzilla.redhat.com/show_bug.cgi?id=1036257

and as of two days ago (12-10) it was not fully resolved:

https://bugzilla.redhat.com/show_bug.cgi?id=1036257#c4

so the update was not sent to stable, and has missed F20 Final release, unfortunately. If I'd noticed I'd have suggested sending out a clutter with just the backported fix :( I'll maintain the commonbugs note for release.
Comment 22 Michael Catanzaro 2013-12-21 21:58:25 EST
1) Install gpk-application (Packages)
2) Open Software Log (from the app menu)
3) Start attempting to Alt+Tab (or maybe Alt+`) between Software Log and Packages.

Software Log is displayed in GNOME Shell as Packages, and has the same app menu as Packages, and its window appears as a second window under Packages in the Alt+Tab switcher, but it has its own entry in the Alt+Tab switcher with no associated window. That seems to be causing GNOME Shell to crash.

reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: clutter_box_layout_allocate
executable:     /usr/bin/gnome-shell
kernel:         3.11.10-301.fc20.x86_64
package:        gnome-shell-3.10.2.1-2.fc20
reason:         Process /usr/bin/gnome-shell was killed by signal 5 (SIGTRAP)
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 23 Kamil Páral 2013-12-28 13:38:10 EST
Another user experienced a similar problem:

I've been doing something very similar to https://bugzilla.gnome.org/show_bug.cgi?id=700288#c21

reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        gnome-shell --sm-client-id 10bee322ca4b4e12c7138771006125396300000008040000
crash_function: clutter_box_layout_allocate
executable:     /usr/bin/gnome-shell
kernel:         3.12.5-302.fc20.x86_64
package:        gnome-shell-3.10.2.1-3.fc20
reason:         gnome-shell killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 24 Adam Williamson 2014-01-10 19:11:02 EST
Kamil, you're the reason that clutter-1.16.2-3 - which was supposed to fix this bug - never went out, because you complained that it broke your graphics. =)

I've had releng nerf the update since then - it contained both clutter and mutter, and a later update was sent out which only contained mutter, so if the clutter/mutter update had ever been pushed stable it would have overridden a newer mutter. Setting this back to ASSIGNED to reflect that.
Comment 25 Adam Williamson 2014-01-10 19:22:04 EST
So, um, I'm getting a bit confused, here. AFAICT, F20 has the following builds in stable:

clutter-1.16.2-1.fc20 (was shipped in Final - my c#21 was incorrect, 1.16.2-1 waas pulled in as part of a different update prior to Final release)
mutter-3.10.2-6.fc20 ( https://admin.fedoraproject.org/updates/FEDORA-2013-23948/mutter-3.10.2-6.fc20 )

There is no pending update for either package for F20.

But if Clutter 1.16.2 was supposed to fix this, why are we still getting reports for it? Would the never-pushed-stable 1.16.2-3 do anything to help with this, or not?
Comment 26 Florian Müllner 2014-01-11 12:04:20 EST
(In reply to Adam Williamson from comment #25)
> But if Clutter 1.16.2 was supposed to fix this, why are we still getting
> reports for it?

The code that produces backtraces like these has not changed - it is a sanity check Clutter is doing, triggering an assertion on failure.

What the version in question did fix was a bug in Clutter itself that caused valid code to fail said sanity check (in particular: wrong size calculations in presence of hidden actors, triggered by the steps in comment #11). But as the assertion is still present, it can still be triggered by other bugs (likely in either gnome-shell or clutter), which is probably the case here. The reproducer in comment #22 is definitively helpful, I will take a look.


> Would the never-pushed-stable 1.16.2-3 do anything to help with this, or not?

No. With the steps from comment #22, I can reproduce on current git master.
Comment 27 Adam Williamson 2014-01-12 01:43:12 EST
Ah, thanks for the info. That explains it.
Comment 28 Adam Williamson 2014-01-12 01:47:53 EST
BTW, when you have a case like this where different issues can be detected as dupes by libreport/abrt, you can usually arrange with the abrt folks to come up with a better detection mechanism that will separate the reports, if it's worth the effort.
Comment 29 Robert Hancock 2014-01-18 15:20:14 EST
Another user experienced a similar problem:

Enabled "Icons on desktop" in gnome-tweak-tool (Advanced Settings)
The Files icon is displayed in the Alt-Tab icon list even though no file window is open. (Before this update, that wasn't occurring.)
If you Alt-Tab to that icon and hit Alt-~ to display the open windows, this crash occurs.

reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: clutter_box_layout_allocate
executable:     /usr/bin/gnome-shell
kernel:         3.12.8-300.fc20.x86_64
package:        gnome-shell-3.10.3-1.fc20
reason:         gnome-shell killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 30 Florian Müllner 2014-01-22 12:14:25 EST
(In reply to Robert Hancock from comment #29)
> Another user experienced a similar problem

Right, both the problem described in comment #22 and this are caused by an application showing up in the alt-tab popup without any windows to switch to. The reason we end up there is different though - see https://bugzilla.gnome.org/show_bug.cgi?id=722434 for the first issue, and https://bugzilla.gnome.org/show_bug.cgi?id=722690 for the second one.
Comment 31 Phil 2014-01-24 08:28:19 EST
Is there a koji link for the updated package so I might test it?

A temporary work around for users experiencing this issue until the proper fix makes it through QA to the repos:

yum downgrade gnome-shell

This should install the previous 3.10.2.x version.  I would advise avoiding 3.10.3-1.fc20 all together.
Comment 32 Phil 2014-01-24 08:35:37 EST
(In reply to Phil from comment #31)
> Is there a koji link for the updated package so I might test it?

Sorry for not searching first, it's late.  The x86_64 package here works for me on 2 separate installations that had the same issue.

http://koji.fedoraproject.org/koji/buildinfo?buildID=493472
Comment 33 Adam Williamson 2014-03-07 19:55:24 EST
Is any incarnation of this still valid with latest F20 shell, clutter and mutter?
Comment 34 Florian Müllner 2014-03-07 20:46:12 EST
(In reply to Adam Williamson from comment #33)
> Is any incarnation of this still valid with latest F20 shell, clutter and
> mutter?

To the best of my knowledge no; the sanity check/assertion is still in clutter and may be triggered by all kind of bugs, but the two identified in this bug have been fixed. So yeah, let's close this ...

Note You need to log in before you can comment on or make changes to this bug.