Bug 1013019 - LVMError: lvremove failed for root: running lvm lvremove --config devices { filter=["r|/vda1$|","r|/fedora$|","r|/vda2$|","r|/vda$|"] } fedora/root failed
LVMError: lvremove failed for root: running lvm lvremove --config devices { ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:cdc7f82e6a35b2e6c4a42a4006e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 11:30 EDT by mock
Modified: 2015-01-20 13:41 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-20 13:41:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (703.61 KB, text/plain)
2013-09-27 11:30 EDT, mock
no flags Details
File: anaconda.log (11.72 KB, text/plain)
2013-09-27 11:30 EDT, mock
no flags Details
File: environ (441 bytes, text/plain)
2013-09-27 11:30 EDT, mock
no flags Details
File: lsblk_output (2.11 KB, text/plain)
2013-09-27 11:31 EDT, mock
no flags Details
File: nmcli_dev_list (4.45 KB, text/plain)
2013-09-27 11:31 EDT, mock
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-27 11:31 EDT, mock
no flags Details
File: program.log (35.98 KB, text/plain)
2013-09-27 11:31 EDT, mock
no flags Details
File: storage.log (124.33 KB, text/plain)
2013-09-27 11:31 EDT, mock
no flags Details
File: syslog (67.84 KB, text/plain)
2013-09-27 11:31 EDT, mock
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-09-27 11:31 EDT, mock
no flags Details
File: packaging.log (436.54 KB, text/plain)
2013-09-27 11:31 EDT, mock
no flags Details
screencast of the vm install attempt (1.15 MB, video/webm)
2013-09-27 15:54 EDT, mock
no flags Details

  None (edit)
Description mock 2013-09-27 11:30:35 EDT
Description of problem:
in virt-manager, i booted from the network install of fedora 20 alpha.

when prompted for media, i chose the usb 8gb key i had attached. i reclaim the space on the drive by pressing the delete of existing partitions. i then accept default partition layout without viewing.

when the closest mirror is found and all is ready, i press begin installation button.

at the "settting up the installation environment" with the status bar, it crashes.

Version-Release number of selected component:
anaconda-20.18-1

The following was filed automatically by anaconda:
anaconda 20.18-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/lvm.py", line 417, in lvremove
    raise LVMError("lvremove failed for %s: %s" % (lv_name, msg))
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2702, in _destroy
    lvm.lvremove(self.vg.name, self._name)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 822, in destroy
    self._destroy()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 318, in execute
    self.device.destroy()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 142, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
LVMError: lvremove failed for root: running lvm lvremove --config  devices { filter=["r|/vda1$|","r|/fedora$|","r|/vda2$|","r|/vda$|"] }  fedora/root failed

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha

Potential duplicate: bug 975955
Comment 1 mock 2013-09-27 11:30:47 EDT
Created attachment 804015 [details]
File: anaconda-tb
Comment 2 mock 2013-09-27 11:30:53 EDT
Created attachment 804016 [details]
File: anaconda.log
Comment 3 mock 2013-09-27 11:30:57 EDT
Created attachment 804017 [details]
File: environ
Comment 4 mock 2013-09-27 11:31:05 EDT
Created attachment 804018 [details]
File: lsblk_output
Comment 5 mock 2013-09-27 11:31:10 EDT
Created attachment 804019 [details]
File: nmcli_dev_list
Comment 6 mock 2013-09-27 11:31:16 EDT
Created attachment 804020 [details]
File: os_info
Comment 7 mock 2013-09-27 11:31:20 EDT
Created attachment 804021 [details]
File: program.log
Comment 8 mock 2013-09-27 11:31:29 EDT
Created attachment 804022 [details]
File: storage.log
Comment 9 mock 2013-09-27 11:31:40 EDT
Created attachment 804023 [details]
File: syslog
Comment 10 mock 2013-09-27 11:31:45 EDT
Created attachment 804024 [details]
File: ifcfg.log
Comment 11 mock 2013-09-27 11:31:52 EDT
Created attachment 804025 [details]
File: packaging.log
Comment 12 mock 2013-09-27 15:54:14 EDT
Created attachment 804132 [details]
screencast of the vm install attempt

this isn't THE screencast i got from the bug generated here, but it is from another attempt. it is reproducable.
Comment 13 David Lehman 2013-09-30 10:45:21 EDT
You have an LVM VG named "fedora" on each of the two disks in your system, which is generally not advisable. It looks like LVM is refusing our attempts to ignore the one on vda2.
Comment 14 mock 2013-09-30 11:19:04 EDT
i went through the process again using a standard (not lvm) configuration and had the same error.

so, if i disable the virtually installed drive from my vm config, this should work?
Comment 15 David Lehman 2013-09-30 11:32:46 EDT
It has nothing to do with whether you choose lvm or standard in the run that crashes -- it has everything to do with the data that is on your disks already.

Yes, excluding either of those disks would help, I expect.
Comment 16 mock 2013-09-30 16:18:02 EDT
yes, that appears to have worked. i removed the virtio ide drive from the vm config and was able to proceed with installation to a usb drive. however, this process has taken a couple of hours, which may be the result of only allotting 2gb of ram to the vm. i'll have to start this again when i have more time on this machine.

Note You need to log in before you can comment on or make changes to this bug.