Bug 1013033 - Glom cannot be started
Glom cannot be started
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: glom (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Haïkel Guémar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 12:19 EDT by Derek P. Moore
Modified: 2014-09-05 10:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-05 10:19:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek P. Moore 2013-09-27 12:19:23 EDT
Description of problem:
Glom fails when attempting to start up.

Version-Release number of selected component (if applicable):
glom-1.22.1-4.fc19.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. try to start glom
2. ???
3. CRASH

Actual results:
$ glom
bool GlomBakery::Document::write_to_disk(): m_file_uri is empty.

(glom:23309): glibmm-ERROR **: 
unhandled exception (type std::exception) in signal handler:
what: Error code from xmlParseChunk(): 111

Trace/breakpoint trap (core dumped)

Expected results:
Glom window

Additional info:
Comment 1 Murray Cumming 2013-10-21 04:18:43 EDT
This was caused by a change in libxml behaviour. This commit in Glom fixes it:
https://git.gnome.org/browse/glom/commit/?h=glom-1-22&id=6f01d7d8f79cd127418c2a4b234de670225fb71a


There are other fixes in the glom-1-22 branches, so it would be best to just update the package with the latest bugfix release (glom 1.22.3)


A couple of Fedora users reported this upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=687996
https://bugzilla.gnome.org/show_bug.cgi?id=710358
Comment 2 Murray Cumming 2013-11-02 16:52:39 EDT
Does anyone know what we can do to get the Glom package updated?
Comment 3 Haïkel Guémar 2013-11-03 04:04:18 EST
Sorry, i had hectic days, i'll push update this morning.
If there's an emergency, you can ping me on freenode (number80)
Comment 4 Fedora Update System 2013-11-03 05:46:22 EST
glom-1.22.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/glom-1.22.4-1.fc19
Comment 5 Haïkel Guémar 2013-11-03 05:46:29 EST
*** Bug 1022294 has been marked as a duplicate of this bug. ***
Comment 6 Murray Cumming 2013-11-03 14:27:03 EST
Thanks.
Comment 7 Fedora Update System 2013-11-04 21:54:44 EST
Package glom-1.22.4-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glom-1.22.4-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20641/glom-1.22.4-1.fc19
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.