Bug 1013235 - Failed to open /dev/initctl: No such device or address
Failed to open /dev/initctl: No such device or address
Status: CLOSED DUPLICATE of bug 1010603
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-28 12:34 EDT by Ihatewindows
Modified: 2014-02-17 01:14 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-17 01:14:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is what I get with "shutdown now" as root, the same happens with sudo as a normal user. (437.42 KB, image/png)
2013-09-28 12:34 EDT, Ihatewindows
no flags Details
The log file made from of "journalctl -b | tee log" (149.41 KB, text/x-vhdl)
2013-10-12 16:05 EDT, Ihatewindows
no flags Details
The log file made from of "journalctl -b | tee log" (149.41 KB, text/plain)
2013-10-12 16:53 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details

  None (edit)
Description Ihatewindows 2013-09-28 12:34:54 EDT
Created attachment 804457 [details]
This is what I get with "shutdown now" as root, the same happens with sudo as a normal user.

Description of problem:
Whenever I restart, it will log me out and will not restart. Logging back in and typing "sudo shutdown now" in a terminal gives the following:

Failed to open /dev/initctl: No such device or address
Failed to talk to init daemon.

Then it just drops me to a prompt where I started.

Version-Release number of selected component (if applicable):


How reproducible:
Type "sudo shutdown now" or run "shutdown now" as root

Steps to Reproduce:
1.Open a terminal
2.Type sudo shutdown now
3.See the error

Actual results:
Typing "sudo shutdown now" in a terminal gives the following:

Failed to open /dev/initctl: No such device or address
Failed to talk to init daemon.

Expected results:
It should send the KILL signal and shut down immediately

Additional info:
I've had some long boot times and had to wait about 30 seconds before I get any authentication prompt for something like sudo or a lockscreen.
Comment 1 Kay Sievers 2013-10-01 22:12:34 EDT
This works just fine here.

Do you have this file?
  $ ls -l /dev/initctl 
  prw------- 1 root root 0 Oct  2 03:14 /dev/initctl
Comment 2 Ihatewindows 2013-10-02 17:39:56 EDT
Yes, it is there. 

ls -l /dev
<snip>
prw-------. 1 root root             0 Oct  2 17:04 initctl
<huge snip>
Comment 3 Lennart Poettering 2013-10-04 11:24:12 EDT
Does "systemctl poweroff" work?
Comment 4 Mikael 2013-10-07 10:31:32 EDT
I encountered the same bug as in the original report, and as in that case, "ls /dev/initctl -l" does find the proper file.

On my system, "systemctl poweroff" gives the following error:

Failed to get D-Bus connection: Failed to connect to socket /run/systemd/private: Connection refused.


For anyone else stumbling upon this problem, [1] suggests using 
"sync && reboot -f" to move on with the reboot/poweroff cycle. That worked for me.



[1]: https://lists.fedoraproject.org/pipermail/devel/2013-March/179407.html
Comment 5 Mikhail Zabaluev 2013-10-12 05:53:36 EDT
This started happened to me ever after kernel 3.10.10-200. After suspending and resuming the laptop (Lenovo Thinkpad T500), the screen lock UI hangs up, then gnome-shell crashes and is restarted. sudo pauses for 30 seconds before printing the password prompt, so there probably is some hold-up in pam.
The laptop cannot be shut down or restarted from gnome-shell, and systemd is hosed:
$ LANG=C sudo shutdown -h
Failed to talk to shutdownd, proceeding with immediate shutdown: Connection refused
Failed to open /dev/initctl: No such device or address
Failed to talk to init daemon.

The device is present:
prw-------. 1 root root 0 Oct 12 12:31 /dev/initctl

On the sum of effects, I'd
Comment 6 Mikhail Zabaluev 2013-10-12 05:54:40 EDT
(In reply to Mikhail Zabaluev from comment #5)
> On the sum of effects, I'd
... reclassify the bug as critical.
Comment 7 Mikhail Zabaluev 2013-10-12 06:58:58 EDT
"systemctl poweroff" fails:

Failed to get D-Bus connection: Failed to connect to socket /run/systemd/private: Connection refused

Also, NetworkManager is unable to restore a Wi-Fi connection.
Comment 8 Zbigniew Jędrzejewski-Szmek 2013-10-12 09:55:36 EDT
Kernel version and architecture? Systemd version?
Comment 9 Zbigniew Jędrzejewski-Szmek 2013-10-12 13:49:10 EDT
And also please attach logs (journalctl -b output).
Comment 10 Ihatewindows 2013-10-12 16:05:48 EDT
Created attachment 811623 [details]
The log file made from of "journalctl -b | tee log"
Comment 11 Ihatewindows 2013-10-12 16:09:13 EDT
Alright, uploaded the file output of of "journalctl -b | tee log", only with my username replaced with $USER for security's sake.

I've also figured something out about this: it only seems to happen after a suspend. Shutting down works fine if I don't suspend it.
Comment 12 Zbigniew Jędrzejewski-Szmek 2013-10-12 16:53:07 EDT
Created attachment 811646 [details]
The log file made from of "journalctl -b | tee log"

Please use text/plain as the type.
Comment 13 Zbigniew Jędrzejewski-Szmek 2013-10-12 17:03:32 EDT
Is this log from the time that the problem happened? I don't see anything about suspending there.

This looks like the same issue as 1010603.
Comment 14 Mikhail Zabaluev 2013-10-13 03:47:45 EDT
(In reply to Zbigniew Jędrzejewski-Szmek from comment #8)
> Kernel version and architecture? Systemd version?

kernel 3.11.3-201.fc19; any kernel after 3.10.10 exhibits this problem.
The architecture is i686. systemd 204-16.fc19.

My problem is most definitely bug #1010603:

Oct 13 10:29:09 zabaluev-laptop kernel: PM: Finishing wakeup.
Oct 13 10:29:09 zabaluev-laptop kernel: Restarting tasks ... 
Oct 13 10:29:09 zabaluev-laptop kernel: traps: systemd[1] general protection ip:
b73cb2c0 sp:bff69d9c error:0

The comments on that bug and the kernel bug 61781 seem to indicate it's endemic to i686, so I can't say if the original reporter has the same issue.
Comment 15 gingerling 2013-10-24 11:28:27 EDT
Hi, most of the above is over my head, however, since updating fedora 18 using sudo yum update 2 days ago, I have been having similar issue: shutdown, when selected from the GUI menu, simply logs me out. This is the same on laptop and desktop. Thanks x
Comment 16 gingerling 2013-10-24 11:33:28 EDT
I just updated again and this seems to be fixed now.
Comment 17 Zbigniew Jędrzejewski-Szmek 2014-02-17 01:14:49 EST

*** This bug has been marked as a duplicate of bug 1010603 ***

Note You need to log in before you can comment on or make changes to this bug.