Bug 1013280 - Slideshow in Anaconda 20.21 is only in Enlish language while in other distros like Ubuntu the language of the slideshow in the installer is according to the selected language for installation
Summary: Slideshow in Anaconda 20.21 is only in Enlish language while in other distros...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-logos
Version: 20
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F20FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-09-29 03:03 UTC by Nix\
Modified: 2013-11-28 06:02 UTC (History)
15 users (show)

Fixed In Version: fedora-logos-21.0.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-26 04:53:03 UTC
Type: Bug


Attachments (Terms of Use)
svg sources for the bitmaps (76.77 KB, application/zip)
2013-10-12 20:55 UTC, Domingo Becker
no flags Details
pot file for translation (2.53 KB, application/vnd.ms-powerpoint)
2013-10-12 20:56 UTC, Domingo Becker
no flags Details
This is the set of bitmaps for Spanish language (118.07 KB, application/x-gzip)
2013-10-13 01:16 UTC, Domingo Becker
no flags Details
This is the set of bitmaps for Japanese language (123.44 KB, application/x-gzip)
2013-10-13 01:21 UTC, Domingo Becker
no flags Details
This is the set of bitmaps for French language (127.28 KB, application/x-gzip)
2013-10-13 13:22 UTC, Domingo Becker
no flags Details
This is the set of bitmaps for Ukrainian language (127.07 KB, application/x-gzip)
2013-10-13 13:26 UTC, Domingo Becker
no flags Details
This is the set of bitmaps for Chinese (Traditional) language (124.66 KB, application/x-gzip)
2013-10-14 16:39 UTC, Cheng-Chia Tseng
no flags Details
This is the set of bitmaps for Chinese (Simplified) language (130.00 KB, application/x-gzip)
2013-10-19 14:30 UTC, Alick Zhao
no flags Details
This is the set of bitmaps proposed for Spanish language in Rhythmbox fixing mp3 word an break of line (198.53 KB, image/jpeg)
2013-11-09 10:22 UTC, Nix\
no flags Details
This is the set of svg for Chinese (Simplified) language (130.00 KB, application/x-gzip)
2013-11-25 09:32 UTC, Alick Zhao
no flags Details

Description Nix\ 2013-09-29 03:03:01 UTC
Description of problem:

The slideshow of images promoting Fedora in anaconda 20.21 are only in English while in other distros are in each language possible.
If I select es_ES for the installer the images of the slideshow are in English, so, is not 100% world wide the message because not all people can read English easily.
I propose that other distros like Ubuntu or Linux Mint or Mageia, the installer wear images in the slideshow for all languages or minimus for the most common languages: 1.-English 2.-Chinese 3.-Spanish 4.-Hindi 5.-Portuguese 6.-Russian 7.-Japanese 8.-German 9.-Korean 10.-Francais 11.-Arabic

The mentioned languages are the more common used in the world wide, and if Fedora profess be a universal OS, friends, the 3 F, is a very good idea be that the installer was more friendly with all ethnicities and therefore languages/country

Version-Release number of selected component (if applicable):
Anaconda 20.21 and related stuff of anaconda. Fedora 20 Alpha4 Live KDE i686

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Other distros, have images in the slideshow for all languages or the most common languages at least.
Is a good idea for save space in bits, that the images are a text with images, so:

Text (all languages and less space in DVD) + Image (the image without text).

I stay that my propose was taken by Fedora team.

Comment 1 Brian Lane 2013-10-02 00:34:54 UTC
Anaconda supports this, but right now there are only images under /usr/share/anaconda/pixmaps/rnotes/en/. Someone needs to create the ones for other languages.

Comment 2 Domingo Becker 2013-10-07 23:11:25 UTC
There is a volunteer to create those banners in Spanish, but I have a question.

Do those bitmaps come from a SVG file? or they are simple bitmaps...

Comment 3 Domingo Becker 2013-10-09 02:56:06 UTC
(In reply to Brian C. Lane from comment #1)
> Anaconda supports this, but right now there are only images under
> /usr/share/anaconda/pixmaps/rnotes/en/. Someone needs to create the ones for
> other languages.

What package do that directory come from?

I took a look at anaconda-20.21-1.fc20.x86_64.rpm and anaconda-20.21-1.fc20.src.rpm and I don't see it.

Comment 4 Hajime Taira 2013-10-09 03:38:35 UTC
I think so good about localized banner.
But also who does prepare the image per fedora release?
I want to manage messages of banner by po file.

Comment 5 Yuri Chornoivan 2013-10-09 05:10:06 UTC
(In reply to Domingo Becker from comment #3)
> (In reply to Brian C. Lane from comment #1)
> > Anaconda supports this, but right now there are only images under
> > /usr/share/anaconda/pixmaps/rnotes/en/. Someone needs to create the ones for
> > other languages.
> 
> What package do that directory come from?
> 
> I took a look at anaconda-20.21-1.fc20.x86_64.rpm and
> anaconda-20.21-1.fc20.src.rpm and I don't see it.

As it is shown in the bug header, it's fedora-logos package:

https://git.fedorahosted.org/git/fedora-logos.git

The diractory name is "rnotes".

Comment 6 Hajime Taira 2013-10-11 02:35:18 UTC
I tried to translate some svg files of rnotes.
But it needed to adjust font size and word wrap in Japanese.

http://htaira.fedorapeople.org/fedora-logos/ja-svg.tar.bz2

String of Cd-or-dvd.png used 2 colors (black and white).
It is difficult by po translation. I think so.

Comment 7 Domingo Becker 2013-10-12 20:55:49 UTC
Created attachment 811647 [details]
svg sources for the bitmaps

Comment 8 Domingo Becker 2013-10-12 20:56:36 UTC
Created attachment 811648 [details]
pot file for translation

Comment 9 Domingo Becker 2013-10-13 01:16:55 UTC
Created attachment 811663 [details]
This is the set of bitmaps for Spanish language

Please, add this set of bitmaps with destination directory 

/usr/share/anaconda/pixmaps/rnotes/es

to fedora-logos package.

Thank you.

Comment 10 Domingo Becker 2013-10-13 01:21:51 UTC
Created attachment 811664 [details]
This is the set of bitmaps for Japanese language

This is the set of bitmaps for Japanese language

Please, add this set of bitmaps with destination directory 

/usr/share/anaconda/pixmaps/rnotes/ja

to fedora-logos package.

Thank you.

Comment 11 dominique 2013-10-13 07:12:53 UTC
hi Domingo,
here the tarball for fr :
http://sd-1.archive-host.com/membres/up/138795649635992281/fr-logo.zip

Comment 12 Yuri Chornoivan 2013-10-13 11:39:43 UTC
Ukrainian (uk) files (SVG, PNG and JPG) can be found here:

https://dl.dropboxusercontent.com/u/55247264/uk.tar.bz2

Comment 13 Domingo Becker 2013-10-13 13:22:02 UTC
Created attachment 811745 [details]
This is the set of bitmaps for French language

Please, add this set of bitmaps with destination directory 

/usr/share/anaconda/pixmaps/rnotes/fr

to fedora-logos package.

Thank you.

Comment 14 Domingo Becker 2013-10-13 13:26:44 UTC
Created attachment 811746 [details]
This is the set of bitmaps for Ukrainian language

Please, add this set of bitmaps with destination directory 

/usr/share/anaconda/pixmaps/rnotes/uk

to fedora-logos package.

Thank you.

Comment 15 Domingo Becker 2013-10-13 23:22:54 UTC
I produced a rpm with the languages translated so far. The necessary changes to fedora-logos package are the following.

The original pixmaps should be moved to rnotes/en directory in fedora-logos git repository.

Later, the translated languages should be added to their corresponding directories, as stated in their attachments (rnotes/langcode) in this bug.

The fedora-logos.spec file has a script that start with the following comment:

# when we get translated rnotes, I'll need to rework this, but this will do for now

the script should be changed to:

 for i in rnotes/* ; do
  mkdir -p $RPM_BUILD_ROOT%{_datadir}/anaconda/pixmaps/$i
  install -p -m 644 $i/* $RPM_BUILD_ROOT%{_datadir}/anaconda/pixmaps/$i
 done
 
and that's it.

If it's necessary, I'm already a fedora packager and I may update the fedora-logos package.

Comment 16 dominique 2013-10-14 08:12:45 UTC
(In reply to Domingo Becker from comment #15)
> I produced a rpm with the languages translated so far. The necessary changes
> to fedora-logos package are the following.
> 
> The original pixmaps should be moved to rnotes/en directory in fedora-logos
> git repository.
> 
> Later, the translated languages should be added to their corresponding
> directories, as stated in their attachments (rnotes/langcode) in this bug.
> 
> The fedora-logos.spec file has a script that start with the following
> comment:
> 
> # when we get translated rnotes, I'll need to rework this, but this will do
> for now
> 
> the script should be changed to:
> 
>  for i in rnotes/* ; do
>   mkdir -p $RPM_BUILD_ROOT%{_datadir}/anaconda/pixmaps/$i
>   install -p -m 644 $i/* $RPM_BUILD_ROOT%{_datadir}/anaconda/pixmaps/$i
>  done
>  
> and that's it.
> 
> If it's necessary, I'm already a fedora packager and I may update the
> fedora-logos package.

For test I rebuild with rpmbuild the fedora-logos-19.0.4-4.fc19.src with your spec and your change (I create a "en" folder and add es,fr,ja and uk folder), and that work.

If that help you.

Comment 17 Domingo Becker 2013-10-14 13:18:17 UTC
We need someone with write access to fedora-logos git repository to do the changes described in comment #15 and update the fedora-logos package.

Comment 18 Cheng-Chia Tseng 2013-10-14 16:39:27 UTC
Created attachment 812106 [details]
This is the set of bitmaps for Chinese (Traditional) language

Comment 19 Cheng-Chia Tseng 2013-10-14 16:43:54 UTC
I have made the bitmaps for zh_TW locale. Please add these with destination directory 
/usr/share/anaconda/pixmaps/rnotes/zh_TW

Here is the link of source files. https://www.dropbox.com/s/8mz7a7red0y6j3k/zh_TW-source.tar.gz

Comment 20 Alick Zhao 2013-10-19 14:30:20 UTC
Created attachment 813993 [details]
This is the set of bitmaps for Chinese (Simplified) language


Please, add this set of bitmaps with destination directory 

/usr/share/anaconda/pixmaps/rnotes/zh_CN

to fedora-logos package.

Thank you.

Comment 21 Hajime Taira 2013-10-22 02:44:02 UTC
(In reply to Domingo Becker from comment #8)
> Created attachment 811648 [details]
> pot file for translation

I looked pot file.

Did you consider the people of multi-byte countries?

Comment 22 Cheng-Chia Tseng 2013-10-22 14:05:59 UTC
(In reply to Hajime Taira from comment #21)
> (In reply to Domingo Becker from comment #8)
> > Created attachment 811648 [details]
> > pot file for translation
> 
> I looked pot file.
> 
> Did you consider the people of multi-byte countries?

In this case, pot file does not fit all languages. 

For different languages, the string location, the color-break position (for example black first latter white to fit the background) of sentence and the proper font for the languages are not all the same with English one. We still have to adjust those things to make them look perfect. It is more like work which combines art with localization. 

In my opinion, there won't be an universal pot file fit for all languages in this case. Pot file here only accelerate the speed of creating the svg files.

Comment 23 dominique 2013-10-22 16:11:09 UTC
(In reply to Cheng-Chia Tseng from comment #22)
> (In reply to Hajime Taira from comment #21)
> > (In reply to Domingo Becker from comment #8)
> > > Created attachment 811648 [details]
> > > pot file for translation
> > 
> > I looked pot file.
> > 
> > Did you consider the people of multi-byte countries?
> 
> In this case, pot file does not fit all languages. 
> 
> For different languages, the string location, the color-break position (for
> example black first latter white to fit the background) of sentence and the
> proper font for the languages are not all the same with English one. We
> still have to adjust those things to make them look perfect. It is more like
> work which combines art with localization. 
> 
> In my opinion, there won't be an universal pot file fit for all languages in
> this case. Pot file here only accelerate the speed of creating the svg files.

I agree.

Comment 24 Domingo Becker 2013-10-22 22:22:13 UTC
(In reply to Hajime Taira from comment #21)
> (In reply to Domingo Becker from comment #8)
> > Created attachment 811648 [details]
> > pot file for translation
> 
> I looked pot file.
> 
> Did you consider the people of multi-byte countries?

What is a multi-byte country for you? Would you give an example?

The pot file encoding is UTF-8, and we have never had problem with that.

Comment 25 Domingo Becker 2013-10-22 22:33:54 UTC
(In reply to Cheng-Chia Tseng from comment #22)
> (In reply to Hajime Taira from comment #21)
> > (In reply to Domingo Becker from comment #8)
> > > Created attachment 811648 [details]
> > > pot file for translation
> > 
> > I looked pot file.
> > 
> > Did you consider the people of multi-byte countries?
> 
> In this case, pot file does not fit all languages. 
> 
> For different languages, the string location, the color-break position (for
> example black first latter white to fit the background) of sentence and the
> proper font for the languages are not all the same with English one. We
> still have to adjust those things to make them look perfect. It is more like
> work which combines art with localization. 

I said so in the announce to trans list.

> 
> In my opinion, there won't be an universal pot file fit for all languages in
> this case. Pot file here only accelerate the speed of creating the svg files.

Yep.

It is trial and error, until you get acceptable results.

Comment 26 Nix\ 2013-11-09 09:40:29 UTC
Still in Anaconda 20.25.6-1.fc20

Comment 27 Nix\ 2013-11-09 09:47:36 UTC
@Domingo Becker

In the image for es_ES say "reproductores mp3" when Fedora by default not include mp3 codec and, the original image say "media players". In adittion, 3 characters less (mp3) and maybe is not needed the foo-break line-foo.

Comment 28 Nix\ 2013-11-09 10:22:29 UTC
Created attachment 821861 [details]
This is the set of bitmaps proposed for Spanish language in Rhythmbox fixing mp3 word an break of line

Comment 29 Domingo Becker 2013-11-09 10:35:46 UTC
(In reply to Nix\ from comment #27)
> @Domingo Becker
> 
> In the image for es_ES say "reproductores mp3" when Fedora by default not
> include mp3 codec and, the original image say "media players". In adittion,
> 3 characters less (mp3) and maybe is not needed the foo-break line-foo.

It's because that's the phrase people use. We don't say "media players" in Spanish, but "mp3 player", and it fits that banner fine.

(In reply to Nix\ from comment #26)
> Still in Anaconda 20.25.6-1.fc20

This is unfortunate. I thought we were on time for beta release.

Comment 30 Fedora Update System 2013-11-19 20:57:01 UTC
fedora-logos-21.0.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedora-logos-21.0.1-1.fc20

Comment 31 Adam Williamson 2013-11-19 20:58:42 UTC
Proposing as a final blocker, criterion "The final branded release notes must be present on release-blocking images and the appropriately versioned generic release notes must be available in the release repository." - https://fedoraproject.org/wiki/Fedora_20_Final_Release_Criteria#Release_notes

Comment 32 Adam Williamson 2013-11-20 17:33:43 UTC
Discussed at 2013-11-20 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-20/f20-blocker-review.2013-11-20-17.00.log.txt . Rejected as a blocker but accepted as a freeze exception issue - I misread the report / update note, this is not really about release notes but about the installer ad banners, which live in a directory called 'rnotes', so it's not really a blocker issue. But we accept it as a freeze exception issue, meaning the update can be taken through the Final freeze if it doesn't go stable by then.

We note that we should check that the additional images don't make the package so much bigger that it causes any of our release-blocking images to go over their size limits - particularly the desktop live image, which is very close to its limit.

Comment 33 Kamil Páral 2013-11-21 12:20:03 UTC
Banners show correctly in Spanish and Japanese in F20 TC2. Verified.

Comment 34 dominique 2013-11-23 07:56:40 UTC
(In reply to Adam Williamson from comment #32)
> We note that we should check that the additional images don't make the
> package so much bigger that it causes any of our release-blocking images to
> go over their size limits - particularly the desktop live image, which is
> very close to its limit.

Why did not use .svg files instead of .png files ?

In a svg file you can set all translations with the "switch" tag, and you have only 5 svg files for all language instead of 5 png file for each language.

In anaconda, if you set language to french, it's french version show up, and if there is no translation for a language, it's the english version.

Comment 35 dominique 2013-11-24 08:02:41 UTC
For test I make a rnote folder with svg files, including french, spanish, zh_TW translation and default en.

It's here : https://mega.co.nz/#!1I1S1ITK!EjveFjgUdvRv5yhOfzcg0lapsu8VDaeiTfIAKj-Myec

The size of this folder is 138.2 kio

If that help you.

Comment 36 dominique 2013-11-24 08:59:55 UTC
I make a typo in Rhythmbox.svg, here the good one : https://mega.co.nz/#!JRcz2JSA!YxZhwEBhPa6ZzTNVafKAjmVbPVoE5vWe95HXJENiOjs
 Sorry.

Comment 37 dominique 2013-11-24 15:23:30 UTC
To complete my svg I need the set of svg for uk, ja and zh_CN.

Comment 38 Yuri Chornoivan 2013-11-24 15:39:11 UTC
(In reply to dominique from comment #37)
> To complete my svg I need the set of svg for uk, ja and zh_CN.

Ukrainian: https://dl.dropboxusercontent.com/u/55247264/uk.tar.bz2

Comment 39 Alick Zhao 2013-11-25 09:32:49 UTC
Created attachment 828580 [details]
This is the set of svg for Chinese (Simplified) language

This is the set of svg files for Chinese (Simplified) language. I adjusted the line spacing in Cd-or-dvd.svg to make sure the background color change does not occur in the middle of a (multi-byte) character.

Comment 40 dominique 2013-11-25 10:12:46 UTC
Thank my friends.
Here the rnote directory with added uk, ja and zh_CN :

https://mega.co.nz/#!MNlCVTCI!bgluZghGZ6qW92WANP1BrzFlLRRYOwfk_TnzzlOUH3k

Thank.

Comment 41 Kamil Páral 2013-11-25 13:02:03 UTC
dominique: This bug has been resolved, banners now display localized. I agree that it would be great to use SVGs instead of PNGs, but it has to be reported as a separate issue (this one will be closed once the update is pushed to stable repository). Can you please open a new bug against fedora-logos, describe your suggestion and attach your files? Thanks.

Comment 42 dominique 2013-11-25 18:24:16 UTC
OK Kamil, I open a new bug report here : https://bugzilla.redhat.com/show_bug.cgi?id=1034390

Comment 43 Fedora Update System 2013-11-26 04:53:03 UTC
fedora-logos-21.0.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 44 Adam Williamson 2013-11-27 22:54:49 UTC
Note that the desktop live image has wound up over its size limit for Final TC3, and this change is a contributor to that (without the translated banners, TC3 would still be under-size).

Comment 45 dominique 2013-11-28 06:02:16 UTC
(In reply to Adam Williamson from comment #44)
> Note that the desktop live image has wound up over its size limit for Final
> TC3, and this change is a contributor to that (without the translated
> banners, TC3 would still be under-size).

Adam, can you send this comment to this bug : https://bugzilla.redhat.com/show_bug.cgi?id=1034407


Note You need to log in before you can comment on or make changes to this bug.