Bug 101333 - redhat-soundcard-config does not see the second USB card
redhat-soundcard-config does not see the second USB card
Status: CLOSED DUPLICATE of bug 81843
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-soundcard (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Depends On:
  Show dependency treegraph
Reported: 2003-07-30 17:36 EDT by Eugenia Loli-Queru
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:57:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eugenia Loli-Queru 2003-07-30 17:36:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Description of problem:
The whole story is that I plugged in a USB sound card
(http://www.osnews.com/story.php?news_id=4158) and Kudzu found it but..... I got
everything explained here:
Please read for the explanation in the Gedit window of that screenshot.

So, I had no sound, and the primary function of the iMic, being a 
microphone, was not available at all in the volume control panel.

As for the redhat-config-soundcard could only see the SBLive PCI card and not
the USB card, even if Kudzu (semi-)probed it. 

I am sorry for including info on the other modules too, but this bug is damn
complex, it involves many other modules in the story. :(

I got sound back after re-running the "Sound Detection Tool" on Severn after
removing the USB device. Then though, I found another, new bug now in the Volume
Control in the notification gnome-panel area. Because the USB device was
disconnected, it would not default to the second one, the SBLive, it would just
move its handler eratically. I had to quit the panel app and restart it and now
is ok.

As you can see, ALL of the apps showing there had bugs in respect to the USB
audio, but I was advised to file a bug report with Kudzu first (#101331). I will
also be filing reports with on gnome-media too.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Plug in your iMic
2. Run Red Hat Severn
3. Watch Kudzu asking you 7 times to configure the device.

Actual Results:  No sound, multiple devices found by Kudzu instead of one,
redhat-config-soundcard was not recognizing it at all, volume control woudln't
show all the sliders available, volume control in the notification area would go
berzerk after removing the USB device intead of defaulting to SBLive (second
audio card in that PC)

Expected Results:  hmm.. to work... to have two working audio cards, recognized
by all pref panels.

Additional info:

Dual Celeron 533 Mhz, 256 MB RAM, Matrox G400 AGP, BX chipset Intel.
Comment 1 Bastien Nocera 2004-07-22 05:05:30 EDT

*** This bug has been marked as a duplicate of 81843 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:57:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.