Bug 81843 - problems with two soundcards
Summary: problems with two soundcards
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-soundcard   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Keywords:
: 101333 106748 107190 115198 119387 122277 125349 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-14 17:24 UTC by David Balažic
Modified: 2007-04-18 16:49 UTC (History)
7 users (show)

Fixed In Version: 1.2.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-19 13:41:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/modules.conf (3.15 KB, text/plain)
2003-01-14 17:27 UTC, David Balažic
no flags Details
/var/log/messages excerpt (1.86 KB, text/plain)
2003-01-14 17:29 UTC, David Balažic
no flags Details

Description David Balažic 2003-01-14 17:24:29 UTC
Description of problem:

firstboot has some issues with multiple soundcard ( I have two ).
The test sound is played on the wrong one. The selected primary one is not used 
as primary later.

My hardware is :
 - onboard SiS 745 audio ( driver is i810_audio )
   Silicon Integrated Systems [SiS]
 - sb64pci PCI card ( driver is es1370 )
   ensoniq ES1370 [AudioPCI]

Version-Release number of selected component (if applicable):
( Phoebe CD )
firstboot-1.03-2

How reproducible:


Steps to Reproduce:
1. install & reboot 
2. in firstboot "Sound Card Configuration" screen , SiS is on the first 
subpage, ensoniq on the second ( SiS is visible ), "Primary audio device" is 
set to SiS
3. switch to the "ensoniq" tab page and click on the "Play test sound" button. 
It is played correctly on the "ensoniq" card
4. set "Primary audio device" to "ES1370 [AudioPCI]"
5. switch to the "sis" tab page and click on the "Play test sound" button. It 
plays it on the "ensoniq" card ! wrong !
6. i played around a bit more, set "Primary audio device" to "ensoniq" at the 
end and finished firstboot
7. log in, play something in xmms , it play on the SiS card ! wrong !

The resulting modules.conf file was weird too, I attach it.
I will also attach a part of /var/log/messages , where a Traceback can be 
found, that may be related to this bug ( or not ).

Comment 1 David Balažic 2003-01-14 17:27:51 UTC
Created attachment 89354 [details]
/etc/modules.conf

Comment 2 David Balažic 2003-01-14 17:29:23 UTC
Created attachment 89355 [details]
/var/log/messages excerpt

A traceback from firstboot involving file
/usr/share/redhat-config-soundcard/soundcard.py

Comment 3 Brent Fox 2003-01-14 22:27:47 UTC
Should be fixed in redhat-config-soundcard-1.0.2-4.  It was actually a bug in
redhat-config-soundcard, so I'm changing the component as well.  QA, please verify.

Comment 4 David Balažic 2003-01-30 19:20:26 UTC
phoebe2 ( 8-0.93 ) , redhat-config-soundcard-1.0.2-4 , firstboot-1.03-5
Still problems :

( same system )

Switch "Primary audio device" to "ensoniq" -> both test sound buttons play on 
the ensoniq card
Switch Primary back to SiS :
 -> test button on SiS subpage plays on ensoniq card
 -> test button on ensoniq subpage plays on ensoniq card
 -> test button on SiS subpage plays on SiS card





Comment 5 Brent Fox 2003-05-25 14:30:49 UTC
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.

Comment 6 David Balažic 2003-10-24 12:42:17 UTC
See bug 107190

Comment 7 Brent Fox 2004-03-25 21:38:27 UTC
*** Bug 107190 has been marked as a duplicate of this bug. ***

Comment 8 Bastien Nocera 2004-07-22 09:05:33 UTC
*** Bug 101333 has been marked as a duplicate of this bug. ***

Comment 9 Bastien Nocera 2004-07-22 09:06:13 UTC
*** Bug 122277 has been marked as a duplicate of this bug. ***

Comment 10 Luke Dubber 2004-08-16 04:46:28 UTC
I have simular issue, I have two soundcards also, SB Live! EMU10k1 PCI
And VT8233/A/8235/8237 AC97 Audio Controller, Onboard. The Problem I
have is that no matter what I do it wont play a sound it dectects both
of them just fine just wont play a sound I have no Idea what to do?

Steps to Reproduce:
1. install & reboot 
2. in firstboot "Sound Card Configuration" screen , It wont play any
sound and even after I restart and go the the config program it still
does not work.

Comment 11 Bastien Nocera 2004-09-19 13:14:07 UTC
*** Bug 106748 has been marked as a duplicate of this bug. ***

Comment 12 Bastien Nocera 2004-09-19 13:15:26 UTC
*** Bug 115198 has been marked as a duplicate of this bug. ***

Comment 13 Bastien Nocera 2004-09-19 13:18:05 UTC
*** Bug 125349 has been marked as a duplicate of this bug. ***

Comment 14 Bastien Nocera 2004-09-19 13:37:03 UTC
*** Bug 119387 has been marked as a duplicate of this bug. ***

Comment 15 Bastien Nocera 2004-09-19 13:41:58 UTC
This should be fixed with recent versions of kudzu (1.1.90-1) and
system-config-soundcard (1.2.9-1).
Please test with those versions and open new independant bugs if this
is not the case. Thank you.


Note You need to log in before you can comment on or make changes to this bug.