Bug 101338 - Missing BuildRequires for tetex-2.0.2-6.src.rpm
Summary: Missing BuildRequires for tetex-2.0.2-6.src.rpm
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: tetex   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-07-30 22:25 UTC by Leonard den Ottolander
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version: 2.0.2-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-08 14:55:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leonard den Ottolander 2003-07-30 22:25:58 UTC
Description of problem:
Building of tetex-2.0.2-6.src.rpm fails on a missing BuildRequires.
Although all dependencies are satisfied build fails on missing autconf-2.13.


Version-Release number of selected component (if applicable):
tetex-2.0.2-6.src.rpm (Severn)


Steps to Reproduce:
1. # rpm -e autoconf213
2. $ rpmbuild -ba tetex.spec 2>&1 | tee tetex.build.log


Actual results:
Failure on missing autoconf-2.13:

texk/tetex
./reautoconf: line 44: autoconf-2.13: command not found
texk/web2c
./reautoconf: line 44: autoconf-2.13: command not found
texk/xdvik
./reautoconf: line 44: autoconf-2.13: command not found
libs/libwww
./reautoconf: line 59: autoconf-2.13: command not found
libs/t1lib
./reautoconf: line 65: autoconf-2.13: command not found
libs/type1
./reautoconf: line 68: autoconf-2.13: command not found
error: Bad exit status from /var/tmp/rpm-tmp.82856 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.82856 (%build)

    

Expected results:
Succesful build when all dependencies are satisfied.


Additional info:
Severn workstation install with X-devel or gtk-devel (? not sure) packages
deselected.

I had problems on 7.3 as well when building tetex (with fixed old source build
stop), probably because of missing dependencies (BuildRequires).
More missing [Build]Requires might follow.

Solution:
Add BuildRequires for either /usr/bin/autoconf-213 or autoconf213 (probably the
latter).

Comment 1 Nils Philippsen 2003-08-06 14:09:02 UTC
Still the case with 2.0.2-7

Comment 2 Tim Waugh 2003-08-06 14:48:59 UTC
It's fixed in CVS and will be in the build after 2.0.2-7.


Note You need to log in before you can comment on or make changes to this bug.