This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 1013398 - ibus-kkc does not automatically enter direct input mode on the password field in the locked screen
ibus-kkc does not automatically enter direct input mode on the password field...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-kkc (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
:
: 1024067 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-29 18:39 EDT by Yohei Yukawa
Modified: 2013-11-11 19:32 EST (History)
3 users (show)

See Also:
Fixed In Version: ibus-kkc-1.5.18-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 19:32:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yohei Yukawa 2013-09-29 18:39:09 EDT
Description of problem:
ibus-kkc does not automatically enter direct input mode on the password field in the locked screen.

Version-Release number of selected component (if applicable):
ibus.x86_64                            1.5.4-1.fc21
ibus-gtk2.x86_64                       1.5.4-1.fc21
ibus-gtk3.x86_64                       1.5.4-1.fc21
ibus-kkc.x86_64                        1.5.18-1.fc21
libkkc.x86_64                          0.3.1-2.fc21
libkkc-common.noarch                   0.3.1-2.fc21
libkkc-data.x86_64                     1:0.2.7-2.fc21
gnome-shell.x86_64                     3.10.0.1-1.fc21
How reproducible:
100%

Steps to Reproduce:
1. Log in
2. Select ibus-kkc
3. Make sure that IME is turned on (Hiragana-mode)
4. Lock screen from the gnome shell menu
5. Try to input the password

Actual results:
ibus-kkc is still in Hiragana-mode.

Expected results:
ibus-kkc is in direct input mode.

Additional info:
I'm not able to reproduce this issue with ibus-anthy 1.5.4-1.fc21
I'm able to reproduce this issue with ibus-mozc.x86_64 1.11.1522.102-2.fc21
Comment 1 Daiki Ueno 2013-10-16 05:14:05 EDT
Thanks for filing this separately.  Will enable the patch from the next build:
https://gitorious.org/libkkc/ibus-kkc/commit/8d9cfe6882f892ff936b20b986fab5d554715c96
Comment 2 Daiki Ueno 2013-10-28 21:58:46 EDT
*** Bug 1024067 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-11-07 00:29:46 EST
ibus-kkc-1.5.18-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-kkc-1.5.18-2.fc20
Comment 4 Fedora Update System 2013-11-07 14:06:16 EST
Package ibus-kkc-1.5.18-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-kkc-1.5.18-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20854/ibus-kkc-1.5.18-2.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-11-11 19:32:34 EST
ibus-kkc-1.5.18-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.