Bug 1013420 - SLES.11.3 guest Error inserting cirrus when booting on KVM hypervisor
SLES.11.3 guest Error inserting cirrus when booting on KVM hypervisor
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-29 22:46 EDT by Xiaoqing Wei
Modified: 2013-10-07 04:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 04:06:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest serial output (37.39 KB, text/plain)
2013-09-29 22:47 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2013-09-29 22:46:42 EDT
Description of problem:

SLES.11.3 guest Error inserting cirrus when booting on KVM hypervisor
Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.406.el6.x86_64

How reproducible:
5/10

Steps to Reproduce:
1./usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/virt/qemu/qemu \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20130927-142430-IrKLilIQ,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130927-142430-IrKLilIQ,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20130927-142430-IrKLilIQ,path=/tmp/seabios-20130927-142430-IrKLilIQ,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20130927-142430-IrKLilIQ,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/virt/shared/data/images/sles11sp3-32-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,bootindex=0 \
    -device virtio-net-pci,netdev=idTQHtMI,mac='9a:34:35:36:37:38',bus=pci.0,addr=0x3,id='idxJmAYJ' \
    -netdev tap,id=idTQHtMI,vhost=on,vhostfd=25,fd=24 \
    -m 8192 \
    -smp 8,maxcpus=8,cores=4,threads=1,sockets=2 \
    -cpu 'Opteron_G3' \
    -M rhel6.5.0 \
    -device AC97,addr=0x6 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga cirrus \
    -rtc base=utc,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off   \
    -no-kvm-pit-reinjection \
    -enable-kvm
2.
3.

Actual results:
...
2013-09-27 16:43:52: Boot logging started on /dev/tty1(/dev/console) at Fri Sep 27 04:43:51 2013
2013-09-27 16:43:52: [    2.411665] [drm] Initialized drm 1.1.0 20060810
2013-09-27 16:43:52: [    2.418231] This driver is only used in secure boot mode as default
2013-09-27 16:43:52: FATAL: Error inserting cirrus (/lib/modules/3.0.76-0.11-pae/kernel/drivers/gpu/drm/cirrus/cirrus.ko): Invalid argument
2013-09-27 16:43:52: Trying manual resume from /dev/vda1
2013-09-27 16:43:52: Invoking userspace resume from /dev/vda1
...
Expected results:
both host and guest work well

Additional info:
Comment 1 Xiaoqing Wei 2013-09-29 22:47:32 EDT
Created attachment 804847 [details]
guest serial output
Comment 3 Gerd Hoffmann 2013-10-02 01:52:10 EDT
Guest fails to load the cirrus driver for whatever reasons (log doesn't say why).  Looks like a guest bug to me.  Also the guest seems to boot up just fine according to the serial console log (attachment #1 [details]), just without the cirrus drm driver.  Are there any problems with the guest, other than the error message?
Comment 4 Xiaoqing Wei 2013-10-05 03:40:45 EDT
(In reply to Gerd Hoffmann from comment #3)
> Guest fails to load the cirrus driver for whatever reasons (log doesn't say
> why).  Looks like a guest bug to me.  Also the guest seems to boot up just
> fine according to the serial console log (attachment #1 [details]), just
> without the cirrus drm driver.  Are there any problems with the guest, other
> than the error message?


Nope, guest just working fine, network functioning, reboot/shutdown w/o failure
except acpi, like
Bug 1013498 - SLES.11.3 guest wont work after resume from S4 on KVM hypervisor
Comment 5 Gerd Hoffmann 2013-10-07 04:06:47 EDT
Thanks.  Nothing the hypervisor can do about guest bugs.  Closing.

Note You need to log in before you can comment on or make changes to this bug.