Bug 1013443 - Win7-64 guest installation with virtio-scsi BSOD
Win7-64 guest installation with virtio-scsi BSOD
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression, TestBlocker
: 996951 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 01:46 EDT by xhan
Modified: 2014-10-14 04:20 EDT (History)
15 users (show)

See Also:
Fixed In Version: virtio-win-prewhql-0.1-73
Doc Type: Bug Fix
Doc Text:
no docs needed (regression)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:20:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bsod_pic.jpg (36.32 KB, image/jpeg)
2013-09-30 01:46 EDT, xhan
no flags Details
memory_dump_bugcheck (9.98 KB, text/plain)
2013-09-30 02:46 EDT, xhan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1592 normal SHIPPED_LIVE virtio-win bug fix update 2014-10-13 21:27:03 EDT

  None (edit)
Description xhan 2013-09-30 01:46:15 EDT
Created attachment 804907 [details]
bsod_pic.jpg

Description of problem:

Install win7.x86_64, BSOD occurs. Tried 4 times, the first 3 times, they are 0x000000D1 error. See the attachment. bsod_pic.jpg. The last one is different bug it is with MEMORY.DUMP file. See the dump link file.

Version-Release number of selected component (if applicable):
kernel-2.6.32-418.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.402.el6.x86_64

How reproducible:
4/4

Steps to Reproduce:
1.start vm with unattended install
qemu \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -monitor stdio \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,addr=0x5 \
    -drive file='win7-64-virtio.qcow2',if=none,id=virtio-scsi0-id0,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device scsi-hd,drive=virtio-scsi0-id0 \
    -device virtio-net-pci,netdev=idam8kAd,mac='9a:0a:0b:0c:0d:0e',bus=pci.0,addr=0x3,id='idB40g9u' \
    -netdev tap,id=idam8kAd,vhost=on,script= \
    -m 65536 \
    -smp 8,maxcpus=8,cores=4,threads=1,sockets=2 \
    -cpu 'Penryn',hv_relaxed \
    -M rhel6.5.0 \
    -drive file='en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso',if=none,id=virtio-scsi1-id1,media=cdrom,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi1-id1 \
    -drive file='winutils.iso',if=none,id=virtio-scsi2-id2,media=cdrom,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi2-id2 \
    -drive file='virtio-win.latest_prewhql.iso',if=none,id=virtio-scsi3-id3,media=cdrom,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi3-id3 \
    -device AC97,addr=0x6 \
    -drive file='answer.vfd',if=none,id=fdc0-0-0,media=disk,readonly=off,format=raw \
    -global isa-fdc.driveA=fdc0-0-0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -spice port=3000,password=123456,addr=0,image-compression=auto_glz,zlib-glz-wan-compression=auto,streaming-video=all,agent-mouse=on,playback-compression=on,ipv4 \
    -vga qxl \
    -global qxl-vga.vram_size=33554432 \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off  \
    -enable-kvm

2. during the installation, the Win7 os would be reboot to confirm installed features
   then BSOD occurs

Actual results:
BSOD

Expected results:
installation should be normally finished.


Additional info:
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 29
model name	: Intel(R) Xeon(R) CPU           E7420  @ 2.13GHz
stepping	: 1
cpu MHz		: 2127.817
cache size	: 8192 KB
physical id	: 0
siblings	: 4
core id		: 0
cpu cores	: 4
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good xtopology aperfmperf pni dtes64 monitor ds_cpl vmx tm2 ssse3 cx16 xtpr pdcm dca sse4_1 lahf_lm dts tpr_shadow vnmi flexpriority
bogomips	: 4255.63
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management:
Comment 3 Mike Cao 2013-09-30 02:25:50 EDT
xhan ,Could you try whether ide can trigger it ?
Comment 4 xhan 2013-09-30 02:46:34 EDT
Created attachment 804921 [details]
memory_dump_bugcheck
Comment 14 lijin 2013-10-08 02:32:46 EDT
QE can reproduce this issue with build 72,win7-64 guest bsod with D1 code.

package info:
    Red Hat Enterprise Linux Server release 6.4 (Santiago)
    qemu-kvm-rhev-0.12.1.2-2.355.el6_4.9.x86_64
    kernel-2.6.32-358.21.1.el6.x86_64
    seabios-0.6.1.2-28.el6.x86_64
    vgabios-0.6b-3.7.el6.noarch
    virtio-win-prewhql-72
Comment 15 lijin 2013-10-08 06:21:09 EDT
QE retest with win7-32,win7-64,win2k8-64,win2k8-32,win2k8R2,only win7-64 hit this issue,cannot reproduce this issue on other guests.
Comment 16 guo jiang 2013-10-08 06:24:32 EDT
QE retest with win8-32,win8-64,cannot reproduce this issue as well.
Comment 17 guo jiang 2013-10-08 07:18:34 EDT
QE retest with win2012, cannot reproduce this issue.
Comment 18 Vadim Rozenfeld 2013-10-08 12:32:46 EDT
since image from https://bugzilla.redhat.com/attachment.cgi?id=804907 and  
http://fileshare.englab.nay.redhat.com/pub/section2/coredump/BZ1013443-MEMMORY.DMP are two different crashes, could you please be more specific on
which BSOD you see? Could you please update the crasdump file with the most recent one? Does the command line from bug description match crashdump file?
Does the problem happen buring unattended install only ot it also reproducible
during manual install?

Thanks,
Vadim.
Comment 19 xhan 2013-10-09 01:00:02 EDT
(In reply to Mike Cao from comment #3)
> xhan ,Could you try whether ide can trigger it ?

change the drive to ide, 

    -device ide-drive,bus=ide.0,unit=0,drive=virtio-scsi0-id0,id=ide0-0-0 \
    -drive file='win7-64-ide.qcow2',if=none,id=virtio-scsi0-id0,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \

This issue could not be hit.
Comment 20 Mike Cao 2013-10-09 01:17:48 EDT
Summary 

on win7 hosts 
scsi system disk + scsi cdrom on the same virtio-scsi-pci  ----> BSOD
scsi system disk + ide cdrom   - ---> works fine
IDE disk    + scsi cdrom        ----> works fine
Comment 21 Mike Cao 2013-10-09 01:19:02 EDT
(In reply to Mike Cao from comment #20)
> Summary 
> 
> on win7 hosts 
Sorry I mean with win7 -64 bit guest

> scsi system disk + scsi cdrom on the same virtio-scsi-pci  ----> BSOD
> scsi system disk + ide cdrom   - ---> works fine
> IDE disk    + scsi cdrom        ----> works fine
Comment 22 Mike Cao 2013-10-09 01:58:40 EDT
Tried scsi system disk + scsi cdrom on different virtio-scsi-pci ---> works fine 

Note I only tested one time for all the results in this comment and comment #21
Comment 23 Mike Cao 2013-10-09 02:27:30 EDT
Tried scsi system disk + scsi cdrom on same virtio-scsi-pci with -cpu family=0xe --> BSOD
Comment 24 Mike Cao 2013-10-09 02:31:57 EDT
(In reply to Vadim Rozenfeld from comment #18)
> since image from https://bugzilla.redhat.com/attachment.cgi?id=804907 and  
> http://fileshare.englab.nay.redhat.com/pub/section2/coredump/BZ1013443-
> MEMMORY.DMP are two different crashes, could you please be more specific on
> which BSOD you see? 

As BSOD most occurs during guest installation ,so there is no dump file for most of times(0x0000001e) . While it is happened after we finished installation ,then we upload the dumps .So we trigger the BSOD with different crashes with the same steps 

>Could you please update the crasdump file with the most
> recent one? Does the command line from bug description match crashdump file?
> Does the problem happen buring unattended install only ot it also
> reproducible
> during manual install?

it can be reproduced on manual install
From my testing ,it only happened when we using scsi-cdrom+scsi-hd on the same virtio-scsi-pci

Mike





> 
> Thanks,
> Vadim.
Comment 25 Vadim Rozenfeld 2013-10-09 04:18:41 EDT
(In reply to Mike Cao from comment #24)
> (In reply to Vadim Rozenfeld from comment #18)
> > since image from https://bugzilla.redhat.com/attachment.cgi?id=804907 and  
> > http://fileshare.englab.nay.redhat.com/pub/section2/coredump/BZ1013443-
> > MEMMORY.DMP are two different crashes, could you please be more specific on
> > which BSOD you see? 
> 
> As BSOD most occurs during guest installation ,so there is no dump file for
> most of times(0x0000001e) . While it is happened after we finished
> installation ,then we upload the dumps .So we trigger the BSOD with
> different crashes with the same steps 
> 
> >Could you please update the crasdump file with the most
> > recent one? Does the command line from bug description match crashdump file?
> > Does the problem happen buring unattended install only ot it also
> > reproducible
> > during manual install?
> 
> it can be reproduced on manual install
> From my testing ,it only happened when we using scsi-cdrom+scsi-hd on the
> same virtio-scsi-pci
> 
> Mike
> 
> 
> 
> 
> 
> > 
> > Thanks,
> > Vadim.

Hi Mike,
Many thanks for detailed analysis of the problem.

Ronen, let's move this problem to 6.6 because the 
appropriate  problem dissecting, fix and testing can 
take some time. Especially because the problem doesn't 
happen on all platforms.

Thanks,
Vadim.
Comment 26 Mike Cao 2013-10-09 05:15:05 EDT
I am sorry Vadim , win2k8R2 hit the exactly same issue .What I reported on comment #15 is using IDE cdrom
Comment 27 Vadim Rozenfeld 2013-10-09 05:29:45 EDT
(In reply to Mike Cao from comment #26)
> I am sorry Vadim , win2k8R2 hit the exactly same issue .What I reported on
> comment #15 is using IDE cdrom

Thanks Mike,
Now it seems less weird than before, 
Could you pleas try reproducing the problem on 32-bit
platforms?

Best regards,
Vadim.
Comment 28 Mike Cao 2013-10-09 06:14:31 EDT
(In reply to Vadim Rozenfeld from comment #27)
> (In reply to Mike Cao from comment #26)
> > I am sorry Vadim , win2k8R2 hit the exactly same issue .What I reported on
> > comment #15 is using IDE cdrom
> 
> Thanks Mike,
> Now it seems less weird than before, 
> Could you pleas try reproducing the problem on 32-bit
> platforms?
Following the results is about starting VM with scsi cdrom and scsi hd at the same virtio-scsi-pci

win7-32,win2k8-32,win2k8-64  can not reproduce 
win7-64,win2k8R2 ---> BSOD

QE will try win8 and win2012 tomorrow 


> 
> Best regards,
> Vadim.
Comment 29 lijin 2013-10-09 23:06:11 EDT
(In reply to Mike Cao from comment #28)
> (In reply to Vadim Rozenfeld from comment #27)
> > (In reply to Mike Cao from comment #26)
> > > I am sorry Vadim , win2k8R2 hit the exactly same issue .What I reported on
> > > comment #15 is using IDE cdrom
> > 
> > Thanks Mike,
> > Now it seems less weird than before, 
> > Could you pleas try reproducing the problem on 32-bit
> > platforms?
> Following the results is about starting VM with scsi cdrom and scsi hd at
> the same virtio-scsi-pci
> 
> win7-32,win2k8-32,win2k8-64  can not reproduce 
> win7-64,win2k8R2 ---> BSOD
> 
> QE will try win8 and win2012 tomorrow 
> 
> 
> > 
> > Best regards,
> > Vadim.

win8-64 and win2012 can reproduce this issue as well;
win8-32 guest can be installed without any error.
Comment 30 lijin 2013-10-10 01:25:46 EDT
retest win8-64 with scsi system disk + scsi cdrom on different virtio-scsi-pci,guest can be installed correctly.
Comment 31 Mike Cao 2013-10-12 06:59:39 EDT
*** Bug 996951 has been marked as a duplicate of this bug. ***
Comment 32 lijin 2013-11-14 22:33:47 EST
Reproduced this issue on virtio-win-prewhql-72;
Verified this issue on virtio-win-prewhql-73 with win7-64 guest.

steps same as comment #0

Actual Results:
on virtio-win-prewhql-72,guest bsod with D1 code during installation;
on virtio-win-prewhql-73,guest can finish installation correctly,no BSOD.

Based on above ,this issue has been fixed already .
Comment 33 Mike Cao 2013-11-14 22:59:16 EST
Move status to VERIFIED according to comment #32
Comment 36 errata-xmlrpc 2014-10-14 04:20:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1592.html

Note You need to log in before you can comment on or make changes to this bug.