Bug 996951 - vioscsi.sys: DRIVER_IRQL_NOT_LESS_OR_EQUAL bsod code: 0xd1
vioscsi.sys: DRIVER_IRQL_NOT_LESS_OR_EQUAL bsod code: 0xd1
Status: CLOSED DUPLICATE of bug 1013443
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Reopened, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 06:58 EDT by Xiaoqing Wei
Modified: 2013-10-12 06:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-12 06:59:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot (36.32 KB, image/jpeg)
2013-08-14 06:58 EDT, Xiaoqing Wei
no flags Details
storport.sys : same 0xd1 (11.34 KB, image/png)
2013-10-09 07:43 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2013-08-14 06:58:03 EDT
Created attachment 786497 [details]
snapshot

Description of problem:
vioscsi.sys: DRIVER_IRQL_NOT_LESS_OR_EQUAL bsod code: 0xd1 

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-67.iso
kernel-3.10.0-9.el7.x86_64
qemu-kvm-1.5.2-3.el7.x86_64

How reproducible:
1/1

Steps to Reproduce:
1. install a Win7.x86_64 guest:
root/staf-kvm-devel/autotest-devel/client/tests/virt/qemu/qemu \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20130814-181003-7RtEtoyD,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130814-181003-7RtEtoyD,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20130814-181003-7RtEtoyD,path=/tmp/seabios-20130814-181003-7RtEtoyD,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20130814-181003-7RtEtoyD,iobase=0x402 \
    -device nec-usb-xhci,id=usb1,bus=pci.0,addr=0x4 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,addr=0x5 \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win7-64-virtio.qcow2',if=none,id=virtio-scsi0-id0,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device scsi-hd,drive=virtio-scsi0-id0 \
    -device virtio-net-pci,netdev=idJ0tX54,mac='9a:27:28:29:2a:2b',bus=pci.0,addr=0x3,id='idhX45Sv' \
    -netdev tap,id=idJ0tX54,vhost=on,fd=22 \
    -m 4096 \
    -smp 4,maxcpus=4,cores=2,threads=1,sockets=2 \
    -cpu 'SandyBridge',hv_relaxed \
    -M pc-i440fx-rhel7.0.0 \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/ISO/Windows7/en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso',if=none,id=virtio-scsi1-id1,media=cdrom,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi1-id1 \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso',if=none,id=virtio-scsi2-id2,media=cdrom,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi2-id2 \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/virtio-win.latest_prewhql.iso',if=none,id=virtio-scsi3-id3,media=cdrom,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi3-id3 \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win7-64/answer.vfd',if=none,id=fdc0-0-0,media=disk,readonly=off,format=raw \
    -global isa-fdc.driveA=fdc0-0-0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -spice port=3000,password=123456,addr=0,tls-port=3200,x509-dir=/tmp/spice_x509d,tls-channel=main,tls-channel=inputs,image-compression=auto_glz,zlib-glz-wan-compression=auto,streaming-video=all,agent-mouse=on,playback-compression=on,ipv4 \
    -vga qxl \
    -global qxl-vga.vram_size=33554432 \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off  \
    -enable-kvm

2.
3.

Actual results:
guest BSOD after prompting reboot

Expected results:
guest installation finished

Additional info:

os mem dumpping didn't functional yet, as it's still in the early stage of installation.
Comment 2 Xiaoqing Wei 2013-08-14 07:33:15 EDT
Tested on RHEL.6.5 7.0 host, both reproducible,
Setting urgent/urgent
Comment 3 Mike Cao 2013-08-14 07:44:06 EDT
I think this bug is dup of https://bugzilla.redhat.com/show_bug.cgi?id=994377
Comment 6 Xiaoqing Wei 2013-08-28 11:10:35 EDT
This blocks virtio-scsi installation, Adding keyword
Comment 8 Vadim Rozenfeld 2013-08-31 03:39:23 EDT

*** This bug has been marked as a duplicate of bug 1001616 ***
Comment 9 Xiaoqing Wei 2013-10-09 06:10:27 EDT
Met on -72 prewhql virtio-win, so it's not dup'ed,
re-opening, still cant get a dump
Comment 10 Xiaoqing Wei 2013-10-09 07:43:40 EDT
Created attachment 809861 [details]
storport.sys : same 0xd1
Comment 11 Mike Cao 2013-10-12 06:59:39 EDT

*** This bug has been marked as a duplicate of bug 1013443 ***

Note You need to log in before you can comment on or make changes to this bug.