Bug 1013491 - oVirt+Neutron: IP lost when shutting down the instance
Summary: oVirt+Neutron: IP lost when shutting down the instance
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.3.1
Assignee: Mike Kolesnik
QA Contact:
URL:
Whiteboard: network
Keywords:
: 1016457 (view as bug list)
Depends On:
Blocks: 1018740 1019391
TreeView+ depends on / blocked
 
Reported: 2013-09-30 08:17 UTC by Riccardo Brunetti
Modified: 2013-11-25 11:56 UTC (History)
5 users (show)

(edit)
Clone Of:
: 1018740 (view as bug list)
(edit)
Last Closed: 2013-11-25 11:56:39 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19966 None None None Never
oVirt gerrit 20138 None None None Never

Description Riccardo Brunetti 2013-09-30 08:17:57 UTC
Description of problem:
When using OpenStack Neutron as external network provider in oVirt-3.3, the association port/internal-IP/floating-IP is lost when the VM is shut down.

Version-Release number of selected component (if applicable):
oVirt-3.3

How reproducible:
Always

Steps to Reproduce:
1. Define an OpenStack Neutron network external provider and import a network. 
2. Start a VM in oVirt using that network in one of the NIC interface and let the NIC to have an IP using DHCP (provided by Neutron itself).
3. Possibly associate a floating-IP to the instance.
4. Shut down (not delete) the machine (from inside the VM or from the oVirt WEB-UI)
5. Start the instance again.

Actual results:
The instance looses the previously attached IP addresses (port/internal-IP change) and the public floating-IP must be manually re-associated.


Expected results:
The instance should keep the previous port and IP leases.


Additional info:

Comment 1 Mike Kolesnik 2013-10-09 05:37:24 UTC
*** Bug 1016457 has been marked as a duplicate of this bug. ***

Comment 2 Mike Kolesnik 2013-10-09 05:42:13 UTC
The port was deleted on VM stop.

The new behavior that is going to be is documented on the feature page:
http://www.ovirt.org/Features/Detailed_OSN_Integration#Integration_with_virtual_NIC_lifecycle

Extract:
"The port will be deleted in these cases:

     The virtual NIC is deleted from the VM.
     The virtual VNIC profile is changed, so that it is no longer
connected to
the external network.
     The VM is deleted.
     The data center containing the external networks is deleted forcefully.
     Snapshot operations (Preview, Undo) on the VM. "

Comment 3 Sandro Bonazzola 2013-11-25 11:56:39 UTC
oVirt 3.3.1 has been released


Note You need to log in before you can comment on or make changes to this bug.