Bug 1013597 - The about pop up (Help->Product->About) does not display JBoss logo image.
The about pop up (Help->Product->About) does not display JBoss logo image.
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Productization (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity medium
: ER05
: JON 3.2.0
Assigned To: John Mazzitelli
Mike Foley
:
: 1016593 (view as bug list)
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-09-30 08:22 EDT by Sunil Kondkar
Modified: 2014-01-02 15:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:37:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (17.42 KB, image/png)
2013-09-30 08:23 EDT, Sunil Kondkar
no flags Details
Screenshot_latest (14.51 KB, image/png)
2013-11-07 06:54 EST, Sunil Kondkar
no flags Details

  None (edit)
Description Sunil Kondkar 2013-09-30 08:22:59 EDT
Description of problem:

The Help->Product->About pop up screen does not display JBoss logo image. The URL 'http://<IP>:7080/images/jboss_logo.png' returns 'HTTP Status 404'.

Please refer the attached screenshot.

Version-Release number of selected component (if applicable):

JBoss ON Version: 3.2.0.ER2 Build Number: 9bf6f76:371eac0
Browser: Firefox 10.0.2

How reproducible:

Always

Steps to Reproduce:

1. Login to JBoss ON
2. Navigate to Help menu
3. Click on 'About' link in 'Product' section.
4. Observe that the box display link 'jboss by Red Hat' but does not display the jboss logo image.


Actual results:

The about pop up (Help->Product->About) does not display JBoss logo image.

Expected results:

The about pop up (Help->Product->About) should display JBoss logo image.

Additional info:
Comment 1 Sunil Kondkar 2013-09-30 08:23:30 EDT
Created attachment 805171 [details]
Screenshot
Comment 2 Jeeva Kandasamy 2013-10-08 07:35:09 EDT
*** Bug 1016593 has been marked as a duplicate of this bug. ***
Comment 3 John Mazzitelli 2013-10-17 11:40:34 EDT
i'm gonna take this and fix that about box... i never did like it (i looks like a dialog box, but its fixed in an odd, offset position).
Comment 4 John Mazzitelli 2013-10-17 17:30:32 EDT
git commit to master : b5aab90

about box is cleaned up. Has only one branded logo now at the top and the rest of the information is cleanly presented in a form..
Comment 5 John Mazzitelli 2013-10-18 08:55:01 EDT
I had to commit another change to master: d563712 because eclipse screwed up the japanese translations of Messages_ja.properties that I had to fix.
Comment 6 John Mazzitelli 2013-10-24 16:33:01 EDT
git commits to release/jon3.2.x branch:

941c86d8d3eb274fd01e852bd3948b2eb74bc0a1
13869f25a6a25f581d41e00ba4d4b8ede438bc3f
Comment 7 John Mazzitelli 2013-10-29 12:25:44 EDT
shows the word "Link" rather than the actual url in the about box because some product URLs might be too long to show

master commit: 9af55b8 
release/jon3.2.x commit: b6adc79
Comment 8 Simeon Pinder 2013-11-06 21:17:18 EST
Moving to ON_QA for test with new brew build.
Comment 9 Sunil Kondkar 2013-11-07 06:53:06 EST
Verified on Version : 3.2.0.ER5 Build Number : 2cb2bc9:225c796
Please refer the screenshot.
Comment 10 Sunil Kondkar 2013-11-07 06:54:10 EST
Created attachment 821037 [details]
Screenshot_latest

Note You need to log in before you can comment on or make changes to this bug.