Bug 1013646 - hwcert-backend submit tracebacks
hwcert-backend submit tracebacks
Status: CLOSED DUPLICATE of bug 1013865
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
Depends On: 1013159
  Show dependency treegraph
Reported: 2013-09-30 09:58 EDT by Greg Nichols
Modified: 2013-11-20 15:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1013159
Last Closed: 2013-09-30 20:55:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2013-09-30 09:58:59 EDT
+++ This bug was initially created as a clone of Bug #1013159 +++

Description of problem:

This might be related to the specific set of results I happen to have on this box but, when I run hwcert-backend submit I get...

    16 -> localhost 07-19-2013 at: 22:37 Cert ID: 886899 
         passed: memory, core  failed: suspend, info 

Arch: x86_64  OS: RHEL 6.4:

    17 -> localhost 07-15-2013 at: 20:21  
         failed: suspend, audio, info 
    18 -> localhost 07-15-2013 at: 20:43  
         failed: suspend, audio, info 
Traceback (most recent call last):
  File "/usr/bin/hwcert-backend", line 45, in <module>
    success = hwcertBackend.do(args)
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 183, in do
    result = self.commands[self.command]()
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 332, in doSubmit
    (files, selection) = self.__selectFromStore("submitting to %s" % self.catalog.getCatalogServer())
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 342, in __selectFromStore
    resultsFiles = self.__showSaved(selection, summary)
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 381, in __showSaved
    systemHeader =  "\n Arch: %s  OS: %s %s:\n" % (infoWords[4], infoWords[5], infoWords[6])
IndexError: list index out of range

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.run hwcert-backend submit

Actual results:

Expected results:

Additional info:

--- Additional comment from Greg Nichols on 2013-09-30 09:20:16 EDT ---

What do the directories /var/hwcert/store and /var/www/hwcert/store look like?  could you tar them and attach them?

--- Additional comment from Greg Nichols on 2013-09-30 09:35:52 EDT ---

--- Additional comment from Greg Nichols on 2013-09-30 09:37:06 EDT ---

The above patch should fix the traceback.   The open issue is how the store directories on you system became unparseable.

--- Additional comment from Greg Nichols on 2013-09-30 09:56:43 EDT ---

Patch committed to R17
Comment 1 Greg Nichols 2013-09-30 20:55:31 EDT

*** This bug has been marked as a duplicate of bug 1013865 ***

Note You need to log in before you can comment on or make changes to this bug.